LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Eliminating Sticky Notes on My kde4 Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/eliminating-sticky-notes-on-my-kde4-desktop-849713/)

josephj 12-11-2010 11:43 PM

Eliminating Sticky Notes on My kde4 Desktop
 
I'm running kubuntu karmic (kde 4.3.5) on my x86 notebook.

I have a temperamental touchpad to start with. So, when I'm trying to click on the kmenu button, etc. in my taskbar and I hit the wrong spot on my touchpad and a cute, but totally unwanted little yellow note appears in the taskbar, I'm not happy. The same thing, only larger, happens on my desktop.

It seems like this happens somewhere on the left side of my touchpad.

There are two issues here.

1) I want my mouse to be a blinking mouse! I don't want it to do anything else except move the mouse cursor and let me do left- and right-clicks.

I have a Synaptics touchpad and I have configured it to turn off all the scrolling areas and hot spots using gsynaptics.

Even with everything I can find turned off, it still does the sticky notes and, in text fields, it often inserts text from the clipboard when I'm just trying to get the text cursor to a new position.

2) "Notes, we don't need no stinkin' sticky notes!"

How do I get rid of this notes feature permanently?

How do I get my touchpad to stop trying to do anything but basic mouse functions?

The darn notes have properties, but there's no "help" or "about" to identify what program they come from. I also looked through ps -ef and I don't see anything obvious that looks like a notes application.

I had knotes installed, but I wasn't using it and uninstalled it. This didn't make the sticky notes feature go away.

I'm sufficiently annoyed that I'm going to try xkill next, but I'm going to send this first in case it takes out my entire desktop and I have to reboot.

I don't believe I ever saw this problem before karmic/kde4.

TIA

Joe

mlangdn 12-12-2010 07:31 AM

That notes feature is called a widget. If its on the taskbar, just right-click it and select "remove this " from the options.

Latios 12-12-2010 09:25 AM

When you click the scroll wheel it does paste the clipboard contents. When doing this on plasma it pastes with a note widget

In newer kde4 you can cancel it - go to the plasma icon in the corner of the desktop - settings - mouse actions. I dont know if the setting existed in 4.3.5

josephj 12-13-2010 03:16 PM

Thanks.
@mlangdn If I understand you correctly, that's how to delete the note itself. I was already doing that. If that didn't work, I would probably have abandoned kde. There is no widget for these notes anywhere on my desktop.

@Latios I have a touchpad, so I don't have a "real" mouse wheel. I'll go into gsynaptics and see if there's anything to adjust there. If not, I'll go to the next layer down and look there now that you've told me what to look for.

mlangdn 12-13-2010 07:03 PM

The last time I had a problem with widgets, I nuked ~/.kde and started over. That means resetting the desktop to whatever you had before. That's a bit drastic, and it does take a bit of time, but it works. However, that's just me - impatient at times and tired of looking for a proper answer. :)

josephj 12-14-2010 03:36 PM

Good idea, but a less extreme alternative
 
Not a bad idea to see if it helps. The trick is to make a backup of it first so I can restore it after seeing if it helps.

I just took a look in there. There's a ton of stuff - and quite a few that look like things I've customized.

So, nuking it would be worse than the problem.

I'll still try it to see if it fixes the problem, but I'll definitely put it back afterward.

If it does fix the problem, then I'll go back in and nuke/restore it bit by bit until I find the piece that's responsible.

That will also take a lot of time, but it will preserve all my customizations.


All times are GMT -5. The time now is 04:45 PM.