LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Dual Boot Win 8 Ubuntu on two different drives (http://www.linuxquestions.org/questions/linux-desktop-74/dual-boot-win-8-ubuntu-on-two-different-drives-4175464185/)

loftus49 05-31-2013 12:01 AM

Dual Boot Win 8 Ubuntu on two different drives
 
This should be simple but I can't find a simple answer.

I just built a new pc and installed Win 8 on one drive (primary) and Ubuntu 12.10 on another drive.

How do I create a (Grub or other) selection of which OS to go to at boot time (e.g. a simple menu).

Win 8 works fine on it's drive and Ubuntu 12.10 works fine on it's drive as is.

GlennsPref 05-31-2013 04:24 AM

I set mine up the same way.

What I do, is have win on the 1st drive and linux / (and /boot) on the second.

After installing windows, then I install linux and install the boot loader to the windows drive.

Now, Ubuntu uses grub2 and the process is different from grub(legacy).

This thread may help you...Update Grub

Hope this helps, Glenn

loftus49 05-31-2013 02:42 PM

2 Drive Boot
 
Quote:

Originally Posted by GlennsPref (Post 4962646)
I set mine up the same way.

What I do, is have win on the 1st drive and linux / (and /boot) on the second.

After installing windows, then I install linux and install the boot loader to the windows drive.

Now, Ubuntu uses grub2 and the process is different from grub(legacy).

This thread may help you...Update Grub

Hope this helps, Glenn


Many thanks for the reply. I think I understand. At the moment though I can't access the 2nd drive with Ubuntu on it. I had loaded Ubuntu 12.10 on it before having to build a new pc. The 1st drive has been loaded with Win8 and seems to work ok. But while I can see the 2nd drive in BIOS, it won't boot. I guess I'll have to double check the connections and see if I can reload Ubuntu on it from the web. Then I can do the grub-mkconfig I suppose.

However, if you have any suggestions/guidance along the way, it is always appreciated.

Duane

jefro 05-31-2013 04:04 PM

I usually don't try to dual boot that way. I just select the hard drive order with a hot key at boot time. That should allow you to keep each drive a single OS drive.

You can either fool with windows to allow dual boot option at boot or you can fool with linux loader to get both choices as an option.

GlennsPref 05-31-2013 08:01 PM

Quote:

But while I can see the 2nd drive in BIOS, it won't boot.
To be sure, to be sure... I used to disconnect the first drive and then install linux,,

That way there can be no confusion of which bootable disk, for grub?

Plug the windows drive back into the system and boot like you said, use the bios to select the OS to boot.

Linux stays fairly hidden to the casual onlooker, most notice the grub boot screen, you might get called a hacker, lol.

loftus49 06-01-2013 10:41 AM

Hot key?
 
Quote:

Originally Posted by jefro (Post 4963020)
I usually don't try to dual boot that way. I just select the hard drive order with a hot key at boot time. That should allow you to keep each drive a single OS drive.

You can either fool with windows to allow dual boot option at boot or you can fool with linux loader to get both choices as an option.

Thanks for the reply. I guess Alzheimer's is really advancing in me. What do you mean by selecting the hard drive order at boot time with a hot key?

Duane

jefro 06-01-2013 01:15 PM

Almost every computer made in the last 8 years has a way to select the boot media with some F key while booting from cold power off. Almost every computer made in the last 15 years can choose the boot order in bios.

What I am suggesting is that you fool the system sort of. Use bios to select which drive is considered the first bootable device. Since you say primary I assume IDE but I'd suspect more like sata channel.

What I do sometimes is to even go so far as to remove power from one drive. Set bios to show that drive as first boot order. Then load and OS. Do the same for the other OS so that both drives now contain an OS that the computer thinks is a first boot order. Neither drive has any knowledge of the other's OS. No grub or bcd issue to affect either.

Now that you have to clean OS installs, you can either permanently choose the boot media in bios order or select at boot time the choice with a F key option. Generally the F key is F9 or F12 or F10 but see your documentation. I do this also to boot to usb flash drives.

I started to do this a very long time ago with odd OS's. I continued it when issues like lilo and grub and later grub1 grub2. When I want to change the computer it is just a matter of one drive and not trying to fix a loader issue.

loftus49 06-02-2013 01:49 AM

Wow
 
jefro - wow that sounds wonderful. I'm trying it when I get home Monday. Thank you. Also, thank you GlennsPref.

Duane

cascade9 06-02-2013 06:23 AM

Quote:

Originally Posted by loftus49 (Post 4962975)
Many thanks for the reply. I think I understand. At the moment though I can't access the 2nd drive with Ubuntu on it. I had loaded Ubuntu 12.10 on it before having to build a new pc. The 1st drive has been loaded with Win8 and seems to work ok. But while I can see the 2nd drive in BIOS, it won't boot. I guess I'll have to double check the connections and see if I can reload Ubuntu on it from the web.

Win8 computer, so it probably has 'secure boot'. If you turn off secure boot in the BIOS/UEFI it should boot.

Personally, I prefer to have windows bootloader on the windows drive, linux bootloader on the linux drive. That way you're got the standard windows bootloader on its own drive, if you remove the linux drive is like it was a 'clean' windows install. Setting the system to boot from the linux drive should let you choose to boot linux or windows.

Sure, you can normally select what drive to boot with some Fkey, but the timing can be a pain, and then you've got to select the drive, etc.. More fiddly and longer than doing it other ways IMO.

loftus49 06-02-2013 06:41 PM

Best laid plans of mice and men ...

I guess it's never simple.

The PC won't boot off my 2nd drive (Linux Unbuntu 12.10). With whatever method I use .. disconnecting drives, trying to force the bios, turning off secure boot ... I merely get a flashing curser in the top left of the screen and it does nothing.

I can see the second drive in BIOS but it does not appear anywhere while in Windows (file manager) except in the device manager. I'm down to trying to wipe out the drive and reformat, then load on the Ubuntu - but I cannot find a way to access the drive and reformat it. This is true even when all other devices are disconnected and it is the only one connected.

I understand that hard drives make good candidates for target practice!

Suggestions?

And thanks.

GlennsPref 06-02-2013 08:01 PM

Not to disagree, but when I turn on/off the drives for install, I just unplug the power cable.

I don't change anything else.

That being said, all of my drives have been marked as active/bootable during the last partitioning and formats.

I suggest, Restart your best laid plans...

powerdown the pc.
disconnect the windows hdd.
boot the pc with the ubuntu dvd (if that fails, check the bios for your hdd).
repartition the drive, to get at least....

a swap, / and /home partitions,

(a fresh install usually requires the formatting of /(root) and /usr directories(and the partition they are on)

personally I go further and create /usr /var /boot /tmp /usr/local as well.

gparted is a good hdd program (live cd). But you can usually do it with the installer.

Be sure to mark the first partition of the drive as "active" for the bios.

install and reboot to check.....

refit win drive when ready.

TobiSGD 06-02-2013 08:07 PM

Quote:

Originally Posted by loftus49 (Post 4964249)
I can see the second drive in BIOS but it does not appear anywhere while in Windows (file manager) except in the device manager.

This is totally normal. Windows can't read Linux file-systems and therefore doesn't show those partitions in the file-manager. Usually at this point I would just boot from a live-CD, chroot into the installed Linux system and re-install the bootloader, to see if that works. If you want to reinstall Ubuntu just use the Windows partition manager to remove the Linux partitions, then do the install.

loftus49 06-03-2013 03:25 AM

Good news and not so good news.

First, I got it to boot on the 2nd drive (thank you GlennsPref and TobiSGD) by loading down an ISO to disk then booting from the disk (unplugging the Win drive), then installing the 12.10 to the drive. It seemed ok and I rebooted again to check it. But now, I am getting errors saying that it is booting in low graphics mode, etc. It's possible that I have errors on my ISO (should have check MD5Sum).

It's late here. I'll go back at it again tomorrow.

Again, thank you all for your help.

Duane

TobiSGD 06-03-2013 07:51 AM

Low graphics mode usually comes up when your video card is not supported by the free drivers, so that the system has to fall back to the Vesa drivers. Which videocard are you using? If it is an AMD or Nvidia I would try the proprietary drivers.

loftus49 06-03-2013 03:34 PM

Pushing the peanut forward!

I suspected a bad ISO on Ubuntu 12.10 so I loaded down and burned a copy of 13.04. I disconnected the WIN drive and booted to the 13.04 disk. I installed 13.04 replacing anything on the drive. I rebooted several times. I then reconnected the Win drive and rebooted. At first the Ubuntu drive displayed errors but after subsequent boots, it worked. I then rebooted and changed to the Win drive in BIOS.

I now have two drives (Ubuntu 13.04 and Win8) that can be booted to by changing the boot order in BIOS.

YEA!

YOU all did it and I thank you.

Now ... if there were a simple little menu that would pop up when you powered on and asked, " Ubuntu or Windows " that would be the ideal solution. But for the meantime, I'm a happy camper.

Duane


All times are GMT -5. The time now is 10:58 AM.