LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-22-2011, 12:23 PM   #1
Hannes
LQ Newbie
 
Registered: Sep 2003
Location: Berlin, Germany
Distribution: OpenSuse 11.4
Posts: 4

Rep: Reputation: 0
du -hs .* does not show size of directories starting with a dot (anymore)


Hey, maybe I have changed some basic setting, but the 'du' program acts weird suddenly. My BASH console output is:

Code:
hannes@livingroom:~/zzausgelagert/weka$ echo .*
. .. .cachedir .classpath .project .pydevproject .settings
Code:
hannes@livingroom:~/zzausgelagert/weka$ du -hs .*
76M	.
369M	..
Weird, this command worked in OpenSuse 11.3 (I recently switched to 11.4). Where are my hidden directories? Now I can only display them this way:

Code:
hannes@livingroom:~/zzausgelagert/weka$ du -hs .[^.]*
12K	.cachedir
4.0K	.classpath
4.0K	.project
4.0K	.pydevproject
12K	.settings
hannes@livingroom:~/zzausgelagert/weka$ du --version
du (GNU coreutils) 8.9

OpenSUSE 11.4, Kernel 2.6.37.1-1.2, Gnome 2.32.1
 
Old 03-22-2011, 12:30 PM   #2
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Have you checked the output of "alias?" One time I had something similar, and I accidentally created an alias.
 
Old 03-22-2011, 12:34 PM   #3
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,154
Blog Entries: 1

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
Code:
du -ha --max-depth=1
 
  


Reply

Tags
coreutils, disk usage, du


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dedicated server problem - HTML page doesn't show anymore prasepretep Linux - Server 1 02-14-2008 02:01 PM
showmount -a shows directories that aren't there anymore toloughlin Linux - Server 0 07-26-2007 03:51 PM
GRUB not loading / boot.ini file does not show Linux anymore jeetasher Linux - Laptop and Netbook 14 10-23-2005 06:50 PM
Why doesn't a wildcard chmod change "dot" files/directories? jht2k Linux - General 1 08-09-2004 02:31 PM
dual boot system doesn't show anymore kyttycat Linux - General 4 04-13-2004 04:37 AM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration