LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 12-18-2009, 07:29 AM   #1
danson
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Rep: Reputation: 0
Dolphin file manager: possible to change "rename" behaviour?


I'm having a small problem with Dolphin (v:1.3; KDE 4.3.1), which I can't seem to find the answer to.

When choosing to rename a file, I'd like the file's original name to remain there, ready to be edited (as was the case in Konqueror), rather than it disappearing completely. In Dolphin, when choosing to rename (via right-click menu, or by pressing F2), the file's previous name disappears completely. Because of this, even if I only want to change, say one or two characters, I end up having to retype the entire filename. Does anyone know how to change this behaviour?

Thanks in advance for any help.
 
Old 12-18-2009, 07:37 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Quote:
When choosing to rename a file, I'd like the file's original name to remain there, ready to be edited
That's how it works here (KDE 4.3.2)
 
Old 12-18-2009, 07:47 AM   #3
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
I am also using dolphin. But i am using KDE 3.5.

In my dolphin ...if i press f2 then a new prompting windows opens. there already existing name is selected. and it is ready for new name. see the image attached.
Attached Images
File Type: jpg dolphin.jpg (6.3 KB, 5 views)
 
Old 12-18-2009, 07:49 AM   #4
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
I think , your KDE version making it different with others.
 
Old 12-18-2009, 08:11 AM   #5
danson
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks to the both of you for the quick replies. How odd that it works differently for you. Perhaps it is related to my particular combination of versions, as you say. I've had a look through the Dolphin documentation and searched through various sources, but to no avail, which may suggest this is some kind of "quirk". The only vaguely related information I found in the Dolphin documentation was the facility to switch to "inline" renaming; this however, produces the same results.

This is the first time I've used Dolphin, but previously, in all the time I used Konqueror it worked in the "edit" way (as per your screenshot), rather than the "delete" way I'm experiencing now. I'm at a bit of a loss on this, really - it's a relatively small issue, but quite annoying. Oh well.

Last edited by danson; 12-18-2009 at 08:13 AM.
 
Old 12-18-2009, 08:34 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,286

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Suse 11.2 .. Dolphin.

Right click on a file → select 'Copy'

Next : Right click on "an empty place"
> > 'Paste One File' .. and write a new file name
in the 'Pop up dialog window'.

That would be the result you want, isnt it ?
.....

Of course the command line is easier ? : cp file1 file123 .
.....
 
Old 12-19-2009, 12:31 AM   #7
danson
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by knudfl View Post
Right click on a file → select 'Copy'

Next : Right click on "an empty place"
> > 'Paste One File' .. and write a new file name
in the 'Pop up dialog window'.
Thanks for the idea, but it produces the same result (empty text box). In any case, with other people experiencing different behaviour to me, I thought this might be a bug, so looked it up on the KDE Bugzilla and it had indeed been reported and appears to be being addressed. It seems it's related to having SCIM installed. I need to use SCIM, so will just switch back to Konqueror for my file manager until the bug is fixed. Thanks again.
 
  


Reply

Tags
dolphin


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hostname defined in file "network" changes after change to file "hosts" qwkfish Linux - Networking 2 10-14-2009 05:07 PM
How do i change the default file manager from nautilus to e.g. dolphin emuub Linux - Software 12 10-04-2009 01:43 PM
GnuPG "File encrypt" option appears in dolphin and Konquorer but not in nautilus emuub Fedora 1 12-06-2008 11:55 AM
Change behaviour of "Sleep" button on laptop under Fedora 7 cdhgee Linux - Laptop and Netbook 1 09-24-2007 04:02 PM
rename file with "mv" not working for folder? Niceman2005 Linux - Newbie 2 03-13-2005 10:34 PM


All times are GMT -5. The time now is 10:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration