LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Disabling Touchpad while typing. (http://www.linuxquestions.org/questions/linux-desktop-74/disabling-touchpad-while-typing-615709/)

nardz 01-23-2008 07:44 AM

Disabling Touchpad while typing.
 
I've figured out how to do it thanks to this howto:

http://www.debuntu.org/2006/06/25/70...d-while-typing

but the only thing i cant figure out is how to make it work automatically.

i had no~/.xinitrc, and i copied one from the etc/x11 folder as instructed by another tutorial i found on google, and added in the line syndaemon -i 1.0 -t but it seams to be innefective.

wat am i doing wrong?

tredegar 01-23-2008 10:42 AM

Try putting that command at the end of the file /home/nardz/.bashrc
Logout, login, is it working?

And the link you gave said that if you want to start syndaemon automatically when you login you should make sure that the -d switch is turn on. -d stands for daemon and will make syndaemon start in the background.

nardz 01-23-2008 07:10 PM

Quote:

Originally Posted by tredegar (Post 3032612)
Try putting that command at the end of the file /home/nardz/.bashrc
Logout, login, is it working?

And the link you gave said that if you want to start syndaemon automatically when you login you should make sure that the -d switch is turn on. -d stands for daemon and will make syndaemon start in the background.

thanks. i dont know how i missed the -d, however it didnt fix the problem.

and i have also tried your other suggestion in /bashrc, and still no luck

atm the only way i can get it to work is by running it from alt-f2

tredegar 01-24-2008 05:28 AM

Quote:

i have also tried your other suggestion in /bashrc, and still no luck
It's not /bashrc it's /home/nardz/.bashrc
Notice the "."

You could also try making a script:

Code:

#!/bin/bash
syndaemon -d -i 1.0 -t

Make it executable:
chmod +x scriptname

And move it to the /home/nardx/.kde/Autostart/ directory

nardz 01-24-2008 05:33 AM

Quote:

Originally Posted by tredegar (Post 3033541)
It's not /bashrc it's /home/nardz/.bashrc
Notice the "."

yeah i know, sorry i just left out the . when repeating it in this forum.


Quote:


You could also try making a script:

Code:

#!/bin/bash
syndaemon -d -i 1.0 -t

Make it executable:
chmod +x scriptname

And move it to the /home/nardx/.kde/Autostart/ directory
i will try that thanks.

I also have a feeling that the issue has something to do with another issue im having

http://www.linuxquestions.org/questi...isible-611465/


All times are GMT -5. The time now is 08:32 AM.