LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Debian XFCE stand-by stopped working (http://www.linuxquestions.org/questions/linux-desktop-74/debian-xfce-stand-by-stopped-working-942234/)

Weapon S 04-28-2012 03:59 AM

Debian XFCE stand-by stopped working
 
My system is Debian satble with XFCE 4.6, and stand-by stopped working. It uses HAL.
I have no idea why. The only thing I can think of is a new graphics card I have installed. But IIRC the PC has been on stand-by since then.
Is there any way to get some more verbose output (of XFCE)?
What command is run in XFCE to go on stand-by? (I'd like to try it separately.)
hal-device says:
Code:

[...]
10: udi = '/org/freedesktop/Hal/devices/computer'
  info.interfaces = { 'org.freedesktop.Hal.Device.SystemPowerManagement' } (string list)
  power_management.type = 'acpi'  (string)
  [...]
  power_management.quirk.dpms_suspend = true  (bool)
  [...]
  power_management.can_suspend = false  (bool)
  power_management.can_suspend_hybrid = false  (bool)
  power_management.can_hibernate = true  (bool)
  system.hardware.primary_video.vendor = 4318  (0x10de)  (int)
  system.hardware.primary_video.product = 2592  (0xa20)  (int)
  system.hardware.serial = 'To Be Filled By O.E.M.'  (string)
  [...]
  org.freedesktop.Hal.Device.SystemPowerManagement.method_execpaths = { 'hal-system-power-suspend', 'hal-system-power-suspend-hybrid', 'hal-system-power-hibernate', 'hal-system-power-shutdown', 'hal-system-power-reboot', 'hal-system-power-set-power-save' } (string list)
  power_management.is_powersave_set = false  (bool)
  info.callouts.add = { 'hal-storage-cleanup-all-mountpoints' } (string list)
  power_management.quirk.vga_mode_3 = true  (bool)
  info.addons = { 'hald-addon-cpufreq', 'hald-addon-acpi' } (string list)
  org.freedesktop.Hal.Device.SystemPowerManagement.method_names = { 'Suspend', 'SuspendHybrid', 'Hibernate', 'Shutdown', 'Reboot', 'SetPowerSave' } (string list)
  org.freedesktop.Hal.Device.SystemPowerManagement.method_signatures = { 'i', 'i', '', '', '', 'b' } (string list)
  org.freedesktop.Hal.Device.SystemPowerManagement.method_argnames = { 'num_seconds_to_sleep', 'num_seconds_to_sleep', '', '', '', 'enable_power_save' } (string list)

Weird. Is there a way to automatically update this file?
Now I tried dpkg reconfigure hal-info. Didn't work.
It turned out I had the BIOS setting disabled. WTH :P hal-device computer, showed properly. STR worked properly.

MensaWater 04-30-2012 07:46 AM

Thanks for posting your solution.


All times are GMT -5. The time now is 01:09 PM.