LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 08-13-2010, 06:14 AM   #1
DaRkBoDoM
Member
 
Registered: Oct 2007
Location: Italy
Distribution: Debian
Posts: 72

Rep: Reputation: 17
Ctrl+alt+backspace


Hi there.

Some wise guy at ubuntu decided that CTRL+ALT+BACKSPACE sequence should now be disabled by default.

I'm desperately trying to get it work again, with no success.

I've added:

Code:
Section "ServerFlags"
        Option          "DontZap" "off"
        Option          "HandleSpecialKeys" "Always"
EndSection
to my xorg.conf (full xorg.conf: http://pastebin.com/QM7FgBHt).

Please help me.

Thank you
 
Old 08-13-2010, 06:22 AM   #2
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 18 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290
Hi,

Have you tried this yet?

Kind regards,

Eric
 
Old 08-13-2010, 06:42 AM   #3
DaRkBoDoM
Member
 
Registered: Oct 2007
Location: Italy
Distribution: Debian
Posts: 72

Original Poster
Rep: Reputation: 17
Code:
setxkbmap -option terminate:ctrl_alt_bksp
Thank you!

This does the trick, but I'm unable to make it run at startup. I've tried putting it on /etc/xprofile /etc/X11/xinit/xinitrc ~/.xprofile and ~/.xinitrc

I still can't kill my Xorg unless i open a terminal and write 'setxkbmap -option terminate:ctrl_alt_bksp' before.
 
Old 08-13-2010, 08:44 AM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,696

Rep: Reputation: 286Reputation: 286Reputation: 286
Here are three more articles on the ctrl+alt+backspace issue.
http://maketecheasier.com/restore-ct...nty/2009/05/17
http://www.hackourlives.com/enable-r...-04-fedora-13/
http://www.ubuntugeek.com/how-to-ena...10-karmic.html
 
Old 08-13-2010, 09:16 AM   #5
DaRkBoDoM
Member
 
Registered: Oct 2007
Location: Italy
Distribution: Debian
Posts: 72

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by bigrigdriver View Post
Here are three more articles on the ctrl+alt+backspace issue.
http://maketecheasier.com/restore-ct...nty/2009/05/17
Obsolete: Dontzap no longer exists
Those are the same as in previous post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+alt+backspace marsques Linux - Newbie 2 02-04-2009 01:05 PM
disable ctrl alt backspace ayan.sen Linux - General 6 10-22-2006 07:12 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
ctrl-alt-backspace suspends wapcaplet Linux - Hardware 19 04-22-2004 09:52 PM
Ctrl+Alt+Backspace Socka Linux - Newbie 8 05-18-2003 07:18 AM


All times are GMT -5. The time now is 06:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration