LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-16-2013, 12:37 PM   #1
tousif
Member
 
Registered: Sep 2013
Posts: 70
Blog Entries: 1

Rep: Reputation: Disabled
Cool Controlling fan speed either automatically on debian 7.1 amd64 (wheezy)


Hey guy's hope you'ree doing well,

PC SPECIFICATIONS :-
M.B - Asus M4A88TD-V EVO/USB3
CPU - AMD PHENOM X2 1055T
RAM - 4GB
GPU - NVIDIA GT520

Now the question is,
when i start debian after few time fan goes very loud & high
and it's truly very disturbing while working so i'm wodering
to control CPU FREQUENCY, CPU FAN and GPU FAN simultaneously
in safe automatic manner.

I'm dual booting with windows 7 Professional and using asus EPU
six engine for above mentioned task, i tried it to run with wine but seems no seccess yet.

any help would be great.
Thanks
 
Old 09-17-2013, 05:55 PM   #2
steve_v
LQ Newbie
 
Registered: Aug 2004
Distribution: Gentoo
Posts: 28

Rep: Reputation: 16
Setting this up in the BIOS is probably easiest, not sure about your board but all the ASUS mobos I have seen have this (called q-fan IIRC) for cpu and possibly case fans.
GPU: dunno. I hacked my GPU BIOS to set fan curves, but it's an NVIDIA anyway.
If you want software control, look into fancontrol - part of the lm_sensors package.
CPU clockspeed scaling should happen automatically, if not check cpufrequtils installed & correct governer for your cpu is loaded.
 
1 members found this post helpful.
Old 09-18-2013, 06:01 AM   #3
tousif
Member
 
Registered: Sep 2013
Posts: 70
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Talking

Quote:
Originally Posted by steve_v View Post
Setting this up in the BIOS is probably easiest, not sure about your board but all the ASUS mobos I have seen have this (called q-fan IIRC) for cpu and possibly case fans.
GPU: dunno. I hacked my GPU BIOS to set fan curves, but it's an NVIDIA anyway.
If you want software control, look into fancontrol - part of the lm_sensors package.
CPU clockspeed scaling should happen automatically, if not check cpufrequtils installed & correct governer for your cpu is loaded.
Thanks for response buddy

I've solved this problem so far,

i googled and found the cpufrequtils and set to ondemand,
have a look,
#/usr/bin/cpufreq-info
#sudo cpufreq-set -g userspace
#sudo cpufreq-set -g ondemand

1. Installed appropriate Nvidia driver as shown at
https://wiki.debian.org/NvidiaGraphi...Version_304.88

2. Replace some lines of grub file as shown at
http://forums.debian.net/viewtopic.php?f=10&t=84455

3. Turned on CPU Q-FAN FUNCTION from BIOS and set it to SILENT.

now PC works flawlessly.WITHOUT ANY DISTURBING NOICE OF FAN.
thanks again for response
 
1 members found this post helpful.
Old 12-05-2013, 04:02 AM   #4
tousif
Member
 
Registered: Sep 2013
Posts: 70
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
ANOTHER SOLUTION FOR NEW LINUX USER, WHO WANT TO INSTALL FAN CONTROL
1) AFTER FRESH INSTALLATION OF LINUX,
2) FIRST TIME FAN CONTROL SETUP IN LINUX,

Disclaimer:- Please check BIOS for Q-FAN FUNCTION if you’ve asus mobo and enable it to solve this issue SAFELY, if don't have Q-FAN FUNCTION, follow the next instructions at your risk,carefully search for critical temperature of CPU & MOTHERBOARD & OTHER HARDWARE to be controlled.
Open terminal, switch to root, type following command,
#apt-get install lm-sensors (let it install & then run next command)
#sensors-detect (followed by YES - let it add lines to /etc/modules)
As per instructions type following command in terminal
#/etc/init.d/kmod start
#apt-get install cpufrequtils
#sudo cpufreq-set -g userspace
#sudo cpufreq-set -g ondemand
for gnom #gedit /etc/default/grub (to edit line of grub configuration file)
for KDE Close the terminal, and press alt+F2,
now type kdesu kwrite /etc/default/grub (to edit line of grub configuration file)
find & change line given below, and save the file
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_enforce_resources=lax"
#sudo update-grub
#sensors
#sensors -s
#pwmconfig (followed by yes)
if it won’t start up while boot, please reinstall the fan control by,
Go to,
http://www.linuxquestions.org/questi...up-4175486802/
Disclaimer:- Enter Manual PWM value after knowing PC’s critical temperature of Mobo, CPU & GPU & other hardwares to be controlled by this.otherwise your PC may malfunction or cause serious permanent damage that may be unrecoverable.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IBM Thinkpad, controlling fan speed exquisite_corpse Linux - Hardware 1 06-01-2011 06:56 PM
Help controlling CPU fan speed in Mandriva 2008 Spring Kourosh Mandriva 4 07-07-2008 02:41 AM
Controlling fan speed according to temperature in Kubuntu 7.04 pashabear Linux - Laptop and Netbook 3 05-09-2007 01:00 PM
SUSE 9.3 AMD64 reduce fan speed, cool'n quiet t2dreamer Suse/Novell 7 06-03-2005 01:49 AM
RedHat not controlling fan speed alansk Linux - Hardware 1 09-29-2003 02:45 AM


All times are GMT -5. The time now is 03:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration