LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 07-19-2013, 07:15 PM   #1
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,416

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Conky text rendering problem on desktop environments


I have been playing about with Conky and have run into an issue.

For those items that vary can frequently, such as minutes and seconds in "uptime," CPU usage, and the like, text renders properly upon Conky startup, but becomes blurred. The best way I can describe it is that it appears that new numbers do not replace old one, but, instead, overlay them, so that the particular column eventually becomes a blurry rectangle.

I have seen this on three computers under KDE and E17. On the same computers, when I use a window manager, such as Fluxbox, the problem does not occur. I've gotten the same results on Slackware --Current, Debian Wheezy, and Mageia 3.

I have tried several edits that supposedly sharpen text, according to the sites where I found them, with no luck. Here's a bit of my conkyrc file that shows some of the items I've tried and then remarked out; I also tried disabling "xftfont" option with no change.

Code:
# double_buffer yes
background no 
own_window yes
own_window_transparent yes
# own_window no

own_window_hints undecorated,below,sticky
# outlines and borders
draw_outline no
draw_borders no
#draw_graph_borders no
border_width 0

# own_window_type normal

use_xft yes
xftfont Bitstream Vera Sans:size=10
This screenshot illustrates the effect.

What am I overlooking?
Attached Images
File Type: jpg conky_e17_mageia_blurredtext.jpg (201.4 KB, 15 views)
 
Old 07-20-2013, 03:56 AM   #2
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
I've had what seems to be, based on your description, similar issues with conky under Fedora 18/19 with Gnome and Cinnamon. I've made some changes to my config file and it appears to have resolved the issue. Here is what I believe is the relevant clip of my config.
PHP Code:
# --- Window Layout & Options --- #
own_window yes
own_window_type desktop
own_window_argb_visual yes
own_window_argb_value 0

double_buffer yes
use_spacer right
use_xft yes
alignment top_right
gap_x 20
gap_y 40 
When I removed all of the "own_window" lines from the original config file and replaced then with the ones shown above the text issue was resolved.

Hope this helps.
 
1 members found this post helpful.
Old 07-20-2013, 08:33 PM   #3
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,416

Original Poster
Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Thanks, Glennnzo. I may not get to test it until Monday--weekends are family time until I log into LQ --but will definitely report back.

Last edited by frankbell; 07-20-2013 at 08:39 PM.
 
Old 07-24-2013, 02:00 PM   #4
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,416

Original Poster
Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Thank you, Glennzo.

That seems to have cleared it up. The key setting that made the difference seems to have been changing

Code:
own_window no
to

Code:
own_window yes
I commented out all my window settings and pasted your code into my .conkyrc file and uptime numbers incremented without blurring after Conky restarted.

However, I had a titlebar, which I do not want.

I then changed the own_window setting back to "no" and the title bar disappeared, but the blurring recurred.

I then returned the own_window setting to "yes" and uncommented these from my previous settings:

Code:
own_window_hints undecorated,below,sticky
and the blurring and the titlebar went away and the sticky state for all desktops returned.

In case it helps someone else, my current window settings are (I've edited out the "remarked out" lines):


Code:
# --- Window Layout & Options --- #
own_window_hints undecorated,below,sticky
own_window yes
own_window_type desktop
own_window_argb_visual yes
own_window_argb_value 0

double_buffer yes
use_spacer right
use_xft yes
alignment top_right
gap_x 25
gap_y 25

Last edited by frankbell; 07-24-2013 at 02:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to desktop environments, looking for a text oriented GUI punchy71 Linux - Newbie 10 12-11-2011 09:33 PM
LXer: Thinking about Desktop Environments, Window Managers and how to get a lightweight desktop LXer Syndicated Linux News 0 07-20-2011 12:20 AM
Desktop Environments Cheechi Linux - Software 9 07-10-2004 12:49 PM
desktop environments moridin Slackware 2 12-02-2003 01:17 PM
Desktop Environments new_user10 Linux - Newbie 1 06-23-2003 07:46 PM


All times are GMT -5. The time now is 10:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration