LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Conky text rendering problem on desktop environments (http://www.linuxquestions.org/questions/linux-desktop-74/conky-text-rendering-problem-on-desktop-environments-4175470253/)

frankbell 07-19-2013 07:15 PM

Conky text rendering problem on desktop environments
 
1 Attachment(s)
I have been playing about with Conky and have run into an issue.

For those items that vary can frequently, such as minutes and seconds in "uptime," CPU usage, and the like, text renders properly upon Conky startup, but becomes blurred. The best way I can describe it is that it appears that new numbers do not replace old one, but, instead, overlay them, so that the particular column eventually becomes a blurry rectangle.

I have seen this on three computers under KDE and E17. On the same computers, when I use a window manager, such as Fluxbox, the problem does not occur. I've gotten the same results on Slackware --Current, Debian Wheezy, and Mageia 3.

I have tried several edits that supposedly sharpen text, according to the sites where I found them, with no luck. Here's a bit of my conkyrc file that shows some of the items I've tried and then remarked out; I also tried disabling "xftfont" option with no change.

Code:

# double_buffer yes
background no
own_window yes
own_window_transparent yes
# own_window no

own_window_hints undecorated,below,sticky
# outlines and borders
draw_outline no
draw_borders no
#draw_graph_borders no
border_width 0

# own_window_type normal

use_xft yes
xftfont Bitstream Vera Sans:size=10

This screenshot illustrates the effect.

What am I overlooking?

Glennzo 07-20-2013 03:56 AM

I've had what seems to be, based on your description, similar issues with conky under Fedora 18/19 with Gnome and Cinnamon. I've made some changes to my config file and it appears to have resolved the issue. Here is what I believe is the relevant clip of my config.
PHP Code:

# --- Window Layout & Options --- #
own_window yes
own_window_type desktop
own_window_argb_visual yes
own_window_argb_value 0

double_buffer yes
use_spacer right
use_xft yes
alignment top_right
gap_x 20
gap_y 40 

When I removed all of the "own_window" lines from the original config file and replaced then with the ones shown above the text issue was resolved.

Hope this helps.

frankbell 07-20-2013 08:33 PM

Thanks, Glennnzo. I may not get to test it until Monday--weekends are family time until I log into LQ :)--but will definitely report back.

frankbell 07-24-2013 02:00 PM

Thank you, Glennzo.

That seems to have cleared it up. The key setting that made the difference seems to have been changing

Code:

own_window no
to

Code:

own_window yes
I commented out all my window settings and pasted your code into my .conkyrc file and uptime numbers incremented without blurring after Conky restarted.

However, I had a titlebar, which I do not want.

I then changed the own_window setting back to "no" and the title bar disappeared, but the blurring recurred.

I then returned the own_window setting to "yes" and uncommented these from my previous settings:

Code:

own_window_hints undecorated,below,sticky
and the blurring and the titlebar went away and the sticky state for all desktops returned.

In case it helps someone else, my current window settings are (I've edited out the "remarked out" lines):


Code:

# --- Window Layout & Options --- #
own_window_hints undecorated,below,sticky
own_window yes
own_window_type desktop
own_window_argb_visual yes
own_window_argb_value 0

double_buffer yes
use_spacer right
use_xft yes
alignment top_right
gap_x 25
gap_y 25



All times are GMT -5. The time now is 09:23 PM.