LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-27-2010, 03:17 AM   #1
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,036

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Completely disable the Gnome background setter


Hi,

I recently started using gnome on a given machine. I'd like to know how to disable the gnome background setter. Things are like this right now:
  • I am booting gnome manually via startx with "exec ck-launch-session gnome-session" from my ~/.xinitrc file.
  • I use my own background setter on my xinitrc file, it's a fairly simple shell script that set's a random picture that it picks from a given folder, then it sleeps in the background and periodically changes my background from time to time at a given interval.
  • When gnome starts my script runs and sets a random picture (I can see that), some seconds after that gnome set's a orange gradient as background instead, my script is still running so after some time another background is set and everything is like I'd like it to be.
  • Yes, I have used gconf-editor and disabled the sticky box at desktop->gnome->background->draw_background[], gnome seems to ignore this settings though.

So, my problem is that gnome is still setting my background and hence overriding the effects of my custom script even though I explicitly disabled the gnome background setter feature. I am not too smart about gnome so maybe I am missing some other important setting. Ideas are all welcome.

Thank you beforehand

ps. I am not using nautilus as my desktop manager. I have no desktop icons and no right-click menu because I don't need that. I am not sure that's relevant at all, but just in case...

Last edited by i92guboj; 08-27-2010 at 03:18 AM.
 
Old 08-29-2010, 12:17 AM   #2
ash joe
LQ Newbie
 
Registered: Aug 2010
Posts: 1

Rep: Reputation: 0
Post

by the what processor are you using.

Last edited by jschiwal; 08-31-2010 at 02:30 AM. Reason: mod removed spam signature
 
Old 09-13-2010, 04:26 AM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,036

Original Poster
Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
It seems this is just a gnome bug. Some settings in the gnome configuration database are no longer acknowledged.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable NumLock and then disable the button completely TL_CLD Slackware 4 01-10-2010 10:24 AM
Completely disable SWAP Syrrace Linux - Security 8 11-27-2008 07:23 AM
how to disable the background color on the console? rsmccain Suse/Novell 4 09-13-2006 04:04 PM
how disable anti-aliasing fonts completely and how to change the default system theme user222 Linux - General 2 10-16-2004 02:03 AM
How to disable firewall completely zyzyis Linux - Newbie 2 09-21-2004 08:23 AM


All times are GMT -5. The time now is 12:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration