LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 01-02-2008, 04:13 PM   #1
Raziel616
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Rep: Reputation: 0
Compiz: No GLXFBConfig for default depth


It seems everybody's having problems with Compiz today, eh?

Anyway, I'm trying to get Compiz-fusion to work on Opensuse 10.3. My video card is an NVIDIA GeForce 6200.

NVIDIA drivers are installed and 3D acceleration is enabled. I installed compiz-fusion via One-click install and everything seemed to go fine.

However, when I run "fusion-icon" all windows lose their decoration and the effects won't work.

This is what I get:

Code:
raziel@linux:~> fusion-icon
 * Detected Session: kde
 * Searching for installed applications...
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
 * KWin is already running
 * Setting window manager to Compiz
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
This is my xorg.conf file:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Dec 13 19:09:35 PST 2007

# /.../
# SaX generated X11 config file
# Created on: 2008-01-02T12:53:31-0600.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[0]" 0 0
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"
    Option         "Clone" "off"
    Option         "Xinerama" "off"
EndSection

Section "Files"
    InputDevices      "/dev/gpmdata"
    InputDevices      "/dev/input/mice"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/URW"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/PEX"
    FontPath        "/usr/share/fonts/cyrillic"
    FontPath        "/usr/share/fonts/latin2/misc:unscaled"
    FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/Type1"
    FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath        "/usr/share/fonts/baekmuk:unscaled"
    FontPath        "/usr/share/fonts/japanese:unscaled"
    FontPath        "/usr/share/fonts/kwintv"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/uni:unscaled"
    FontPath        "/usr/share/fonts/CID"
    FontPath        "/usr/share/fonts/ucs/misc:unscaled"
    FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/misc:unscaled"
    FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/Type1"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/xtest"
    FontPath        "/opt/kde3/share/fonts"
EndSection

Section "Module"
    Load           "freetype"
    Load           "type1"
    Load           "dbe"
    Load           "glx"
    Load           "extmod"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "es"
    Option         "XkbModel" "pc102"
    Option         "XkbRules" "xfree86"
EndSection

Section "InputDevice"
    Identifier     "Mouse[1]"
    Driver         "mouse"
    Option         "Buttons" "5"
    Option         "Device" "/dev/input/mice"
    Option         "Name" "Logic3 / SpectraVideo plc PS/2+USB Mouse"
    Option         "Protocol" "explorerps/2"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Modes"
    Identifier         "Modes[0]"
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "BNQ"
    ModelName      "BENQ FP553"
    UseModes       "Modes[0]"
    DisplaySize     304    228
    HorizSync       30.0 - 60.0
    VertRefresh     43.0 - 75.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "GeForce 6200 (0x0221)"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DisableGLXRootClipping" "True"
    SubSection     "Display"
        Depth       15
        Modes      "1024x768" "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1024x768" "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1024x768" "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1024x768" "800x600"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
Any ideas on how I can solve this?

Thanks in advance.

Last edited by Raziel616; 01-02-2008 at 04:16 PM.
 
Old 01-02-2008, 07:28 PM   #2
google01103
Member
 
Registered: May 2006
Distribution: Suse 10.2 x64
Posts: 247

Rep: Reputation: 31
if you're using the latest Nvidia drives (169.07) you need to start compiz with "compiz --no-libgl-fallback --replace ccp&"
 
Old 01-03-2008, 04:29 PM   #3
Raziel616
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by google01103 View Post
if you're using the latest Nvidia drives (169.07) you need to start compiz with "compiz --no-libgl-fallback --replace ccp&"
Hey, it worked!

Thanks a lot for your help
 
Old 01-03-2008, 04:42 PM   #4
google01103
Member
 
Registered: May 2006
Distribution: Suse 10.2 x64
Posts: 247

Rep: Reputation: 31
fyi - iirc (and I do) the "reload window manager" in fusion-icon will not function
 
Old 01-09-2008, 03:47 PM   #5
eagleMcMoe
LQ Newbie
 
Registered: Dec 2006
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by google01103 View Post
the "reload window manager" in fusion-icon will not function
I solved this problem by writing a tiny shell script that adds the option to the compiz call.
Code:
#!/bin/bash
/usr/bin/compiz --no-libgl-fallback $*
`which compiz` should point to the script so that fusion icon will start the script instead of starting compiz directly.
 
Old 01-09-2008, 05:00 PM   #6
google01103
Member
 
Registered: May 2006
Distribution: Suse 10.2 x64
Posts: 247

Rep: Reputation: 31
Quote:
Originally Posted by eagleMcMoe View Post
I solved this problem by writing a tiny shell script that adds the option to the compiz call.
Code:
#!/bin/bash
/usr/bin/compiz --no-libgl-fallback $*
`which compiz` should point to the script so that fusion icon will start the script instead of starting compiz directly.
In the compiz-fusion forums they suggest using "LIBGL_ALWAYS_INDIRECT=1 /usr/bin/compiz --no-libgl-fallback"
 
Old 01-24-2008, 03:43 PM   #7
ssabchew
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by eagleMcMoe View Post
I solved this problem by writing a tiny shell script that adds the option to the compiz call.
Code:
#!/bin/bash
/usr/bin/compiz --no-libgl-fallback $*
`which compiz` should point to the script so that fusion icon will start the script instead of starting compiz directly.

And how can I do that?
 
Old 02-01-2008, 03:11 PM   #8
eagleMcMoe
LQ Newbie
 
Registered: Dec 2006
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by ssabchew View Post
And how can I do that?
So what I tried to say with "make 'which compiz' point to your script" is that the script should be in your PATH before the original /usr/bin/compiz.
So your ~/bin might be a good place, or /usr/local/bin (if you want to provide it to all users on your machine)
 
Old 01-27-2011, 02:31 AM   #9
javahaxxor
LQ Newbie
 
Registered: Jan 2009
Posts: 5

Rep: Reputation: 1
compiz (core) - Fatal: No GLXFBConfig for default depth

I'm having the same issue some years later, and the nolibgl-fallback param is not reckognized.


Code:
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager
Xorg log:
Code:
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
...
(EE) Jan 27 08:43:57 NVIDIA(1): Unable to find available Display Devices for screen 1.
(EE) Jan 27 08:43:57 NVIDIA(1): No display devices found for this X screen.
and my xorg.conf:
Code:
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Default Screen" LeftOf "Screen1"
    Screen      1  "Screen1" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

# DPMS options need to be put under the Device section for NVIDIA as well as Monitor
Section "ServerFlags"
	Option  "Xinerama"	"0"
    	Option	"BlankTime"	"1"
    	Option	"StandbyTime"	"0"
    	Option	"SuspendTime"	"0"
    	Option	"OffTime"	"2"
    	Option  "DontZap"       "off"
	Option	"DontVTSwitch"   "off"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "se"
	Option         "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "Emulate3Buttons" "true"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Samsung"
    ModelName      "Syncmaster 2443BW"
    HorizSync       30.0 - 75.0
    VertRefresh     56.0 - 61.0
    Option	   "DPMS"
    Option      "BlankTime"     "1"
    Option      "StandbyTime"   "2"
    Option      "SuspendTime"   "3"
    Option      "OffTime"       "4"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Samsung"
    ModelName      "Syncmaster 2443BW"
    HorizSync       30.0 - 75.0
    VertRefresh     56.0 - 61.0
    Option         "DPMS"
    Option      "BlankTime"     "1"
    Option      "StandbyTime"   "2"
    Option      "SuspendTime"   "3"
    Option      "OffTime"       "4"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 450 GTS"
    BusID          "PCI:1:0:0"
    Screen          0
    Option 	"AddARGBGLXVisuals" "true"
    Option      "BlankTime"     "3"
    Option      "StandbyTime"   "4"
    Option      "SuspendTime"   "5"
    Option      "OffTime"       "6"
EndSection

Section "Device"
    Identifier     "Videocard1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 450 GTS"
    BusID          "PCI:1:0:0"
    Screen          1
    Option 	"AddARGBGLXVisuals" "true"
    Option      "BlankTime"     "3"
    Option      "StandbyTime"   "4"
    Option      "SuspendTime"   "5"
    Option      "OffTime"       "6"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1920x1200"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    SubSection	   "Display"
	Depth	   24
	Modes	   "1920x1200"
    EndSubSection
    Option         "TwinView" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    Option         "metamodes" "CRT: 1152x864_75 +0+0"
# Removed Option "metamodes" "CRT: 1280x1024 +0+0; CRT: 1152x864_75 +0+0"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz - How do I include the compiz-extra plugins? lostinpurdy Linux - Desktop 2 05-29-2007 02:00 AM
mdv 2007 compiz cube not displaying and pictures not memorised by gset-compiz Emmanuel_uk Mandriva 0 10-10-2006 02:33 AM
Cant get 1024x768 with Depth 16 or 24 rgogada Mandriva 3 06-30-2005 02:24 AM
X will only do 1024x768 at depth 4 e0r Linux - Hardware 12 02-07-2005 12:26 PM
I have a problem configurating the Default Depth. Please, help. Damog Linux - Hardware 2 08-10-2002 02:00 PM


All times are GMT -5. The time now is 07:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration