LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Compiz Cube Gears Fixed Tearing...but (http://www.linuxquestions.org/questions/linux-desktop-74/compiz-cube-gears-fixed-tearing-but-738083/)

firstpaladin 07-06-2009 10:24 AM

Compiz Cube Gears Fixed Tearing...but
 
So I am using an Nvidia 9800 gt graphics card (evga) and am running Kubuntu 9.04 (compiz version 0.8.2).

The default compiz vsync does not work. Specifically, I get tearing at the top of the screen...changing the refresh rate does not fix anything, neither has anything else that I've tried in this regard...

However, the nvidia opengl vsync works fine (as long as I do nvidia-settings -l before loading compiz) when compiz is in cube rotation mode, running the benchmark, etc.

Normally, when the desktop is just running normally it tears like mad. My solution, which has completely fixed the problem, was to turn cube transparency when not rotating to 99% opacity and activate cube gears (atlantis works too). This fixed it. However, I'm not happy because of the constant cpu usage (that I consider unnecessary). I'm using a quad core, so it's not a huge issue, but I'd prefer to have my computer idle at a much lower cpu %.

There seems to be a patch for compiz 0.6.2 here: http://www.nvnews.net/vbulletin/showthread.php?t=101336 ...it sounds like it would fix my issues, but I don't know how to use this patch in compiz 0.8.2...and I haven't tested it at all.


So basically I'm asking is...

How do I keep my desktop from tearing after disabling cube gears?


All times are GMT -5. The time now is 10:54 PM.