LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 07-15-2010, 12:16 PM   #1
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Debian GNU/Linux with XFCE and packages from "testing"
Posts: 377

Rep: Reputation: 46
Compiz activates when I move windows around.


Hi,

as the the title states, when I move windows around when Metacity is activated, Compiz automatically activates, especially when I move the windows over edges (but also otherwise, just-for-fun it seems :/). I use the fusion-icon.
Is there a way to disable this behavior? For me, this is kinda annoying, I don't know what the devs were thinking...

TIA, "Titan"
 
Old 07-15-2010, 02:36 PM   #2
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: Slackware 13.0, Linux Mint 17.0
Posts: 97

Rep: Reputation: 22
System Tools>Configuration>Compiz>
or CCSM

Last edited by jtarin; 07-15-2010 at 02:38 PM.
 
Old 07-16-2010, 12:39 PM   #3
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Debian GNU/Linux with XFCE and packages from "testing"
Posts: 377

Original Poster
Rep: Reputation: 46
I can open the CCSM with just a right-click on the fusion-icon and then a click on "settings manager". But where do I disable the automatic activation in the CCSM?
TIA
 
Old 07-17-2010, 12:42 AM   #4
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: Slackware 13.0, Linux Mint 17.0
Posts: 97

Rep: Reputation: 22
I misunderstood. I thought you were only interested in this one behavior.

Disable compiz window manager (without killing current desktop session)
Code:
# DISPLAY=$DISPLAY metacity –replace &
Enable compiz window manager (without killing current desktop session)
Code:
# DISPLAY=$DISPLAY compiz –replace &
 
Old 07-17-2010, 09:37 AM   #5
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Debian GNU/Linux with XFCE and packages from "testing"
Posts: 377

Original Poster
Rep: Reputation: 46
It seems I need to clarify my question...

When I start up my desktop (Gnome), compiz is started (via the command fusion-icon -f). Then I switch to metacity with the fusion-icon, for example to play a game (games don't run smoothly when compiz is enabled). After I play my game, I don't activate compiz again right away (for example, because I want to play again after doing something else). Now, with compiz still disabled, I move windows around. While I do that, compiz just activates without being asked for it. But I don't want compiz to activate when I don't tell it to. How do I change that behavior?

TIA
 
Old 07-17-2010, 12:05 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
I can't think of any reason why compiz would just spontaneously start. In the years I've used compiz, I've never seen that happen.

Next time you switch from compiz to metacity to play a game, run this command:

Code:
ps ax | egrep 'compiz|metacity'
Then, afterwards, when compiz just starts up on its own, run that command again. Then show us the output of that command each time you ran it.

Adam
 
Old 07-17-2010, 01:01 PM   #7
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Debian GNU/Linux with XFCE and packages from "testing"
Posts: 377

Original Poster
Rep: Reputation: 46
I didn't catch the output from that command when I started metacity, but here's the one right after compiz started just from moving windows around:
Code:
24303 ?        R      0:02 compiz --replace --sm-disable --ignore-desktop-hints ccp
24333 pts/0    R+     0:00 egrep compiz|metacity
TIA for ideas and solutions
 
Old 07-18-2010, 01:36 AM   #8
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: Slackware 13.0, Linux Mint 17.0
Posts: 97

Rep: Reputation: 22
Have you tried the two commands I gave you for disabling and enabling to see if this behavior still presents itself.
 
Old 07-18-2010, 07:31 AM   #9
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Debian GNU/Linux with XFCE and packages from "testing"
Posts: 377

Original Poster
Rep: Reputation: 46
I managed to capture both outputs.

Right after I switch to metacity:
Code:
 2908 ?        S      0:00 /bin/sh /apps/firefox/firefox http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2912 ?        S      0:00 /bin/sh /apps/firefox/run-mozilla.sh /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2916 ?        Sl     0:05 /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 3017 ?        S      0:00 metacity --replace
 3048 pts/0    S+     0:00 egrep compiz|metacity
Right after compiz starts on its own:
Code:
 2908 ?        S      0:00 /bin/sh /apps/firefox/firefox http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2912 ?        S      0:00 /bin/sh /apps/firefox/run-mozilla.sh /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2916 ?        Sl     0:06 /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 3133 ?        S      0:02 compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding
 3153 pts/0    R+     0:00 egrep compiz|metacity
I made those lines bold that I think have to do with this.

About the two commands: Why do I set $DISPLAY to $DISPLAY?? I don't see the point in that, but calling metacity from the console seems to help track down the problem: When I moved windows around now, metacity crashes (I'm left without any window manager at all; I wouldn't be able to get one back without the fusion-icon). metacity outputs this:
Code:
**
metacity:ERROR:core/boxes.c:1161:meta_rectangle_edge_aligns: code should not be reached
My conclusion is that this is a bug in metacity.
 
Old 07-18-2010, 08:03 AM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Ahhh, yeah, metacity is crashing and your system is recovering, or trying to, anyway, by starting a window manager back up. I'm not sure why, however, it chooses compiz over metacity. I'd definitely open up a bug report with your distribution.

Adam
 
Old 07-18-2010, 08:22 AM   #11
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Debian GNU/Linux with XFCE and packages from "testing"
Posts: 377

Original Poster
Rep: Reputation: 46
OK I'll probably deal with this later, now that we've found out what's wrong.
Thank you two for your help.

CYA
 
  


Reply

Tags
auto, compiz


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox no borders under compiz. Not able to move, maximize. Rockgod1969 Linux - Software 7 02-18-2009 07:15 AM
windows decorations, compiz STARHARVEST Slackware 7 05-02-2008 02:58 AM
Compiz on Ubuntu(Studio) - Resizing windows causes Compiz to crash! lostinpurdy Linux - Desktop 1 03-27-2008 10:02 PM
Compiz Themes: How to move buttons to other side psychobyte Ubuntu 0 09-11-2006 02:11 AM
eth0 Activates but no internet! benrose111488 Linux - Networking 8 06-21-2004 04:42 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration