LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Compiz activates when I move windows around. (http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013/)

TITiAN 07-15-2010 12:16 PM

Compiz activates when I move windows around.
 
Hi,

as the the title states, when I move windows around when Metacity is activated, Compiz automatically activates, especially when I move the windows over edges (but also otherwise, just-for-fun it seems :/). I use the fusion-icon.
Is there a way to disable this behavior? For me, this is kinda annoying, I don't know what the devs were thinking...

TIA, "Titan"

jtarin 07-15-2010 02:36 PM

System Tools>Configuration>Compiz>
or CCSM

TITiAN 07-16-2010 12:39 PM

I can open the CCSM with just a right-click on the fusion-icon and then a click on "settings manager". But where do I disable the automatic activation in the CCSM?
TIA

jtarin 07-17-2010 12:42 AM

I misunderstood. I thought you were only interested in this one behavior.

Disable compiz window manager (without killing current desktop session)
Code:

# DISPLAY=$DISPLAY metacity –replace &
Enable compiz window manager (without killing current desktop session)
Code:

# DISPLAY=$DISPLAY compiz –replace &

TITiAN 07-17-2010 09:37 AM

It seems I need to clarify my question...

When I start up my desktop (Gnome), compiz is started (via the command fusion-icon -f). Then I switch to metacity with the fusion-icon, for example to play a game (games don't run smoothly when compiz is enabled). After I play my game, I don't activate compiz again right away (for example, because I want to play again after doing something else). Now, with compiz still disabled, I move windows around. While I do that, compiz just activates without being asked for it. But I don't want compiz to activate when I don't tell it to. How do I change that behavior?

TIA

adamk75 07-17-2010 12:05 PM

I can't think of any reason why compiz would just spontaneously start. In the years I've used compiz, I've never seen that happen.

Next time you switch from compiz to metacity to play a game, run this command:

Code:

ps ax | egrep 'compiz|metacity'
Then, afterwards, when compiz just starts up on its own, run that command again. Then show us the output of that command each time you ran it.

Adam

TITiAN 07-17-2010 01:01 PM

I didn't catch the output from that command when I started metacity, but here's the one right after compiz started just from moving windows around:
Code:

24303 ?        R      0:02 compiz --replace --sm-disable --ignore-desktop-hints ccp
24333 pts/0    R+    0:00 egrep compiz|metacity

TIA for ideas and solutions

jtarin 07-18-2010 01:36 AM

Have you tried the two commands I gave you for disabling and enabling to see if this behavior still presents itself.

TITiAN 07-18-2010 07:31 AM

I managed to capture both outputs.

Right after I switch to metacity:
Code:

2908 ?        S      0:00 /bin/sh /apps/firefox/firefox http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2912 ?        S      0:00 /bin/sh /apps/firefox/run-mozilla.sh /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2916 ?        Sl    0:05 /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
3017 ?        S      0:00 metacity --replace
 3048 pts/0    S+    0:00 egrep compiz|metacity

Right after compiz starts on its own:
Code:

2908 ?        S      0:00 /bin/sh /apps/firefox/firefox http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2912 ?        S      0:00 /bin/sh /apps/firefox/run-mozilla.sh /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
 2916 ?        Sl    0:06 /apps/firefox/firefox-bin http://www.linuxquestions.org/questions/linux-desktop-74/compiz-activates-when-i-move-windows-around-820013-new/
3133 ?        S      0:02 compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding
 3153 pts/0    R+    0:00 egrep compiz|metacity

I made those lines bold that I think have to do with this.

About the two commands: Why do I set $DISPLAY to $DISPLAY?? I don't see the point in that, but calling metacity from the console seems to help track down the problem: When I moved windows around now, metacity crashes (I'm left without any window manager at all; I wouldn't be able to get one back without the fusion-icon). metacity outputs this:
Code:

**
metacity:ERROR:core/boxes.c:1161:meta_rectangle_edge_aligns: code should not be reached

My conclusion is that this is a bug in metacity.

adamk75 07-18-2010 08:03 AM

Ahhh, yeah, metacity is crashing and your system is recovering, or trying to, anyway, by starting a window manager back up. I'm not sure why, however, it chooses compiz over metacity. I'd definitely open up a bug report with your distribution.

Adam

TITiAN 07-18-2010 08:22 AM

OK I'll probably deal with this later, now that we've found out what's wrong.
Thank you two for your help.

CYA


All times are GMT -5. The time now is 08:06 PM.