LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 05-05-2007, 04:40 AM   #1
leong3779
LQ Newbie
 
Registered: Mar 2007
Location: uk
Distribution: ubuntu 7.04
Posts: 22

Rep: Reputation: 15
Unhappy chinese/Japanese input via SCIM in ubuntu 6.10


i try to use scim to input chinese and japanese in ubuntu 6.10 , but stil can't active scim by ctrl+space key; the following is some msg from my f-s laptop:


Quote:
cll@cll-fsl7310Wlaptop:~$ scim
Smart Common Input Method 1.4.4

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.4

Starting SCIM ...

Quote:
cll@cll-fsl7310Wlaptop:~$ scim -l
Smart Common Input Method 1.4.4


Available FrontEnd module:
socket
x11

Available Config module:
simple
socket
dummy

Available IMEngine module:
anthy
canna
chewing
libanthy
libcanna
pinyin
rawcode
socket
table
cll@cll-fsl7310Wlaptop:~$
thank !!
 
Old 05-06-2007, 11:13 PM   #2
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
Hi leong3779,
please clarify your locale setting
in any of your command line, type
locale
give us the result.

And, for your information by default some program won't work with chinese input(example amsn).

Good luck,
Ks
 
Old 05-07-2007, 06:17 PM   #3
leong3779
LQ Newbie
 
Registered: Mar 2007
Location: uk
Distribution: ubuntu 7.04
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kstan
Hi leong3779,
please clarify your locale setting
in any of your command line, type
locale
give us the result.

And, for your information by default some program won't work with chinese input(example amsn).

Good luck,
Ks
i was install a lot of thing from net , but the thing is at the end i got some more error msg!!

Code:
cll@cll-fsl7310Wlaptop:~$ scim
Smart Common Input Method 1.4.4

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
ERROR: could not open init.scm (errobj No such file or directory)

*backtrace*
>>(require "init.scm")
>>(*catch (quote errobj) (require "init.scm"))
>>(eq? (quote *init.scm-loaded*) (*catch (quote errobj) (require "init.scm")))

ERROR: unbound variable (errobj create-context)

*backtrace*
>>(create-context 0 (quote ()) (quote ()))

Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.4

Starting SCIM ...
SCIM successfully exited.

cll@cll-fsl7310Wlaptop:~$
but i search the file init.scm is under my //usr/share/fastival
and from the locale i got the msg as :

Code:
cll@cll-fsl7310Wlaptop:~$ locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
cll@cll-fsl7310Wlaptop:~$
can help ?? sorry for more error !!!!
 
Old 05-07-2007, 07:47 PM   #4
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
If you scim can start but won't allow you to change input language(always in english US)
Try change to
LC_CTYPE="zh_CN.UTF-8"
LANGUAGE="zh_CN.UTF-8:en_US.UTF-8"

See whether it help?
By the way, make sure you'd had install chinese table.
Regards,
Ks
 
Old 05-10-2007, 09:05 AM   #5
leong3779
LQ Newbie
 
Registered: Mar 2007
Location: uk
Distribution: ubuntu 7.04
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kstan
If you scim can start but won't allow you to change input language(always in english US)
Try change to
LC_CTYPE="zh_CN.UTF-8"
LANGUAGE="zh_CN.UTF-8:en_US.UTF-8"

See whether it help?
By the way, make sure you'd had install chinese table.
Regards,
Ks
yah ! i was install the chinese table from synaptic package manager and all recommended , suggesded also ; sorry for how to change the above two option ? and is i need to change the local setting to chinese and Japanese ? and how to do it ?

Rgs
leong
 
Old 05-10-2007, 09:32 AM   #6
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
you can edit /etc/environment, /etc/profile, or /etc/profile.d/*anyfile*, ~/.dmrc and etc. Use the 1st should be ok for u.
 
Old 05-10-2007, 04:32 PM   #7
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 12.04
Posts: 913

Rep: Reputation: 32
Quote:
Originally Posted by kstan
you can edit /etc/environment, /etc/profile, or /etc/profile.d/*anyfile*, ~/.dmrc and etc. Use the 1st should be ok for u.
Do your locale settings affect SCIM? I'm not using Ubuntu, but on Red Hat and Fedora, scim works just fine at least for typing Japanese chars without any change to the default locale settings.
 
Old 05-12-2007, 01:52 AM   #8
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 12.04
Posts: 913

Rep: Reputation: 32
Quote:
Originally Posted by daihard
Do your locale settings affect SCIM? I'm not using Ubuntu, but on Red Hat and Fedora, scim works just fine at least for typing Japanese chars without any change to the default locale settings.
I apparently spoke too soon. I just installed Ubuntu 6.10 on a spare machine and I'm having a heck of a hard time getting SCIM to work. It does start up, but it won't let me type in anything other than Roman alphabets...
 
Old 05-12-2007, 03:01 PM   #9
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
thats why this topic come out..
 
Old 05-13-2007, 08:09 PM   #10
leong3779
LQ Newbie
 
Registered: Mar 2007
Location: uk
Distribution: ubuntu 7.04
Posts: 22

Original Poster
Rep: Reputation: 15
Cool

Quote:
Originally Posted by kstan
thats why this topic come out..
hi ! I edit my /etc/environment as below :-
Code:
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games"
#LANG="en_GB.UTF-8"
#LANGUAGE="en_GB:en"
#LC_CTYPE="zh_CN.UTF-8"
#LANGUAGE="zh_CN.UTF-8:en_US.UTF-8"
LC_CTYPE="zh_CN.UTF-8"
LANGUAGE="en_GB:en"
and now i can input Chinese / Japanese in English environment thank your help , and b4 that i was install all ttf font and all this thing :

scim
scim-chinese
scim-config-gconf
scim-config-socket
scim-frontend-socket
scim-gtk2-immodule
scim-server-socket
scim-tables-zh
xfonts-intl-chinese
thank every body give me a help !!谢谢 有難う御座います
after the typing of Chinese and Japanese look like i have to improve the font type , can help ? or just simply change it from application i am using ?
 
Old 05-13-2007, 08:44 PM   #11
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
u can try change LC_CTYPE=zh_TW.UTF-8, have a try
 
Old 05-13-2007, 11:09 PM   #12
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 12.04
Posts: 913

Rep: Reputation: 32
Quote:
Originally Posted by kstan
u can try change LC_CTYPE=zh_TW.UTF-8, have a try
Does that mean you need to change LC_CTYPE whenever you need to switch between Chinese and Japanese? That sounds kinda awkward. Under Fedora Core 5/6 you don't need to touch LC_CTYPE in order for SCIM to work.
 
Old 05-14-2007, 02:53 AM   #13
leong3779
LQ Newbie
 
Registered: Mar 2007
Location: uk
Distribution: ubuntu 7.04
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by daihard
Does that mean you need to change LC_CTYPE whenever you need to switch between Chinese and Japanese? That sounds kinda awkward. Under Fedora Core 5/6 you don't need to touch LC_CTYPE in order for SCIM to work.
no , just can input very well between Chinese/Japanese like above fist two is Chinese and the following is Japanese , and if you know Koren also can be done.
 
Old 05-14-2007, 03:28 AM   #14
leong3779
LQ Newbie
 
Registered: Mar 2007
Location: uk
Distribution: ubuntu 7.04
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kstan
u can try change LC_CTYPE=zh_TW.UTF-8, have a try
thank ! the font is much better then before
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why I can't input chinese with scim yearnjia Linux - Desktop 4 01-29-2009 05:15 PM
No idea what's going on (about chinese input using SCIM) MichaelYoung Debian 1 10-19-2006 07:54 AM
Japanese input not working in Qt with SCIM-QTIMM AireTamStorm Linux - Software 1 04-30-2006 10:33 AM
chinese input SCIM -d doesn't work xjchen001 Linux - Newbie 1 09-15-2005 09:14 PM
Chinese input using SCIM in OpenOffice satellite360 Linux - Software 4 05-17-2005 09:21 AM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration