LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 04-10-2007, 02:23 PM   #1
pmikec
LQ Newbie
 
Registered: Mar 2007
Distribution: Debian Etch
Posts: 8

Rep: Reputation: 0
Changing desktop resolution on Debian 4.0 with Xorg and KDE


Hello. I'm having some problems getting my desktop set to the correct resolution. When I configured xorg, I specified the 1440X900 resolution to be kept, but when I go into KDE and try to change the resolution using the display manager, the only options listed are 1024X768, 800X600, and 640X480. My graphics card is an ATI RADEON X850 XT. I also don't have the RADEON drivers installed because they don't seem to want to install on Etch.

Thanks in advance!
 
Old 04-10-2007, 02:38 PM   #2
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
Which driver is being used in xorg.conf?
 
Old 04-10-2007, 03:41 PM   #3
pmikec
LQ Newbie
 
Registered: Mar 2007
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
Here's my entire xorg.conf

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-72
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 04-10-2007, 03:49 PM   #4
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Change "vesa" to "ati" or "radeon". It may also help to bump the top of the HorizSync range up to 99.
 
Old 04-10-2007, 04:02 PM   #5
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
I would use radeon in place of vesa. And if the HorizSync and VertRefresh values were auto detected, I would leave them alone. If you know these values, you should use the correct ones in xorg.conf.
 
Old 04-10-2007, 04:17 PM   #6
pmikec
LQ Newbie
 
Registered: Mar 2007
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
Alright. I changed the setting in xorg.conf to both radeon and ati, and both worked. Howver, in both cases the display was off to the left about 1/3 of the screen. (i.e. I could only see the right 2/3 of my desktop, and the rest of the screen was black). Could this be because of incorrect sync rates?

EDIT: This is my monitor: http://www.westinghousedigital.com/d...spx?itemnum=54

Last edited by pmikec; 04-10-2007 at 04:19 PM.
 
Old 04-10-2007, 04:20 PM   #7
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
I was just about to ask what type of monitor it is.
 
Old 04-10-2007, 04:21 PM   #8
pmikec
LQ Newbie
 
Registered: Mar 2007
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
Check my post above. I can't find any website that has this sync rates listen. Maybe you'll have better luck?
 
Old 04-10-2007, 04:27 PM   #9
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
I'm not sure if the HorizSync and VertRefresh values even matter with an LCD. It might be a problem if you are trying to run the monitor at anything but the native resolution. I don't have much experience with LCD monitors though.
 
Old 04-10-2007, 08:35 PM   #10
pmikec
LQ Newbie
 
Registered: Mar 2007
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
The native resolution is 1440X900.
 
Old 04-10-2007, 08:41 PM   #11
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
According to the link you posted, the native resolution is 1280x1024.
 
Old 04-10-2007, 08:49 PM   #12
pmikec
LQ Newbie
 
Registered: Mar 2007
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
I'm sorry. I forgot to mention that the manufacturer's site is actually wrong (believe it or not). The monitor is that exact model (I'm looking at the box now), but the native resolution is definitely 1440X900 (which is also stated on the box).
 
Old 04-10-2007, 09:11 PM   #13
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
I've been doing some searching, but I'm not having much luck. The only thing I've noticed is mention of the UseEDID option in xorg.conf, but I'm not sure how to use it in this case.
 
Old 04-10-2007, 09:24 PM   #14
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
I'm sort of old-fashioned; I still use "modelines" to specify custom resolutions in my xorg.conf. You can calculate modelines using something like "COLA's free modeline generator". With a modeline, it's possible to completely tweak the timings of the video mode--even adjusting a letterboxed or windowsboxed active screen area with black borders all around.
 
Old 04-11-2007, 10:14 AM   #15
pmikec
LQ Newbie
 
Registered: Mar 2007
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
I fixed it. I went in and ran the xorg config again and then used the auto-adjust feature on my monitor and it alligned itself properly. Thanks for the suggestions!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
changing screen resolution on Xorg Bopi Linux - General 5 11-26-2005 05:15 AM
Changing the Xorg virtual desktop resolution iscurrah Slackware 4 04-05-2005 01:09 PM
Changing resolution in FC3. Which xorg.conf line do I edit? ColKurtz Linux - Newbie 2 02-18-2005 12:09 PM
Changing desktop resolution after a fresh install of Debian Sarge Virp00 Debian 7 01-17-2005 05:05 AM
changing the desktop resolution dmann304 Linux - General 10 11-18-2003 10:27 PM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration