LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 10-13-2008, 07:49 AM   #1
IsharaComix
Member
 
Registered: Sep 2008
Location: Raleigh
Distribution: Ubuntu 8.10
Posts: 88
Blog Entries: 1

Rep: Reputation: 15
Change the screen resolution in Xubuntu?


I'm running Xubuntu 8.04 in QEMU right now, and the only choices for resolution in my control panel are 800x600 and 640x480.

I tried editing the xorg.conf file by adding my desired resolution (1280x800) into the modes section, but all I succeeded in doing was crashing my system. When it went into low-graphics mode, my resolution ended up even smaller than ever, so I ran "sudo dpkg-reconfigure xserver-xorg" and all THAT did was get my resolution back to normal (800x600).

Can someone help me out here? I'm running a fresh install of Xubuntu 8.04 with all the defaults set pretty much in place. Keep in mind that I'm running QEMU, so auto-detection is (apparently) a little funky. If there's something I can do with the terminal either in Linux or in the QEMU bootline, I'm willing to try it.

I don't pretend to be an expert on either QEMU or Linux, so feel free to insult my intelligence.
 
Old 10-13-2008, 02:33 PM   #2
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
I haven't run Ubuntu in QEMU but have seen a very similar problem with Fedora in Parallels on a Mac.

The problem (for me) would seem to be an issue relating to both the default colour depth and resolution.

I modified my xorg.conf from a default depth of 24 to 16. That allowed me to exceed the 800x600 resolution.

I then gradually increased the resolution beyond and the X server was fine up to 1200x1024 but anything over that and I started getting all sorts of issues that finally culminated in the X server failing to start.

Not the most helpful reply I guess but slowly stepping up the resolution may reveal your maximum setting.
 
Old 10-13-2008, 03:21 PM   #3
IsharaComix
Member
 
Registered: Sep 2008
Location: Raleigh
Distribution: Ubuntu 8.10
Posts: 88
Blog Entries: 1

Original Poster
Rep: Reputation: 15
My Unhelpful xorg.conf

Thanks for trying. Makes me feel good to know someone cares.

I can't figure out how to edit my conf file. Here's the entire xorg.conf thing in code brackets. If I can get some exact parameters to add in, that would help. If it had some numbers, I could play the file by ear. But this is the most unhelpful system file I've ever seen.

Code:
# xorg.conf (X.Org X Window System server configuration file)

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
EndSection
I cut out the commented headers, since this is big enough as it is.

Any more ideas?
 
Old 10-13-2008, 03:52 PM   #4
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
Your xorg.conf has very little detail in it which is normal for virtual machine installations.

You should add the following lines directly after Section "Screen" so that it reads;

Code:
Section "Screen"
	Identifier	"Default Screen"
        Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	16
	SubSection "Display"
		Depth		16
		Modes		"1024x768"
	EndSubSection
EndSection
In order to do this you should press Ctrl-Alt-F1 to go to a terminal.

In Ubuntu type
Code:
sudo vi /etc/X11/xorg.conf
and edit the file. If you aren't familiar with vi then google it for instructions but simply put you need to press 'i' to go into insert mode, make the changes and when you have finished press 'escape' and type
Code:
:wq!
which will write the changes and quit.

You can then press Ctrl-Alt-F7 to go back to the GUI and then Ctrl-Alt-backspace to restart the Xserver.

Hopefully it will work fine at 1024x768. You can keep changing the xorg.conf until it breaks.

Best of luck...

Last edited by Unknown_User; 10-13-2008 at 03:53 PM.
 
Old 10-13-2008, 05:03 PM   #5
IsharaComix
Member
 
Registered: Sep 2008
Location: Raleigh
Distribution: Ubuntu 8.10
Posts: 88
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Thanks. I really do appreciate the help... even though I'm not getting anywhere (as is often the case).

I tried what you said, adding the modes variable to the subsection, and I also added a line of code to the "monitor" section. (it started with modeline and followed up with specific refresh specs, I got it from running a command but I can't recall what it was)

It silently ignored everything I put in. It didn't crash on me this time, but I still have yet to see any results. Do you think it might have something to do with that depth variable? I've seen other questions on the site answering a similar question to change depth to 24 or other such numbers.

Maybe there's a package I could download to make this problem go away. Normally I could deal with this resolution thing, but Ubuntu just has such huge icons that there's no room for me to work! I'm using an Xterm just because the default terminal overflows out of the screen.

I do hope I'm not being a pain. You're far more helpful than I deserve.
 
Old 10-13-2008, 08:54 PM   #6
IsharaComix
Member
 
Registered: Sep 2008
Location: Raleigh
Distribution: Ubuntu 8.10
Posts: 88
Blog Entries: 1

Original Poster
Rep: Reputation: 15
A hopeless venture?

Here's an excerpt I recently found in /var/log/Xorg.0.log

Code:
(II) CIRRUS(0): Not using default mode "640x350" (vrefresh out of range)
(II) CIRRUS(0): Not using default mode "320x175" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "640x400" (vrefresh out of range)
(II) CIRRUS(0): Not using default mode "320x200" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "720x400" (vrefresh out of range)
(II) CIRRUS(0): Not using default mode "360x200" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "640x480" (vrefresh out of range)
(II) CIRRUS(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "640x480" (vrefresh out of range)
(II) CIRRUS(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "640x480" (hsync out of range)
(II) CIRRUS(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "400x300" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "400x300" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "800x600" (hsync out of range)
(II) CIRRUS(0): Not using default mode "400x300" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "800x600" (hsync out of range)
(II) CIRRUS(0): Not using default mode "400x300" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "800x600" (hsync out of range)
(II) CIRRUS(0): Not using default mode "400x300" (bad mode clock/interlace/doublescan)
(II) CIRRUS(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
)
And that's just a tiny snippet. Am I doomed to forever be stuck in this tiny box because of QEMU's lack of support for larger window resolutions?

It's weird, because I've run DSL in QEMU for a long while, and I can't get it SMALLER than 1280x1024. But then again, it uses Xvesa, not Xserver. It doesn't have a /etc/X11/Xorg.conf file either.

If anyone comes up with anything, I'll be waiting. Until then, I guess I'll just get used to using a super-scrunched up environment. As a Linux-user-wannabe, I suppose it shouldn't matter since I should be in the terminal anyways. But in case any QEMU geniuses out there can help me with my plight, I'll put this info up and be quiet.
 
Old 10-14-2008, 03:10 AM   #7
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
Ah, that's interesting.

It looks like the information that your monitor is sending is not being understood by the xserver as it seems to assume that just about any resolution or refresh rate is out of range.

Try adding to your device section so that it reads;
Code:
Section "Device"
	Identifier	"Configured Video Device"
	Option		"UseFBDev"		"true"
        Option		"NoDDC" "1"
EndSection
so that X ignores the input and uses the default.

Are you using an LCD monitor? I'm sure that you know that you should be fine in trying this out but an old CRT can do odd things (and you can damage it) if you try a resolution or refresh rate that is manifestly outside its capabilities.
 
Old 10-14-2008, 09:56 AM   #8
IsharaComix
Member
 
Registered: Sep 2008
Location: Raleigh
Distribution: Ubuntu 8.10
Posts: 88
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Thanks again for the quick reply.

It's ignoring me telling it to ignore it and I still get the same results with the log file.

In QEMU, I'm able to utilize two different graphical chips... aCirrus CLGD 5446 PCI VGA card or dummy VGA card with Bochs VESA extensions (hardware level, including all non standard modes). I usually try both of them every time I edit the xorg-conf file. The log file is somewhat different with the emulated Bochs chip. Rather than testing every single possible configuration, it tests a few (including mine) and then won't even give me a choice of 800x600.

It still says hsync is out of range.

As a side note, I can also link Qemu's output to a physical monitor connected to my machine instead of the built-in virtual monitor (which I'm using now), but I don't know how to reference my laptop's monitor in 'port language.' If I stopped using Qemu's virtual monitor and instead used my own, I'd lose the ability to use Windows at the same time, but that's not really much of a loss. If you know how I could reference the monitor, here's some QEMU command line options of the relevant section out of the help file (I'm hosting on Windows Vista... why, I do not know):

`-serial dev'

Redirect the virtual serial port to host character device dev. The default device is vc in graphical mode and stdio in non graphical mode.

This option can be used several times to simulate up to 4 serials ports.

Use -serial none to disable all serial ports.

Available character devices are:

vc
Virtual console

pty
[Linux only] Pseudo TTY (a new PTY is automatically allocated)

none
No device is allocated.

null
void device

/dev/XXX
[Linux only] Use host tty, e.g. `/dev/ttyS0'. The host serial port parameters are set according to the emulated ones.

/dev/parportN
[Linux only, parallel port only] Use host parallel port N. Currently only SPP parallel port features can be used.

file:filename
Write output to filename. No character can be read.

stdio
[Unix only] standard input/output

pipe:filename
name pipe filename

COMn
[Windows only] Use host serial port n

udp:[remote_host]:remote_port[@[src_ip]:src_port]
This implements UDP Net Console. When remote_host or src_ip are not specified they default to 0.0.0.0. When not using a specifed src_port a random port is automatically chosen.

If you just want a simple readonly console you can use netcat or nc, by starting qemu with: -serial udp::4555 and nc as: nc -u -l -p 4555. Any time qemu writes something to that port it will appear in the netconsole session.

If you plan to send characters back via netconsole or you want to stop and start qemu a lot of times, you should have qemu use the same source port each time by using something like -serial udp::4555@:4556 to qemu. Another approach is to use a patched version of netcat which can listen to a TCP port and send and receive characters via udp. If you have a patched version of netcat which activates telnet remote echo and single char transfer, then you can use the following options to step up a netcat redirector to allow telnet on port 5555 to access the qemu port.

Qemu Options:

-serial udp::4555@:4556
netcat options:

-u -P 4555 -L 0.0.0.0:4556 -t -p 5555 -I -T
telnet options:

localhost 5555

`-monitor dev'

Redirect the monitor to host device dev (same devices as the serial port). The default device is vc in graphical mode and stdio in non graphical mode.


Sorry for the super-lengthy code segment.

Last edited by IsharaComix; 10-14-2008 at 09:58 AM. Reason: way too long. T_T
 
Old 10-14-2008, 05:20 PM   #9
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Rep: Reputation: 51
gvidm is a great tool
and having a proper /etc/X11/Xorg.conf
 
Old 12-18-2008, 05:52 AM   #10
nabilalk
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
Question Do I have to use the terminal?

Quote:
Originally Posted by Unknown_User View Post
Your xorg.conf has very little detail in it which is normal for virtual machine installations.

You should add the following lines directly after Section "Screen" so that it reads;

Code:
Section "Screen"
	Identifier	"Default Screen"
        Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	16
	SubSection "Display"
		Depth		16
		Modes		"1024x768"
	EndSubSection
EndSection
In order to do this you should press Ctrl-Alt-F1 to go to a terminal.

In Ubuntu type
Code:
sudo vi /etc/X11/xorg.conf
and edit the file. If you aren't familiar with vi then google it for instructions but simply put you need to press 'i' to go into insert mode, make the changes and when you have finished press 'escape' and type
Code:
:wq!
which will write the changes and quit.

You can then press Ctrl-Alt-F7 to go back to the GUI and then Ctrl-Alt-backspace to restart the Xserver.

Hopefully it will work fine at 1024x768. You can keep changing the xorg.conf until it breaks.

Best of luck...
Can't I just edit the xorg.conf file through a text editor? If not, why?
Thanks!

-nka
 
Old 12-18-2008, 09:14 AM   #11
IsharaComix
Member
 
Registered: Sep 2008
Location: Raleigh
Distribution: Ubuntu 8.10
Posts: 88
Blog Entries: 1

Original Poster
Rep: Reputation: 15
You can't just open it up in gedit or mousepad natively because it's a locked system file. You need to edit the file with superuser privileges, and to do that, you need the terminal. If you were able to open it, you still won't be able to save it.

Secondly, if you follow Unknown_User's advice and use Ctrl+Alt+F1, you'd have to mess around with some extra variables to make the graphical editor show up.

It's easy enough just to edit it in the terminal. If you don't like Vim or emacs, just use Nano.

~$sudo nano /etc/X11/xorg.conf

That's what I do. Hope this helped.
 
Old 12-18-2008, 10:31 AM   #12
nabilalk
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by IsharaComix View Post
You can't just open it up in gedit or mousepad natively because it's a locked system file. You need to edit the file with superuser privileges, and to do that, you need the terminal. If you were able to open it, you still won't be able to save it.

Secondly, if you follow Unknown_User's advice and use Ctrl+Alt+F1, you'd have to mess around with some extra variables to make the graphical editor show up.

It's easy enough just to edit it in the terminal. If you don't like Vim or emacs, just use Nano.

~$sudo nano /etc/X11/xorg.conf

That's what I do. Hope this helped.
Hi, I noticed that earlier. Vim was a little foreign, so I will try nano. Thanks.
 
Old 12-22-2008, 11:41 PM   #13
marshtric
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 0
post the Screen and Monitor section here.
 
Old 12-23-2008, 01:16 AM   #14
tailender
LQ Newbie
 
Registered: Oct 2006
Posts: 27

Rep: Reputation: 15
Refer this article on how to change your desktop resolution
http://linuxtuts.blogspot.com/2008/0...esolution.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change screen resolution of xdm login screen in suse linux pseudoxiah Linux - Desktop 2 04-02-2007 09:26 AM
How can I change my screen resolution? Thaidog Linux - Newbie 1 12-24-2006 10:43 PM
Screen resolution doesn't change? flabbergasted Ubuntu 14 11-18-2006 10:43 PM
Xubuntu screen resolution problem and no net connection Ishkabibble Linux - Newbie 1 09-07-2006 08:36 AM
Cannot change screen resolution codeman9 Fedora - Installation 1 11-18-2005 11:42 PM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration