LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-27-2011, 07:58 PM   #1
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,609

Rep: Reputation: 45
Change "Logout" layout from XFCE


hi

I've Debian Squeeze with XFCE desktop installed.
If I would like to logout, then I get some options like: suspend, hibernate, logout etc.
Howto change them to get just shutdown and reboot displayed?

Last edited by cccc; 03-27-2011 at 08:26 PM.
 
Old 03-27-2011, 08:48 PM   #2
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,609

Original Poster
Rep: Reputation: 45
"Suspend" and "Hibernate" I can easily disable using these commands:
Code:
# xfconf-query -c xfce4-session -np '/shutdown/ShowSuspend' -t 'bool' -s 'false'
# xfconf-query -c xfce4-session -np '/shutdown/ShowHibernate' -t 'bool' -s 'false'
but it doesn't work if I try to disable "Logout" in the same way:
Code:
# xfconf-query -c xfce4-session -np '/shutdown/ShowLogout' -t 'bool' -s 'false'
Even doesn't work if I try to edit directly:

/home/user/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml.

Knows someone howto disable "Logout" button from the logout dialog under XFCE?

Last edited by cccc; 03-28-2011 at 07:31 AM.
 
Old 09-25-2012, 05:55 PM   #3
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,609

Original Poster
Rep: Reputation: 45
I've solved this problem now:

change in /usr/share/applications/xfce4-session-logout.desktop:
Code:
[Desktop Entry]
Version=1.0
Type=Application
Exec=/usr/bin/xfce4-session-shutdown.sh
Icon=system-log-out
StartupNotify=false
Terminal=false
Categories=System;X-XFCE;X-Xfce-Toplevel;
OnlyShowIn=XFCE;
Name=Log Out
and using this shutdown script /usr/bin/xfce4-session-shutdown.sh:
Code:
#! /bin/sh
sudo /sbin/shutdown -h now $*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How do I run "menu" and "logout" from the command line in fluxbox? psionl0 Slackware 19 03-02-2011 12:46 AM
How to set "change key layout" konzo Linux - Newbie 3 10-06-2010 06:04 PM
[SOLVED] Xfce panel's "quit" button not working correctly; logout is also delayed... MrCode Linux - Desktop 5 09-02-2010 04:59 AM
How do I disable "shutdown" and "restart" options in KDE logout screen for all users? maxgsp Linux - Distributions 1 12-12-2008 03:18 PM
KDE "Logout" and "Lock Session" menu restoration powah Linux - Software 3 03-29-2005 08:02 PM


All times are GMT -5. The time now is 08:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration