LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   can not change fluxbox font (http://www.linuxquestions.org/questions/linux-desktop-74/can-not-change-fluxbox-font-828344/)

rusyd 08-25-2010 04:59 AM

can not change fluxbox font
 
This is my first time using fluxbox.
I installed fluxbox on Gentoo Linux.
I have read fluxbox wiki about font and done instruction in it, but nothing happened. I'm still unable to change fluxbox font.
I also checked whether my desired font is detected by X with xfontsel.
Maybe I miss some package.
Any help?

xeleema 08-25-2010 05:41 AM

Greetingz!

If you're trying to change the font of the Fluxbox menus / window titles / etc, try the following methods;

1) Have you attempted to setup a StyleOverlay?

2) If that still doesn't work, try changing the default font(s) for your (create / edit ~/.Xdefaults)

! `xrdb -load ~/.Xdefaults'
! Color section

XTerm*background: #000000
XTerm*foreground: #cfcfcf
XTerm*cursorColor: #cdc092

! black
XTerm*color0: #000000
! red
XTerm*color1: #e01010
! green
XTerm*color2: #20ad20
! yellow
XTerm*color3: #d4c24f
! blue
XTerm*color4: #231bb8
! purple
XTerm*color5: #9c3885
! cyan
XTerm*color6: #1dbdb8
! white
XTerm*color7: #fefefe
! bright-black
XTerm*color8: #6a6a6a
! bright-red
XTerm*color9: #e83a3d
! bright-green
XTerm*color10: #35e956
! bright-yellow
XTerm*color11: #ffff2f
! bright-blue
XTerm*color12: #3a53f0
! bright-purple
XTerm*color13: #e628ba
! bright-cyan
XTerm*color14: #1cf5f5
! bright-white
XTerm*color15: #ffffff

! Nice for manpages
!XTerm*underLine: on
!XTerm*colorMode: on
XTerm*colorBD: lightyellow
!XTerm*colorBDMode: off
XTerm*colorUL: blue
!XTerm*colorULMode: on

XTerm*dynamicColors: on
XTerm*highlightSelection: true

XTerm*eightBitInput: false
XTerm*metaSendsEscape: true
!XTerm*oldXtermFKeys: true
XTerm*charClass: 33:48,35-38:48,39:43,42-47:48,58-59:48,61:48,63-64:48,126:48
!XTerm*charClass: 46-47:48,58:48,64:48,63:48,95:48,126:48,61:48,37:48,35:48,43:48,36:48

! Other settings
XTerm*VT100.Translations: #override \
! <Key>BackSpace: string(0x7F)
!\n\
<Key>Delete: string("\033[3~")\n\
! <Key>Home: string("\033OH")\n\
! <Key>End: string("\033[4~")
! <Key>Home: string("\033[1~")\n\
XTerm*ttyModes: erase ^?

! Suggested by denek
! *VT100*backarrowKey: false
!XTerm*backarrowKeyIsErase: true
!XTerm*backarrowKey: true
!XTerm*borderWidth: 0 doesn't do anything
XTerm*internalBorder: 0
!XTerm*modifier: alt
XTerm*saveLines: 80000
XTerm*scrollBar: true
!XTerm*titeInhibit: true

XTerm*faceName: Vera sans mono
XTerm*faceSize: 5
XTerm*termName: xterm-xfree86

XDvi*mfMode: ljfour
XDvi*pixelsPerInch: 1200
XDvi*shrinkFactor: 8
!XDvi*paper: a5
XDvi*wwwBrowser: firefox
XDvi*thorough: true
XDvi*foreground: #202020
XDvi*background: #eeeeee
XDvi*underLink: true
XDvi*font: ter-120b
xpdf*initialZoom: width

rusyd 08-25-2010 09:07 AM

Quote:

Originally Posted by xeleema (Post 4077024)
1) Have you attempted to setup a StyleOverlay?

Yes, I have configured font using overlay as mentioned in wiki. No change.

Quote:

Originally Posted by xeleema (Post 4077024)
2) If that still doesn't work, try changing the default font(s) for your (create / edit ~/.Xdefaults)

In your .Xdefault sample, I don't know in which line I can setup my desktop font.
I read Xdefault wiki and I don't find any syntax to setup desktop font.

Thanks

rusyd 08-25-2010 11:22 AM

Finally I can change the font. But it works only for x-fonts, not ttf-fonts.
Maybe fluxbox can't detect my ttf fonts.
I have added ttf fonts directory to /etc/fonts/fonts.conf and run fc-cache but fluxbox still can't detect ttf fonts.

rusyd 08-25-2010 11:59 AM

solved!
I forgot to compile fluxbox with truetype support.
What a shame :)

xeleema 08-26-2010 12:21 AM

Quote:

Originally Posted by rusyd (Post 4077333)
solved!
I forgot to compile fluxbox with truetype support.
What a shame :)

Awesome! Thanks for posting the fix! I've "Found your post Helpful" your post!


All times are GMT -5. The time now is 06:16 AM.