LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-09-2010, 04:21 AM   #1
magoot
Member
 
Registered: Feb 2005
Location: Finland
Distribution: Debian testing
Posts: 38

Rep: Reputation: 15
Blurry fonts after system reinstall


Hi!

I have a question about fonts in Xorg, i recently reinstalled my home computer and dist-upgraded to Debian testing. Then i copied some fonts, Verdana, Arial and so on from my work computer and placed them in /usr/share/fonts/windows (exactly as my work computer, which is also running Debian testing, however not dist-upgraded for a couple of months).

I noticed the fonts looked bad, so i made a simple web page that lists some strings with different fonts, and took screenshots of them on both computers (and also a buddy's windows 7 computer for comparison).

As you can see the fonts on my home computer looks really bad. And it's not just Firefox, but all interface text looks like this, except in rxvt or xterm, where it looks good on both computers.

My work computer is running:
xserver-xorg 1:7.3+18
xserver-xorg-core 2:1.4.2-10
xfce4 4.6.1.2

My home computer is running:
xserver-xorg 1:7.5+3
xserver-xorg-core 2:1.7.5-1
xfce4 4.6.1.3

Anyone know how to fix this?
Please let me know if you need any more info.

// MagooT
Attached Images
File Type: png fonts.png (188.8 KB, 13 views)
 
Old 03-09-2010, 12:34 PM   #2
penguiniator
Member
 
Registered: Feb 2004
Location: Olympia, WA
Distribution: SolydK
Posts: 442
Blog Entries: 3

Rep: Reputation: 60
Step 1: search for "install fonts debian" on Google
Step 2: click a promising link, such as http://linuxandfriends.com/2009/07/2...ubuntu-debian/ (How to install fonts in Linux -- Ubuntu, Debian)

One other thing to check is the font settings in xfce. Make sure font smoothing is set up correctly. The link above will tell you that simply copying your fonts to a system font folder is not enough. That document will tell you more.
 
Old 03-09-2010, 12:51 PM   #3
magoot
Member
 
Registered: Feb 2005
Location: Finland
Distribution: Debian testing
Posts: 38

Original Poster
Rep: Reputation: 15
I have tried those steps in your link, run fc-cache -f -v as both root and regular user.
I have also tried creating the following ~/.fonts.conf
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit mode="assign" name="autohint" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>none</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>false</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintnone</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>
After that i have run fc-cache again, restarted X, rebooted, still the same problem.
The fc-list command shows that Arial, Verdana and so on are installed.
In Xfce's settings manager antialiasing was already checked, unchecking that makes the fonts look a lot worse. However when i change the "Hinting" value, nothing seems to happen, i'm thinking that hinting is the problem... Question is how do i enable it, and why is it not suddenly enabled seeing as every time i have installed debian on various computers the fonts have always looked great out of the box.
Wonder if there are any changes in the latest versions of Xorg or Xfce that could cause this problem?
 
Old 03-10-2010, 05:35 PM   #4
magoot
Member
 
Registered: Feb 2005
Location: Finland
Distribution: Debian testing
Posts: 38

Original Poster
Rep: Reputation: 15
Made some progress with this issue. I ran the following as root:

cd /etc/fonts/conf.d
ln -s ../conf.avail/10-autohint.conf .
ln -s ../conf.avail/10-sub-pixel-rgb.conf
dpkg-reconfigure fontconfig

Then rebooted and started X, now the fonts look real sharp and nice
This seems to enable some of the same settings i tried in ~/.fonts.conf but it didn't work there (as i had read it should have).
The fonts are not exactly the same when browsing the web as before, but at least now they are sharp and comfortable to look at.
 
Old 03-10-2010, 05:52 PM   #5
penguiniator
Member
 
Registered: Feb 2004
Location: Olympia, WA
Distribution: SolydK
Posts: 442
Blog Entries: 3

Rep: Reputation: 60
Also, if you are using Firefox, set gfx.use_text_smoothing_setting to true and maybe change the default fonts for serif, sans-serif, and monospace to something like Liberation Serif/Sans/Mono or your favorite font family.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crunchbang + Firefox = Blurry fonts? BlackSheep024 Ubuntu 1 04-15-2009 06:52 AM
Blurry default fonts on Fedora Core 6 azcn2503 Fedora 1 02-19-2007 03:28 PM
fonts in kde are blurry werfer Linux - General 2 02-03-2006 02:45 AM
Blurry fonts and slooow Chromium and TuxRacer datoda Linux - Newbie 2 09-20-2004 08:02 PM
too blurry antialiased fonts oski Mandriva 4 10-12-2003 02:22 PM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration