LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-24-2007, 10:20 PM   #1
SlowCoder
Member
 
Registered: Oct 2004
Location: Southeast, U.S.A.
Distribution: Fedora (Desktop), CentOS (Server), Knoppix (Diags)
Posts: 934

Rep: Reputation: 38
Beryl not default window manager?


I've installed Beryl with Gnome, and it's working beautifully. Really fun to play with when I have nothing else to do.

Now the bad news ... When I (re)start X it seems like Beryl isn't the default manager. My desktop seems to act like it's defaulting to Compiz. I have to go to Applications > System Tools > Beryl Manager to get the Beryl icon in the taskbar. Then I have to select Compiz as the window manager from the icon, then reselect Beryl to get my effects to work.

After that, Beryl works fine ... until I restart.

Any suggestions? Thanks.
 
Old 03-25-2007, 01:39 PM   #2
old_geekster
LQ Newbie
 
Registered: Mar 2007
Location: Walla Walla, WA
Distribution: Ubuntu Feisty Fawn 7.04 - Final
Posts: 19

Rep: Reputation: 0
Add Beryl-Manager to System/Preferences/Sessions/Startup Programs. This should start Beryl each time that you boot.

I hope that you are using Ubuntu. Otherwise, I am not sure my solution will work.

It is a good idea to include your distro in your question.

Good luck!
 
Old 03-25-2007, 01:48 PM   #3
SlowCoder
Member
 
Registered: Oct 2004
Location: Southeast, U.S.A.
Distribution: Fedora (Desktop), CentOS (Server), Knoppix (Diags)
Posts: 934

Original Poster
Rep: Reputation: 38
I'm using Fedora Core 6. Though it wasn't in exactly the same menu path as you stated, I was able to locate it. Now the manager loads, but I'm still having problems where it looks like it wants to start with the Compiz manager instead. I still have to change the settings each time.
 
Old 04-07-2007, 02:53 PM   #4
SlowCoder
Member
 
Registered: Oct 2004
Location: Southeast, U.S.A.
Distribution: Fedora (Desktop), CentOS (Server), Knoppix (Diags)
Posts: 934

Original Poster
Rep: Reputation: 38

I'm still having problems with this issue. For some reason, though the Beryl manager is loading, when I access "Select Window Manager" from the Beryl icon, it is defaulted to Metacity. Selecting Beryl as the manager works until I restart my machine, then reverts back to Metacity.

Has anyone else had this problem?
 
Old 05-04-2007, 11:03 AM   #5
Limbonic
LQ Newbie
 
Registered: Jun 2006
Location: 127.0.0.1
Distribution: (K)Ubuntu 7.04
Posts: 13

Rep: Reputation: 0
Gotta up this one...
Does anyone know how to make Beryl the default windows manager?
 
Old 05-04-2007, 02:34 PM   #6
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 30
Hi,
Along with adding "beryl-manager", you must also add "beryl" to the same startup location.

Source:
http://en.opensuse.org/Beryl#Making_..._automatically
(though it was written for suse, I suppose it will work for Gnome in general)

Sam
 
Old 05-04-2007, 06:58 PM   #7
Ryptyde
Member
 
Registered: Jun 2004
Location: Tragic City,Michigan,USA
Distribution: Fedora 18 Fedora 17
Posts: 242

Rep: Reputation: 37
If you have Beryl set as default wm then when there is a kernel update your gui will most likely crash if you have a nVidia card.
 
Old 05-04-2007, 07:11 PM   #8
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 30
Quote:
Originally Posted by Ryptyde
If you have Beryl set as default wm then when there is a kernel update your gui will most likely crash if you have a nVidia card.
That can be true. The beryl-manager does offer an option to autoload a backup WM in case beryl crashes, though, so I wouldn't worry. It just becomes a matter of re-installing the nvidia driver and rebooting.
 
Old 05-05-2007, 02:42 AM   #9
Limbonic
LQ Newbie
 
Registered: Jun 2006
Location: 127.0.0.1
Distribution: (K)Ubuntu 7.04
Posts: 13

Rep: Reputation: 0
I am a bit worried by that.
Can you please tell me where I have to tell Beryl to autoload a backup WM and how do I have to reinstall the nVidia drivers without WM?

I still got problems with making it teh deafult WM. I'm using Kubuntu. Whenever I restart X11 or reboot, KWin is up.

I added the links
Code:
ln -s /usr/bin/beryl-manager ~/.kde/Autostart/beryl-manager
ln -s /usr/bin/beryl ~/.kde/Autostart/beryl
And still I have to manually chose Beryl. When it starts, it shows 10 desktops, although I always reduce them to just four, but somehow Beryl does not seem to remember.

Thanks for all your input.
 
Old 05-05-2007, 02:54 AM   #10
Limbonic
LQ Newbie
 
Registered: Jun 2006
Location: 127.0.0.1
Distribution: (K)Ubuntu 7.04
Posts: 13

Rep: Reputation: 0
Somehow there seems to be an option that tells Beryl to show 10 Desktops even if the general setting is one desktop.
I am completely lost.
 
Old 05-05-2007, 03:02 AM   #11
Limbonic
LQ Newbie
 
Registered: Jun 2006
Location: 127.0.0.1
Distribution: (K)Ubuntu 7.04
Posts: 13

Rep: Reputation: 0
Ah ok, there was something wrong with emerald, I replaced it by aquamarine and then switched back to emeral, now I got the cube back.
But still there's the problem with making it default and preparing for kernel updates...
 
Old 05-05-2007, 04:13 AM   #12
h3x0r
LQ Newbie
 
Registered: Mar 2007
Location: 10.1.1.1
Distribution: Crux[main],Gentoo[Experimental]
Posts: 28

Rep: Reputation: 15
Hey to make beryl default for gnome desktop
in terminal:
gnome-session-properties
then add beryl to start-up programs:
beryl-manager
 
Old 05-05-2007, 06:41 AM   #13
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 30
OK, when you right-click on the beryl-manager diamond icon, you should see "Launch fall-back window manager if beryl crashes" or something like it. Enable that, and under the fall-back WM section, choose Kwin (if you're using KDE).

So the next time beryl crashes, it should seamlessly turn on Kwin. Even if it doesn't, X shouldn't crash anyway. You just won't have a WM

As for getting it to start automatically, people have noticed that Kubuntu isn't consistently starting up beryl using the standard autostart instructions.

Have a look here:
http://wiki.beryl-project.org/wiki/A...rt_for_Kubuntu

Sam
 
Old 05-06-2007, 06:16 AM   #14
Limbonic
LQ Newbie
 
Registered: Jun 2006
Location: 127.0.0.1
Distribution: (K)Ubuntu 7.04
Posts: 13

Rep: Reputation: 0
Thank you for that information!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Bring on the bling with Beryl: a look at a new Linux window manager LXer Syndicated Linux News 0 03-19-2007 03:31 PM
Beryl manager --- changing the window behaviour [minimizing] me4linux Linux - Software 3 03-16-2007 10:31 AM
[Beryl] Window manager defauting to compiz? LDJ Linux - General 2 02-28-2007 01:15 AM
Beryl Window Manager / Emerald Theme Manager Not Changing With ATi Drivers. Z3R0o Linux - Desktop 2 01-06-2007 11:23 PM
Default Window Manager Brian031168 Ubuntu 4 10-07-2005 01:11 PM


All times are GMT -5. The time now is 09:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration