LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 05-28-2008, 01:20 AM   #1
SMukhuti
Member
 
Registered: Jun 2006
Location: India
Distribution: PCLinux OS, Mint
Posts: 32

Rep: Reputation: 15
Audio not coming for mp4 video in Mandriva 2008 (free)


Hi,

I have Mandriva 2008 Free installed on my Desktop. I noticed that it failed to open mp4 video files and some avi files.

Recently I installed VLC media player (0.8.6c) and win32 codecs (1.8-2plf2007.1) which now helps me to play a wide variety of audio/video formats. Now, the problem is - I am able to play mp4 files, but the audio is not coming.

Can anybody help please?
 
Old 05-28-2008, 02:02 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
I use kaffeine and it has played all that I can throw at it.

I do not want to talk you into using something else....but can you show links to any mp4 and avi file that we can download and test pls?

2) it sounds like either sound is being grabbed and not released by another application or you have not configured vlc audio correctly?
 
Old 05-28-2008, 02:26 AM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
found a logfile if you run as normal user check /home/yourloginname/vlc-log.txt pls
 
Old 05-28-2008, 09:16 AM   #4
SMukhuti
Member
 
Registered: Jun 2006
Location: India
Distribution: PCLinux OS, Mint
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by aus9 View Post
found a logfile if you run as normal user check /home/yourloginname/vlc-log.txt pls
I was unable to find the vlc-log.txt file.

I tried to play using kaffeine, but with the same result. I found out that in Kaffeine, xine engine audio driver was set to auto. I tried to change it to oss, but it wouldńt allow me to do that and falled back to auto.

Error message: ¨Canṫ init new audio driver - oss. Falling back to auto.¨
 
Old 05-28-2008, 08:14 PM   #5
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
ahhhh....well that is good info thanks.

it sounds like (no pun intended) that you are missing a oss module.

run commands
Code:
su
lsmod
post your list of your snd module outputs pls

also we need to know what sound you are using is it onboard sound...name the chipset pls or name the soundcard pls
 
Old 05-28-2008, 08:16 PM   #6
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
BTW I use alsa and pulse.....have you tried to setup with root powers alsa?

su
alsaconf

then run a mixer to raise volumes and unmute any things you need?
 
Old 05-29-2008, 09:23 AM   #7
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 381

Rep: Reputation: 31
The first step I do in mandriva for the audio and video problems I install the mplayer codecs.
download the codecs from mplayerhu.hq and untar the codecs to these folders:
/usr/lib/codecs
/usr/local/lib/codecs

you will not find the folders in mandriva so create them (you will need the root account to do this)

this is the link of the full thread if you are interested

Good Luck
 
Old 05-29-2008, 01:17 PM   #8
SMukhuti
Member
 
Registered: Jun 2006
Location: India
Distribution: PCLinux OS, Mint
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by aus9 View Post
BTW I use alsa and pulse.....have you tried to setup with root powers alsa?

su
alsaconf

then run a mixer to raise volumes and unmute any things you need?
alsaconf command did worked


lsmod gave the below result

Module Size Used by
appletalk 32096 2
ipx 25188 2
p8022 2496 1 ipx
psnap 3620 2 appletalk,ipx
llc 6228 2 p8022,psnap
p8023 2304 1 ipx
af_packet 17960 0
snd_seq_dummy 3492 0
ipv6 249988 8
snd_seq_oss 29888 0
snd_seq_midi_event 6912 1 snd_seq_oss
snd_seq 46800 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 7276 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 37216 0
snd_mixer_oss 14784 1 snd_pcm_oss
video 15080 0
thermal 11304 0
sbs 16520 0
processor 25796 1 thermal
fan 4260 0
container 4032 0
button 6576 0
dock 7568 0
battery 10344 0
ac 4452 0
binfmt_misc 9416 1
loop 14276 0
nls_utf8 2496 5
ntfs 252840 5
dm_mod 48064 0
usb_storage 90276 0
scsi_mod 125356 1 usb_storage
floppy 54052 0
cpufreq_ondemand 7340 1
cpufreq_conservative 6600 0
cpufreq_powersave 2240 0
p4_clockmod 4996 0
speedstep_lib 5028 1 p4_clockmod
freq_table 4512 2 cpufreq_ondemand,p4_clockmod
nvram 8488 0
8139cp 19712 0
8139too 22816 0
mii 5280 2 8139cp,8139too
snd_hda_intel 284028 4
ati_agp 7596 0
snd_pcm 69636 3 snd_pcm_oss,snd_hda_intel
agpgart 27656 1 ati_agp
ide_cd 35200 0
snd_timer 19652 3 snd_seq,snd_pcm
snd_page_alloc 8456 2 snd_hda_intel,snd_pcm
i2c_piix4 8332 0
snd_hwdep 7492 1 snd_hda_intel
i2c_core 20224 1 i2c_piix4
snd 45092 15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwd ep
ohci_hcd 19972 0
soundcore 6624 1 snd
usbcore 118760 3 usb_storage,ohci_hcd
tsdev 7104 0
evdev 8448 3
ext3 118408 2
jbd 50504 1 ext3
ide_disk 14624 9
atiixp 5616 0 [permanent]
ide_core 99748 4 usb_storage,ide_cd,ide_disk,atiixp


Soundcard as noted from harddrake:

Vendor: ‎ATI Technologies Inc

Description: ‎SB450 HDA Audio

I have a Intel D101GGC motherboard.

Last edited by SMukhuti; 05-29-2008 at 01:21 PM.
 
Old 05-31-2008, 09:18 PM   #9
SMukhuti
Member
 
Registered: Jun 2006
Location: India
Distribution: PCLinux OS, Mint
Posts: 32

Original Poster
Rep: Reputation: 15
Any update on this?
 
Old 05-31-2008, 09:46 PM   #10
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
well it appears not to be oss from your lsmod outputs I can see oss.

I mentioned that I use alsa.....oss is a kind of older system.....maybe you have got confused and think you must run audio via oss?

2) can you post some links to some files that you are not getting any sound pls

3) did you try installing codecs in case you are missing the relevant codec for the audio file? as suggested by AGazzaz
 
Old 06-01-2008, 09:15 AM   #11
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 381

Rep: Reputation: 31
I noticed something...

Quote:
Originally Posted by SMukhuti View Post
Hi,

I have Mandriva 2008 Free installed on my Desktop. I noticed that it failed to open mp4 video files and some avi files.

Recently I installed VLC media player (0.8.6c) and win32 codecs (1.8-2plf2007.1) which now helps me to play a wide variety of audio/video formats. Now, the problem is - I am able to play mp4 files, but the audio is not coming.

Can anybody help please?
I had problems installing old packages with my Mandriva 2008, I wonder how you did it? Was this package from Mandriva's Package Manager?

And as aus9 asked, a link will be definitely useful.
 
Old 06-01-2008, 09:55 AM   #12
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
I do not use VLC myself (pulls in too much of Gnome) so I do not know whether it has some codecs built in or it depends fully on external codecs installed into system. However, I do know FFmpeg supports many video and audio formats, including AAC (MP4 audio). Of course, FFmpeg takes lots of compile-time options, make sure your FFmpeg is built with AAC support. Win32 codecs really aren't necessary nowadays.
 
Old 06-01-2008, 11:11 AM   #13
SMukhuti
Member
 
Registered: Jun 2006
Location: India
Distribution: PCLinux OS, Mint
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by AGazzaz View Post
I noticed something...



I had problems installing old packages with my Mandriva 2008, I wonder how you did it? Was this package from Mandriva's Package Manager?

And as aus9 asked, a link will be definitely useful.
Yes, I just did it form package manager. It didn't returned an error. I also have ffmpeg installed. Maybe a conflict? I'll try un-installing win32 codec and get back.

I can't upload a link since the files are huge - 800MB mp4 files (Originally converted from avi for my iPod )

Last edited by SMukhuti; 06-01-2008 at 11:13 AM.
 
Old 06-01-2008, 10:00 PM   #14
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
well why can you not play them as avi?

I can play avis on kaffeine from my digital camera....and I do not have win32 codecs installed on my free 2008.1
 
Old 06-03-2008, 01:32 PM   #15
SMukhuti
Member
 
Registered: Jun 2006
Location: India
Distribution: PCLinux OS, Mint
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by aus9 View Post
well why can you not play them as avi?

I can play avis on kaffeine from my digital camera....and I do not have win32 codecs installed on my free 2008.1
I can play avi but actually I store a lot of mp4's in my hard drive to sync with my iPod.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Perfect Server - Mandriva 2008 Spring Free (Mandriva 2008.1) LXer Syndicated Linux News 0 04-10-2008 04:10 PM
MP4 with Xine.. I have video but no audio darkone66669 Linux - Software 1 03-04-2008 05:37 AM
Mandriva 2008 Fails To Update Mandriva 2007 Spring Free max53000 Mandriva 1 10-20-2007 04:53 AM
LXer: The Perfect Desktop - Mandriva 2008 Free (Mandriva 2008.0) LXer Syndicated Linux News 0 10-16-2007 07:20 PM
LXer: The Perfect Server - Mandriva 2008 Free (Mandriva 2008.0) LXer Syndicated Linux News 0 10-11-2007 09:41 PM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration