LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 11-09-2006, 02:16 PM   #1
Gavvo
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Rep: Reputation: 0
artsd -> /dev/dsp "no such device"


I am trying to get cd's to play on my computer at work. I believe it is running slackware, and I am using KDE. The cdplayer thinks it is playing, but no sound comes out of the headphone jack or the speaker jack (with headphones plugged in). When I go to control panel -> sound & multimedia -> sound system and click test nothing happens.

I have tried starting artsd from the command prompt, and this is what I get:

> artsd
unix_connect: can't connect to server (unix:/tmp/mcop-gavin/dev10_flr-engineering_local-170a-455387b3)
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)

when I look in /dev I can see dsp@ in blue which points to dsp0 in yellow (dsp1 through dsp3 are also in yellow), and if I run artsd -d /dev/dsp1 I get the same error (/dev/dsp1 can't be opened)

I am a member of the groups audio, cdrom, disk, and a few others, and can sudo if necessary (although I don't want to ruin anything)

I know enough about linux to move through directories and look at their contents but that is about it. Can anybody help me?

Thanks for any advice you could give (even if I don't know what you're talking about).

-G
 
Old 11-11-2006, 01:26 AM   #2
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
Please don't be offended if you've tried this, but one of the
most common problems I've seen (and done my self) is to forget
to turn up the volume...In the KDE desktop applications menu
this would be Multimedia -> Kmix and check the levels...
Also if you're running ALSA try alasmixer at the command line, I.E.:
user@host:~$alsamixer
 
Old 11-11-2006, 03:49 AM   #3
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
First check if /dev/dsp exists. In my case it's a symlink so you need to follow that:
Code:
pu@slackw:~$ v /dev/dsp
lrwxrwxrwx 1 root root 9 2006-11-11 09:47 /dev/dsp -> sound/dsp
pu@slackw:~$ v /dev/sound/dsp
crw-rw--w- 1 root audio 14, 3 2006-11-11 09:47 /dev/sound/dsp
As you see you need to be in group audio, maybe you aren't. Try
Code:
pu@slackw:~$ groups
users disk audio video cdrom games scanner
Finally, your sound card might not have been recognised. As root, run "alsaconfig" to see if your card is recognized.

Finally... it helps to KNOW what distro and what version you are using. If it's Slackware, post the result of
Code:
pu@slackw:~$ cat /etc/slackware-version
Slackware 11.0.0
 
Old 11-12-2006, 02:57 PM   #4
Gavvo
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Alright, so here are the results of all the things letitgo and uselpa suggested I check

gavin@dev10:~$ cat /etc/slackware-version
Slackware 10.2.0

gavin@dev10:~$ groups
disk wheel floppy audio video cdrom users

gavin@dev10:~$ v /dev/dsp
lrwxrwxrwx 1 root root 4 2006-11-03 14:04 /dev/dsp -> dsp0

gavin@dev10:~$ v /dev/sound/dsp
/usr/bin/ls: /dev/sound/dsp: No such file or directory

gavin@dev10:~$ sudo alsaconfig
Password:
sudo: alsaconfig: command not found
gavin@dev10:~$ alsaconfig
-bash: alsaconfig: command not found

gavin@dev10:~$ alsamixer
alsamixer: function snd_ctl_open failed for default: No such device or address

Also, when I loaded KDE today I got an error saying "Sound server informational message: Error while initializing the sound driver: device: default can't be opened for playback (No such device or address) The sound server will continure, using the null output device.". Under control center when I loaded KDE today under 'Sound System -> Hardware -> Select the audio device' it was set to ALSA, rather than autodetect. When it runs on autodetect I don't get that error.

When I load Kmix from the K menu -> multimedia I get a box which has a pull-down tab labelled "current mixer", but with nothing to select in the pull-down part. Under "Sound Server Control (aRts control tool)" the volume looks like it is all the way up. In the same program if I open the aRts Status window it says "Artsd should run with realtime scheduling but is does not (Is artswrapper suid root?)"

Anyway, if any of this means anything to you, or if there is anything else I can check and get back to you about, please let me know.

Thanks for your help so far,
Gavin.
 
Old 11-12-2006, 02:59 PM   #5
Gavvo
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Oh, and in /dev/ there is no ./sound/ subdirectory, but there is a ./snd/ subdirectory.

gavin@dev10:~$ v /dev/snd/dsp
/usr/bin/ls: /dev/snd/dsp: No such file or directory

Cheers,
Gavin
 
Old 11-12-2006, 03:00 PM   #6
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
What's the result of "v /dev/dsp0"?
Do not use "sudo alsa*", but get root using "su -" (the dash is important) and retry alsaconfig and alsamixer.
 
Old 11-12-2006, 04:41 PM   #7
Gavvo
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
gavin@dev10:~$ v /dev/dsp0
crwxrwxrwx 1 root audio 14, 3 2003-08-29 03:47 /dev/dsp0

And I can't get root access. The company is getting big enough that anyone but the administrator having root access means the administrator (who is also a lead programmer) doesn't have time to do anything but fix other people's mistakes (other people like me, who don't know anything). Aynway, would that make a difference? If I needed root access to use alsaconfig wouldn't it tell me that instead of saying "command not found"?

In ALSA-Configuration.txt it says "To enable ALSA support you need at least to build the kernel with
primary sound card support (CONFIG_SOUND)." Could that have something to do with it?

Thanks,
Gavin.
 
Old 11-12-2006, 07:13 PM   #8
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
Quote:
If I needed root access to use alsaconfig wouldn't it tell me that instead of saying "command not found"?
No. Root has commands and permissions available that a user
doesn't. For instance, try the command "adduser" and the shell won't find it either.

Quote:
ALSA-Configuration.txt it says "To enable ALSA support you need at least to build the kernel with
primary sound card support (CONFIG_SOUND)." Could that have something to do with it?
Yes--without kernel support alsa won't work. It is possible that
sound is not enabled at the kernel level. If so, changing
that requires a kernel recompile. But if your supervisor went
through the trouble to compile a custom kernel without sound,
the only way I know to change that condition without the root
password is to re-install Slackware. But you know, that doesn't
sound like a path for career advancement

You could check the state of sound a few ways. If you go to the
main kde menu, under System you may find KinfoCenter. If it's
there, open it and look under Sound. You should get a list on the
right panel of sound drivers and audio devices etc. You could also
go to the terminal and try:

lsmod | less

This should give you a scrollable list of kernel modules
(including sound, I.E.,snd modules). Oh, and I'm guessing you
already checked to see if a sound card is installed. Unfortunately,
I don't think lspci will work without root privileges
...humm...perhaps a portable CD player's in your future?

But seriously, if you have drivers, modules, and a sound card
installed, there's usually a way to get it all working. Also, I'm
guessing you'd prefer not to ask that lead programmer about it.
 
Old 11-13-2006, 08:33 AM   #9
Gavvo
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
So under KInfoCenter -> Sound it says "No information available about the sound card".

And "lsmod | less" shows "soundcore" as a Module.

Anyway, since I'm only here for three weeks I figured there was no point in buying a new discman (I have two that no longer play cds, thank you Disposable North-American Society TM), but I have acquired one from a friend. So thanks for all your help. Anyway, I'm learning how to use this machine better, so it wasn't an entirely useless exercise.

Cheers,
Gavin.
 
Old 11-13-2006, 01:31 PM   #10
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
Sorry I couldn't help more but unless someone else has an idea about how to go
forward from here with user permissions I'm at a loss. But for completness, it
seems that dsp0 and you have the group "audio" in common, and sound is enabled in
the kernel. Fyi, the part of my modules list that deals with alsa and sound
looks like this:

snd-ens1371 11776 1
gameport 1388 0 [snd-ens1371]
snd-rawmidi 12224 0 [snd-ens1371]
snd-seq-device 3716 0 [snd-seq-oss snd-seq snd-rawmidi]
snd-ac97-codec 68160 0 [snd-intel8x0 snd-ens1371]
snd-pcm 52804 0 [snd-pcm-oss snd-intel8x0 snd-ens1371 snd-ac97-codec]
snd-timer 13168 0 [snd-seq snd-pcm]
snd 34304 2 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ens1371 snd-rawmidi snd-seq-device snd-ac97-codec snd-pcm snd-timer]
snd-page-alloc 4980 0 [snd-seq-oss snd-seq snd-mixer-oss snd-intel8x0 snd-rawmidi snd-seq-device snd-pcm snd-timer snd]
soundcore 3300 12 [snd]

The first one, "snd-ens1371" is the alsa driver for my sound card.

The only time I've personally experienced the problem you describe is when the
wrong driver was installed for my sound card. If you want to persue this, and
no one here can help, I've found the audio-users list at

linux-audio-user@music.columbia.edu

Perhaps slightly less friendly than LQ, but has members quite expert in linux sound issues..

Be well,
Lawrence
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"/dev/dsp not found" error on KDE, GNOME sound also doesn't work KneeLess Linux - Software 3 09-04-2007 03:41 PM
Could not open device "/dev/dsp" for writing bhomass Debian 7 11-16-2005 03:04 PM
problem in giving sound input through "/dev/dsp" b0nd Linux - Newbie 1 03-14-2005 10:16 PM
"/dev/dsp: Device or resource busy" Cdzin Linux - Hardware 4 02-25-2004 06:39 AM
another "device /dev/dsp can't be opened (device does not exist)" in DEBIAN, woody Kroppus Linux - Hardware 12 11-13-2003 12:23 PM


All times are GMT -5. The time now is 02:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration