LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 10-01-2009, 06:35 PM   #1
squirrel-the-tire
LQ Newbie
 
Registered: Oct 2009
Posts: 9
Blog Entries: 2

Rep: Reputation: 0
Another X sever on a second display


I know you can have GNOME running, and run KDE on vt9 like this:
press ctrl+alt+2 to switch to virtual terminal 2,
login
xinit -- :1 vt9
startKDE -- :1 vt9
And then you would be able to press ctrl+alt+F7 to go to GNOME, and ctrl+alt+F9 to switch to KDE.

But is there a way to run another X server in a second display, for example: Run GNOME on one monitor, and KDE on the other?

I have an ATI All-in-wonder card, (Pretty much a Radeon 9600 with extra featurs), with the fglrx driver. Running Ubuntu 8.10 (ATI is too lazy to improve their drivers for 9.04)
 
Old 10-01-2009, 06:50 PM   #2
somedude
Member
 
Registered: Nov 2003
Distribution: Mint, openSUSE, Mandriva, Knoppix, puppy, Arch
Posts: 68

Rep: Reputation: 16
I don't think you can run more than one instance of the graphical server (X), but you may be able to assign a monitor for each window manager.
 
Old 10-02-2009, 02:16 PM   #3
squirrel-the-tire
LQ Newbie
 
Registered: Oct 2009
Posts: 9
Blog Entries: 2

Original Poster
Rep: Reputation: 0
I want to run GNOME on one monitor, and KDE on the other.
 
Old 10-02-2009, 02:39 PM   #4
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,049

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
It depends only in how well do gnome and kde behave. For example, I have a dual setup without xrandr and I have no problem to run fvwm in one monitor and openbox in the other.

But first, you need to setup X so it doesn't use xrandr, xinerama or any of that stuff.

For fglrx, you need to do this to disable xrandr (and this is only for fglrx):

Code:
# aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"
You can verify that it worked this way:

Code:
# grep RandR /etc/ati/amdpcsdb
EnableRandR12=SFALSE
If everything is right, then you need to setup your xorg.conf for a dual head setup. This is mine as a guide:

Code:
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        Screen         "aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-0"
#       Option "Xinerama" "false"
EndSection

Section "Files"
        FontPath "/usr/share/fonts/100dpi"
        FontPath "/usr/share/fonts/75dpi"
        FontPath "/usr/share/fonts/corefonts"
        FontPath "/usr/share/fonts/dejavu"
        FontPath "/usr/share/fonts/hunkyfonts"
        FontPath "/usr/share/fonts/intlfonts"
        FontPath "/usr/share/fonts/liberation-fonts"
        FontPath "/usr/share/fonts/misc"
        FontPath "/usr/share/fonts/terminus"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
#       Option       "DPMS" "true"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-1"
#       Option       "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
        Option                  "ForceMonitors" "notv"
        Option                  "MonitorLayout" "CRT,DFP"
        Option                  "XaaNoOffscreenPixmaps"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-1"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
        Option                  "XaaNoOffscreenPixmaps"
        Screen      1
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Modes "1600x1200"
                Depth     24
        EndSubSection
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-1"
        Device     "aticonfig-Device[0]-1"
        Monitor    "aticonfig-Monitor[0]-1"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Modes "1680x1050"
                Depth     24
        EndSubSection
EndSection
I launch X via startx, so it honors ~/.xinitrc, the two relevant lines in my .xinitrc file are these:

Code:
DISPLAY=:0.1 openbox > ${HOME}/logs/openbox.log 2>&1 &
fvwm -s 0 > ${HOME}/logs/fvwm.log 2>&1
The concrete syntax will depend on the WM's/DE's involved. I have no idea if startkde and gnome-session support this feature. First check if they have some command line switch to specify the screen or display, if not, try to set the DISPLAY var as in my example. If that doesn't work, you will have to dive into the startkde and/or gnome-session script(s) and see what's inside.

Last edited by i92guboj; 10-02-2009 at 02:42 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sever shutdown amena Linux - Server 3 04-11-2007 04:20 PM
SME sever emailssent Linux - Networking 5 11-01-2004 10:04 PM
file sever civicracer999 Linux - Networking 2 07-24-2004 12:04 AM
Should I buy a sever!? zetsui Linux - Hardware 9 01-25-2004 07:38 PM
X Sever Crash chutzpah Linux - Software 5 04-30-2003 05:06 AM


All times are GMT -5. The time now is 10:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration