LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-29-2006, 05:41 PM   #1
simbobo
LQ Newbie
 
Registered: Jan 2006
Location: Hampshire, UK
Distribution: Debian Lenny - it may be testing, but XP is a lot more testing!
Posts: 27

Rep: Reputation: 15
alsa not loading


Since an alsa update (I think), I have to run alsaconfig after each time I boot. Obviously some configuration or startup file is wrong or missing, but I don't really know where to look. Any ideas?

I'm running Debian Etch

alsa-base 1.0.11-2
alsa-utils 1.0.11-4

thanks
 
Old 08-30-2006, 03:56 AM   #2
sooty
LQ Newbie
 
Registered: Nov 2002
Location: birmingham england
Distribution: Gentoo
Posts: 26

Rep: Reputation: 15
If you boot and then run lsmod you can see what modules you have loaded ,you can then run alsaconfig to load the alsa modules and then run lsmod again and see witch extra alsa mods have been loaded.
once you know witch mods are needed for alsa you can add them to the auto module load file in etc I,m not sure what its called under debian but under gentoo its /etc/modules.autoload.d/<kernel version>
There is usually a start up script called alsasound that needs adding to your startup default run level that takes care of most of this and also calls alsactl restore so that you have not got to run alsa mixer every time.
 
Old 08-30-2006, 04:00 AM   #3
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
after you've run alsaconfig as root (which should load the appropriate module), run (still as root)
Code:
alsactl store
that should save any changes you've made.
 
Old 08-30-2006, 09:19 AM   #4
simbobo
LQ Newbie
 
Registered: Jan 2006
Location: Hampshire, UK
Distribution: Debian Lenny - it may be testing, but XP is a lot more testing!
Posts: 27

Original Poster
Rep: Reputation: 15
thanx guys
 
Old 08-31-2006, 12:40 PM   #5
simbobo
LQ Newbie
 
Registered: Jan 2006
Location: Hampshire, UK
Distribution: Debian Lenny - it may be testing, but XP is a lot more testing!
Posts: 27

Original Poster
Rep: Reputation: 15
Unhappy

Quote:
Originally Posted by pwc101
after you've run alsaconfig as root (which should load the appropriate module), run (still as root)
Code:
alsactl store
I tried this approach first and it doesn't help

Quote:
Originally Posted by sooty
run alsaconfig to load the alsa modules and then run lsmod again and see which extra alsa mods have been loaded.
then I went to this. The only difference is that after I run alsaconfig rtc is no longer loaded. I am sure there is no other difference, having piped and sorted lsmod before and after.

I haven't found where Debian keeps its version of modules.autoload yet, but when I do I don't know if I can remove rtc, as I don't know what it is!!
 
Old 08-31-2006, 01:09 PM   #6
sooty
LQ Newbie
 
Registered: Nov 2002
Location: birmingham england
Distribution: Gentoo
Posts: 26

Rep: Reputation: 15
Ok if all the modules are beening loaded during boot and you have previously used alsactl store to save your setingd try booting from scracth and enter alsactl restore if the sound works then you will have to include this command in one of your startup files if it does not enable sound try removing the rtc module ( login as root and enter modprobe -r rtc )
this will remove rtc from the current session in order to remove it permantly you will have to remove it from a start up file.
Let us know how you get on

Last edited by sooty; 08-31-2006 at 01:12 PM.
 
Old 09-01-2006, 04:33 AM   #7
simbobo
LQ Newbie
 
Registered: Jan 2006
Location: Hampshire, UK
Distribution: Debian Lenny - it may be testing, but XP is a lot more testing!
Posts: 27

Original Poster
Rep: Reputation: 15
I've now discovered the problem's different to what I thought - when I log in with xfce it's all fine - with Gnome there's no sound until alsaconfig...!?!
 
Old 09-04-2006, 04:59 PM   #8
simbobo
LQ Newbie
 
Registered: Jan 2006
Location: Hampshire, UK
Distribution: Debian Lenny - it may be testing, but XP is a lot more testing!
Posts: 27

Original Poster
Rep: Reputation: 15
Well my solution is just use XFCE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa not loading in Debian/Sarge bender324 Linux - Newbie 5 01-23-2006 07:23 PM
ALSA loading? chrtur Linux - Newbie 1 02-28-2005 12:44 PM
alsa-mixer not loading bobbens Debian 10 10-26-2004 12:19 PM
loading the ALSA module ViN86 Slackware 3 04-10-2004 11:34 PM
ALSA not loading at startup Thetargos Linux - Hardware 1 04-30-2003 11:22 PM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration