LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   alsa not loading (http://www.linuxquestions.org/questions/linux-desktop-74/alsa-not-loading-478546/)

simbobo 08-29-2006 05:41 PM

alsa not loading
 
Since an alsa update (I think), I have to run alsaconfig after each time I boot. Obviously some configuration or startup file is wrong or missing, but I don't really know where to look. Any ideas?

I'm running Debian Etch

alsa-base 1.0.11-2
alsa-utils 1.0.11-4

thanks

sooty 08-30-2006 03:56 AM

If you boot and then run lsmod you can see what modules you have loaded ,you can then run alsaconfig to load the alsa modules and then run lsmod again and see witch extra alsa mods have been loaded.
once you know witch mods are needed for alsa you can add them to the auto module load file in etc I,m not sure what its called under debian but under gentoo its /etc/modules.autoload.d/<kernel version>
There is usually a start up script called alsasound that needs adding to your startup default run level that takes care of most of this and also calls alsactl restore so that you have not got to run alsa mixer every time.

pwc101 08-30-2006 04:00 AM

after you've run alsaconfig as root (which should load the appropriate module), run (still as root)
Code:

alsactl store
that should save any changes you've made.

simbobo 08-30-2006 09:19 AM

thanx guys

simbobo 08-31-2006 12:40 PM

Quote:

Originally Posted by pwc101
after you've run alsaconfig as root (which should load the appropriate module), run (still as root)
Code:

alsactl store

I tried this approach first and it doesn't help

Quote:

Originally Posted by sooty
run alsaconfig to load the alsa modules and then run lsmod again and see which extra alsa mods have been loaded.

then I went to this. The only difference is that after I run alsaconfig rtc is no longer loaded. I am sure there is no other difference, having piped and sorted lsmod before and after.

I haven't found where Debian keeps its version of modules.autoload yet, but when I do I don't know if I can remove rtc, as I don't know what it is!!

sooty 08-31-2006 01:09 PM

Ok if all the modules are beening loaded during boot and you have previously used alsactl store to save your setingd try booting from scracth and enter alsactl restore if the sound works then you will have to include this command in one of your startup files if it does not enable sound try removing the rtc module ( login as root and enter modprobe -r rtc )
this will remove rtc from the current session in order to remove it permantly you will have to remove it from a start up file.
Let us know how you get on

simbobo 09-01-2006 04:33 AM

I've now discovered the problem's different to what I thought - when I log in with xfce it's all fine - with Gnome there's no sound until alsaconfig...!?!

simbobo 09-04-2006 04:59 PM

Well my solution is just use XFCE


All times are GMT -5. The time now is 11:35 AM.