LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-11-2012, 02:34 PM   #1
nobuntu
Member
 
Registered: Mar 2012
Distribution: Debian for server, CrunchBang for everything that's not a server
Posts: 143

Rep: Reputation: 24
[xubuntu] 12.04: cannot successfully mount any external drives or storage devices


Good morning,

Please see http://i.imgur.com/8jxt4.png.

This persistent error message is proving to be the bane of my existence. My (i686) Xubuntu 12.04 installation is not allowing me to successfully access any form of removable external storage media, including SD cards.

I have attempted various fixes found around the Forums, none of which have been met with any success.

Please, if anyone has any ideas re: fixing this issue, let me know. It is quite imperative that the issue be resolved at some point during this weekend, as I have some data that must be backed up in order for me to be able to continue with normal operations over the coming week.

Thank you,

Lawrence

Last edited by nobuntu; 08-11-2012 at 02:35 PM.
 
Old 08-11-2012, 05:44 PM   #2
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,087

Rep: Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809
What exactly are you doing to get this message? What are the permissions on the external media? If you want users to be able to access and read/write to external media/partitions you will need to give them permission to do so. Normally, this can be done with an entry in the /etc/fstab file. Post more information on the drives/partitions and filesystem types you are trying to access and how you are trying to do so.
 
Old 08-11-2012, 08:40 PM   #3
nobuntu
Member
 
Registered: Mar 2012
Distribution: Debian for server, CrunchBang for everything that's not a server
Posts: 143

Original Poster
Rep: Reputation: 24
Hello! I apologize for taking so long to respond to your post; I have been on a hike for the past while.

All I am "doing" is inserting the drive into my laptop's USB port. It does appear on my desktop, however double-clicking the icon in an attempt to access it results in the aforementioned error message.

df -T output follows.

Code:
lawrence@Edith:~$ df -T
Filesystem     Type     1K-blocks     Used Available Use% Mounted on
/dev/sda1      ext4     485746808 28105556 433326372   7% /
udev           devtmpfs   1019016        4   1019012   1% /dev
tmpfs          tmpfs       410512      856    409656   1% /run
none           tmpfs         5120        0      5120   0% /run/lock
none           tmpfs      1026276      220   1026056   1% /run/shm
lawrence@Edith:~$
How do I tell which of these drives is the external drive I am attempting to connect? Once I can establish the drive name, it should simply be a matter of chmoding the drive from a terminal emulator, but I am unsure of the drive's identity.

My primary user account, lawrence, has full administrative permissions.
 
Old 08-11-2012, 11:03 PM   #4
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,087

Rep: Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809
What's on the external drives? Anything? Have they been formatted? have a filesystem?

When I plug a flash drive in my computer and run your command I get the following output for the drive

Quote:
/dev/sdb1 vfat 3.8G 1.1G 2.8G 28% /media/disk
:

Usually you can access external drives in Ubuntu derivatives by going to the /media directory where it will show a folder icon with a UUID number. The only drive/partition showing is sda1 which I expect would be your Kubuntu root partition. If you don't have any filesystem on the external I would not expect it to show anything. I don't have any empty flash or external drives to check this.
 
Old 08-12-2012, 02:21 AM   #5
nobuntu
Member
 
Registered: Mar 2012
Distribution: Debian for server, CrunchBang for everything that's not a server
Posts: 143

Original Poster
Rep: Reputation: 24
The drives have different things on them. One has a backup of my files from a previous (somewhat disastrous) attempt at using Debian 6.0.5 prior to installing Xubuntu, another has some MTS files from my camcorder, and various other drives have documents, photographs, etc. In short, data I do not want to lose.

I will try your /media suggestion tomorrow morning; as of right now, I am utterly drained and want to go to bed. I do have a tendency to get really ingrained in a project at 10 p.m. and then the next thing I know I look at the clock and it's 6 a.m. Tonight is not a good time for that to happen, so it looks like my laptop is going to have to be off for a while...
 
Old 08-13-2012, 12:08 AM   #6
guyonearth
Member
 
Registered: Jun 2012
Location: USA
Distribution: SolydX
Posts: 399

Rep: Reputation: 82
I'm curious what you mean by your user having "full administrative permissions"? A normal use doesn't have that. These drives should automount by default, without any special action on your part. Have you modified the default setup somehow, or changed group permissions? Can you mount them manually using sudo in a terminal?
 
Old 08-15-2012, 02:00 PM   #7
nobuntu
Member
 
Registered: Mar 2012
Distribution: Debian for server, CrunchBang for everything that's not a server
Posts: 143

Original Poster
Rep: Reputation: 24
Quote:
Originally Posted by guyonearth View Post
I'm curious what you mean by your user having "full administrative permissions"? A normal use doesn't have that. These drives should automount by default, without any special action on your part. Have you modified the default setup somehow, or changed group permissions? Can you mount them manually using sudo in a terminal?
I'm sorry - I worded that post badly. What I meant to say is that I can gain root permissions via sudo, eg my user account is in the sudoers file.

I have not tried mounting the drive in a terminal. How would I go about doing that if I am unsure of the drive's UUID, as I mentioned in earlier posts?

Last edited by nobuntu; 08-15-2012 at 02:01 PM.
 
Old 08-15-2012, 03:51 PM   #8
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,087

Rep: Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809
You can get the device/partition number by running: sudo fdisk -l(lower case Letter L) and you should be able to get the uuid with: blkid command or this command: ls -l /dev/disk/by-uuid/

You don't need the uuid to mount it. Have you checked the /media directory after plugging in one of these external devices?
 
Old 08-15-2012, 04:41 PM   #9
guyonearth
Member
 
Registered: Jun 2012
Location: USA
Distribution: SolydX
Posts: 399

Rep: Reputation: 82
Quote:
Originally Posted by R3nCi View Post
I'm sorry - I worded that post badly. What I meant to say is that I can gain root permissions via sudo, eg my user account is in the sudoers file.

I have not tried mounting the drive in a terminal. How would I go about doing that if I am unsure of the drive's UUID, as I mentioned in earlier posts?
If you have only one hard drive in the computer, then any usb drive you plugged in would probably be device sdb.

You can mount it by using
Code:
sudo mount /dev/sdb1 /media/usb
This assumes there is one partition on the usb drive.
You will need to make the directory first (if it's not there already) by using
Code:
sudo mkdir /media/usb
If you do this and it will not mount, post the error message here.

Last edited by guyonearth; 08-15-2012 at 04:47 PM.
 
Old 05-03-2014, 07:57 PM   #10
blueinca99
LQ Newbie
 
Registered: Apr 2014
Posts: 27

Rep: Reputation: Disabled
Unhappy

yeah nubuntu - I am having the same problems - the display I get from fdisk -l is even difficult to work which is the actual external HD & it's UUID.

I tried Mint Mate 13 & 16, now I am trying Xubuntu.

Did you ever get this actually fixed. For me using a computer without an easily (sitting there ready to go/use) accessible & useable external hard drive/s is a practically worthless.......
 
Old 05-03-2014, 08:58 PM   #11
blueinca99
LQ Newbie
 
Registered: Apr 2014
Posts: 27

Rep: Reputation: Disabled
I think it has something to do with the external Hard Drive itself- there's nothing wrong with the HD - it has worked fine- responsive etc in XP, but it is Seagate & I do believe Seagate can sometimes have compatibility issues working in other systems, for example it's the only hard device to NOT work in my PVR. I have tried a generic 16gb usb stick - it is recognised, & now I put in a different external HD - a Samsung 2TB & both of these mount automatically & play the files contained.

Does anyone else have issues with Seagate External HDs?

Paul
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
to mount external drives on startup kutlu Debian 8 03-15-2010 11:29 PM
Can't mount external storage after upgrading to Kubuntu 8.04 hardy BigFoot13 Linux - Hardware 3 09-24-2009 05:20 PM
How to mount usb storage devices phenixs Linux - Hardware 2 03-27-2007 06:37 PM
USB storage devices difficult to mount and use jaakkop Slackware 4 11-16-2005 05:03 PM
External storage devices category under the HCL LinuxLala LQ Suggestions & Feedback 3 05-30-2004 01:57 AM


All times are GMT -5. The time now is 07:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration