LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin
User Name
Password
Linux Deepin This forum is for the discussion of Linux Deepin.

Notices

Reply
 
Search this Thread
Old 06-17-2014, 11:49 PM   #1
ilox
LQ Newbie
 
Registered: Feb 2008
Location: Adelaide, South Australia, Australia
Distribution: Deepin2014RC
Posts: 10

Rep: Reputation: Disabled
Exclamation Deepin 2014 RC: Incorrect Time Zone information


Some of you may recall a previous post about the Time Zone settings in Deepin 2013 - the options were all set on hourly increments.

Well nobody on the Dev team took any notice of my post, the new 2014RC is still on hourly increments!

While South Australia might be an infinitesimal section of your market - our zone is GMT +9hr 30 mins - what about a major IT-aware country like India? India is 5:30 hours ahead of UTC. Most other Linux Distros seem to have been able to incorporate the right time zone information, now it is time for Deepin to get with it.

Wikipedia says:
"Newfoundland, India, Iran, Afghanistan, Venezuela, Burma, Sri Lanka, the Marquesas, as well as parts of Australia use half-hour deviations from standard time, and some nations, such as Nepal, and some provinces, such as the Chatham Islands, use quarter-hour deviations."
The full listing of World Time Zones is at;
http://en.wikipedia.org/wiki/Time_zo...of_UTC_offsets

During Installation I correctly selected the Map option and located the cursor at Adelaide (our Capital) and it set everything up for Adelaide except it set the Time zone as +10 hours. It isn't, it is +9.5 hours.

Trying to adjust it once installed brings me nothing but grief. So many entries and nothing for Adelaide. Nothing other than hourly increments.

This time - before the RC is locked in place - can somebody please fix this problem?

Last edited by ilox; 06-18-2014 at 12:07 AM. Reason: added info on installation procedure
 
Old 06-20-2014, 05:20 AM   #2
cxbii
LDcontributor
 
Registered: Aug 2012
Location: china
Distribution: LinuxDeepin
Posts: 66

Rep: Reputation: Disabled
Hello friends, I'm from Deepin official team.
Your question has been recorded, but we are Chinese. We solve this problem you need help, please contact me, my e-mail: chenxiangbang AT linuxdeepin.com
 
Old 06-20-2014, 05:29 PM   #3
doomcake
LQ Newbie
 
Registered: Jun 2014
Posts: 1

Rep: Reputation: Disabled
Deepin seems to have a problem with GMT settings for timezones.

England + G.M.T are the centre of the universe,so i would expect this simple detail to be working properly.
 
Old 06-21-2014, 08:59 AM   #4
ilox
LQ Newbie
 
Registered: Feb 2008
Location: Adelaide, South Australia, Australia
Distribution: Deepin2014RC
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cxbii View Post
Hello friends, I'm from Deepin official team.
Your question has been recorded, but we are Chinese. We solve this problem you need help, please contact me, my e-mail: chenxiangbang AT linuxdeepin.com
Hello chenxiangbang, not sure what you are asking from me. I have told you the problem and shown where to get the right information so that the database can be expanded to properly allow for time zones that are not exactly on the hour separation.

Would it be more appropriate to raise this error as a Bug Report so that it can be allotted and tracked?

I cannot code but I am happy to advise the information which is required to be available as an option to anybody trying to set the time correctly.

At present I have to manually adjust the time so that my computer shows it correctly.

Last edited by ilox; 06-21-2014 at 09:01 AM.
 
Old 07-16-2014, 02:05 AM   #5
cxbii
LDcontributor
 
Registered: Aug 2012
Location: china
Distribution: LinuxDeepin
Posts: 66

Rep: Reputation: Disabled
Quote:
Originally Posted by ilox View Post
Hello chenxiangbang, not sure what you are asking from me. I have told you the problem and shown where to get the right information so that the database can be expanded to properly allow for time zones that are not exactly on the hour separation.

Would it be more appropriate to raise this error as a Bug Report so that it can be allotted and tracked?

I cannot code but I am happy to advise the information which is required to be available as an option to anybody trying to set the time correctly.

At present I have to manually adjust the time so that my computer shows it correctly.
Deepin 2014 Release has fixed this problem. Please check whether this problem still exists.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deepin 2014 Alpha Be ready to embrace the New Deepin cxbii Linux Deepin 0 04-16-2014 03:44 PM
How to get Time Zone information from the system chowdhary_g Programming 12 04-04-2014 08:56 PM
[SOLVED] Incorrect Time Zone Displaying in Arch toynbee Linux - Newbie 2 03-06-2010 06:18 AM
Time Zone Incorrect: trouble in fixing it sanmartin Linux - Hardware 4 03-05-2005 12:35 PM


All times are GMT -5. The time now is 03:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration