LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linspire/Freespire
User Name
Password
Linspire/Freespire This Forum is for the discussion of Linspire and Freespire.

Notices

Reply
 
Search this Thread
Old 04-17-2004, 12:22 AM   #1
Brolin_1911a1
LQ Newbie
 
Registered: Apr 2004
Posts: 19

Rep: Reputation: 0
Question Lindows Rewrites LILO Boot Order


I recently purchased Lindows v4.5.112 and installed it on an AMD K6-2 333MHz computer also running Win98 from the same hardrive but (obviously) different partition. Since Win98 seems to need to reboot everytime one installs, reconfigures, or sometimes just runs a program I'd prefer that the default boot option be Win98 for convenience. But the Lindows default is for Win98 to be option #4. I've repeatedly reconfigured /etc/lilo.conf to make Win98 the first option and then run lilo to make it so but this works only until I next boot into Lindows. After I've booted into Lindows again, the next time I reboot the computer Win98 is again choice #4 instead of the default option #1. I've even tried copying lilo.conf to lilo.conf.old to no avail.

I saw a post in another forum from last November that Lindows 4.5 had a file called /sbin/fooze that rewrote /etc/lilo.conf but locate couldn't find such a file on my system.

Any advice would be appreciated.
 
Old 04-17-2004, 12:47 AM   #2
wolfe2554
Member
 
Registered: Apr 2003
Location: denver co
Distribution: redhat9
Posts: 156

Rep: Reputation: 30
please post a print of your /etc/fstab & /etc/lilo.conf & fdisk /dev/hda <- assuming that it is your first harddrive with inside of linux as root run fdisk /dev/hda and hit option p copy and paste.
 
Old 04-17-2004, 12:59 PM   #3
MEMY
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
to change boot order try this link
http://www.nwinfo.net/~sourkraut/tip...20boot%20order
 
Old 04-17-2004, 07:15 PM   #4
Brolin_1911a1
LQ Newbie
 
Registered: Apr 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Okay. I didn't understand the fdisk instruction but here's what's in my /dev/fstab file:
# DO NOT EDIT: This is a generated file. To set mount points, file system types, or mount options edit
# /etc/harddrive.inf.
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hda5 / reiserfs rw 0 0
/boot/linux-swap.swp none swap sw 0 0
none /proc proc defaults 0 0
none /proc/bus/usb usbdevfs defaults 0 0
/dev/fd0 /mnt/floppy1 auto showexec=no,sync,rw,user,noauto 0 0
/dev/dvd /mnt/cdrom iso9660 noauto,ro,user,exec,unhide 0 0
/dev/dvd /mnt/cdrom1 iso9660 noauto,ro,user,exec,unhide 0 0
/dev/sr1 /mnt/cdrom2 iso9660 noauto,ro,user,exec,unhide 0 0
/dev/hda1 /disks/dos vfat rw,noexec,showexec=no,umask=0 0 0

That's it. Here's the lilo.conf file as rewritten by Lindows.....
# Generated by jiffyboot version 5.0.97. If this file is edited, the system will stop modifying it. To allow #the system to resume management of this file, remove it and run /sbin/jiffyboot.
boot=/dev/discs/disc0/disc
install=/boot/cboot.b
message = /boot/splash.lilo
map=/boot/map
fix-table
lba32
prompt
delay=70
timeout=70
image=/boot/vmlinuz-2.4.23
label=L<>|_4.5.122

Hmmm.... ran out of room in this message. ....
 
Old 04-17-2004, 07:18 PM   #5
Brolin_1911a1
LQ Newbie
 
Registered: Apr 2004
Posts: 19

Original Poster
Rep: Reputation: 0
The rest of my /etc/lilo.conf file ......

image=/boot/vmlinuz-2.4.23
label=L<>|_4.5.122
vga=0xf04
root=/dev/hda5
initrd=/boot/initrd-2.4.23.gz
append="resume=/dev/hda5 resume_block=0x2014"
image=/boot/vmlinuz-2.4.23
label=Redetect
vga=normal
root=/dev/hda5
initrd=/boot/initrd-2.4.23.gz
append="noresume redetect resume=/dev/hda5 resume_block=0x2014"
image=/boot/vmlinuz-2.4.23
label=Diagnostics
vga=normal
root=/dev/hda5
initrd=/boot/initrd-2.4.23.gz
append="noresume resume=/dev/hda5 resume_block=0x2014 single"
other=/dev/hda1
label=W<>_98
~
That's it. When it says it won't mess with this file after it's been edited, Lindows lies.
 
Old 04-17-2004, 07:40 PM   #6
Brolin_1911a1
LQ Newbie
 
Registered: Apr 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by MEMY
to change boot order try this link
http://www.nwinfo.net/~sourkraut/tip...20boot%20order
Thanks. Those looked like the instructions I needed. I'll know for sure the next time I reboot but I think that mention of jiffyboot and how to disable it was what I needed.

Again, many thanks to both of you .
 
Old 05-24-2004, 10:09 PM   #7
GentooJava
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
Cool My fix for this

Since I haven't yet figured out where Lindows rewrites lilo.conf (except that it has been done by the time you have booted), I implented a very simple solution.

I modified lilo.conf to be the way I wanted it, and then saved it as lilo.conf.xp

I then created a file called /etc/rc6.d/K31fixlilo and made it executable (chmod a+x):

Code:
#!/bin/bash
cp /etc/lilo.conf.xp /etc/lilo.conf
lilo
This way every time I reboot (shutdown does not count), lilo.conf will be replaced by my version and lilo will be called to fix the MBR.

Hope someone finds this helpful
 
Old 06-23-2004, 04:22 AM   #8
d4d4n9
Member
 
Registered: Oct 2003
Distribution: Mandrake 10.1, Knoppix 3.7
Posts: 153

Rep: Reputation: 30
Hi GentooJava,

I experienced the same condition on my box with multi boot Windoze ME, Mandrake 10.0 Official and Lindows. When I booting to Lindows, my lilo.conf was rewritten with Lindows defaults lilo.
If I try to implement your advice, I have to put the file in Mandrake 10.0 /etc/rc6.d/ directory, haven't I ? This means that this file will be read in time of booting ?
Thanks in advance.
 
Old 06-23-2004, 10:58 AM   #9
GentooJava
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
d4d4n9:

You would put this into the /etc/rc6.d directory on the Lindows side.

Since my original posting, it occured to me that I could just rename the lilo executable, so that Lindows wouldn't be able to rewrite the boot sector in the first place. (I haven't actually tried this, but it seems a simpler solution.)

--Nathan Chilton
 
Old 06-23-2004, 02:47 PM   #10
ealm
Member
 
Registered: Mar 2004
Location: Stockholm, Sweden
Distribution: Linspire
Posts: 88

Rep: Reputation: 15
Re: Lindows Rewrites LILO Boot Order

Quote:
Originally posted by Brolin_1911a1
I recently purchased Lindows v4.5.112 and installed it on an AMD K6-2 333MHz computer also running Win98 from the same hardrive but (obviously) different partition. Since Win98 seems to need to reboot everytime one installs, reconfigures, or sometimes just runs a program I'd prefer that the default boot option be Win98 for convenience. But the Lindows default is for Win98 to be option #4. I've repeatedly reconfigured /etc/lilo.conf to make Win98 the first option and then run lilo to make it so but this works only until I next boot into Lindows. After I've booted into Lindows again, the next time I reboot the computer Win98 is again choice #4 instead of the default option #1. I've even tried copying lilo.conf to lilo.conf.old to no avail.

I saw a post in another forum from last November that Lindows 4.5 had a file called /sbin/fooze that rewrote /etc/lilo.conf but locate couldn't find such a file on my system.

Any advice would be appreciated.
As you've noticed Linspire re-writes boot loader on every boot. To prevent it form doing this simply double-click "My Computer" -> System -> /sbin. Locate "jiffyboot" and right-click it -> Properties -> Permissions. Remove all the "exec" permissions.
Now Linspire won't re-write boot loader on boot any more.

Btw this behaviour will be improved in Linspire 5.0.
 
Old 06-23-2004, 11:53 PM   #11
d4d4n9
Member
 
Registered: Oct 2003
Distribution: Mandrake 10.1, Knoppix 3.7
Posts: 153

Rep: Reputation: 30
Thanks ealm for your advice.

Just to make sure, I use Mandrake 10.0 Official lilo to boot my box. If I logon to Lindows, it will rewrite the lilo with it's own. Will it rewrite lilo on booting or on shutdown ?
I think that I could do what ealm advised from within Mandrake 10.0 session, couldn't I ?

Last edited by d4d4n9; 06-24-2004 at 01:21 AM.
 
Old 06-24-2004, 08:40 AM   #12
GentooJava
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
Lindows/Linspire will install it's boot loader during bootup. Mandrake is not the problem. You cannot follow his advise on the Mandrake side, because it only applies to Lindows. I have never used another distro that rewrites your MBR on every boot and I find it quite frustrating and rude of Lindows to think that it's ok to do that without notifying the user and making it easy to turn this most annoying feature off.

That said, I am really glad that ealm knows how to disable this feature. I looked for the answer to this problem all over the place and found nothing but postings from other people with the same issue.

I will try ealm's advise the next time I boot into Lindows on my laptop and will post a message here if it does not solve the problem, but it sounds like we finally know the proper way to turn off this feature.

Aside from that Lindows/Linspire is rather cool. I like the Click 'N Run Warehouse in concept and implementation. It really is the easiest, coolest way to install software on Linux that I have seen. My only real complaint about Lindows (besides this lilo issue) is that the web browser constantly locks up on my machine. I don't know if it's specific to my machine or not, because I have not actually used it on another computer, but the web browser (a customized version of Mozilla) seems to completely stop responding when waiting for a page to load.

I installed Opera from CNR and had no problem with it -- except that it is the "free" version, so part of the window contains advertisements. What I really wanted was Firefox, but it wasn't in CNR, so I installed it manually. This solved all my real problems. Firefox doesn't hang for me, and it's my browser of choice anyway (even on Windows).

Just my $0.02

--Nathan Chilton
 
Old 06-24-2004, 05:00 PM   #13
ealm
Member
 
Registered: Mar 2004
Location: Stockholm, Sweden
Distribution: Linspire
Posts: 88

Rep: Reputation: 15
The LILO issue is pretty annoying, but at the same time understandable with regards to what group of people Linspire aims for.
I think it could be better done though, and so thus Lindows Inc. and as a result this will be improved for Linspire 5.0 (currently in testing by Insiders).

Regarding the Mozilla issue this is a known problem and I had it too with an earlier version of Lindows (4.5.3xx). It seems to be gone in the latest Linspire release though...
 
Old 06-25-2004, 10:13 AM   #14
GentooJava
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
Ok, so I didn't quite realize what ealm's solution was, at first glance. Yes, you can do this from the Mandrake side. If you have Lindows/Linspire's partition mounted from Mandrake, you can turn off the executabe bits for the jiffyboot command.

If you are in Mandrake and your Lindows partition has been mounted as, say /dev/hda2, then you would just execute the command (as root):
chmod 444 /mnt/hda2/sbin/jiffyboot
or
chmod a-x /mnt/hda2/sbin/jiffyboot
or ... (as root) you could browse to the file with a graphical file manager, right-click, choose properties, and turn off the executable bits.

So just find out which partition Lindows is using, mount it, and tell the file system not to allow the program to execute.

As far as the Mozilla issue goes, yes I am using a 4.5.3xx release -- 4.5.316 to be precise. I'm glad to hear that the issue has been resolved and I'll look forward to seeing the 5.0 version when it is released. I'm in Lindows at the moment, actually (my version is just before the name change). But I'm at work now, so it's time to reboot back into XP... *sigh* (but, at least I still have my Gentoo box here...)

:-)
--Nathan Chilton
 
Old 06-25-2004, 09:00 PM   #15
d4d4n9
Member
 
Registered: Oct 2003
Distribution: Mandrake 10.1, Knoppix 3.7
Posts: 153

Rep: Reputation: 30
Hi GentooJava,

Thanks for your info.
Actually, my lindows' partition is in hdb6 and mounted on mandrake 10.0 session on /mnt/hdb6.
I have tried to cd to /mnt/hdb6/sbin but I could not find jiffyboot file. May be it is hidden file . Planning to try again later.

Last edited by d4d4n9; 06-25-2004 at 09:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken LILO on Lindows 4.5 ratgod Linux - Software 4 02-23-2005 09:28 AM
Change LILO boot order ??? glenn69 Linux - Newbie 2 04-24-2004 07:01 PM
LILO configuration Lindows Mandrake vladuna Linux - Newbie 3 03-04-2004 07:29 AM
Lilo boot order BicycleBob Linux - General 3 10-27-2003 01:32 PM
lindows & OS boot order the_y_man Linux - Newbie 1 01-28-2003 03:08 PM


All times are GMT -5. The time now is 07:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration