LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Incognito
User Name
Password
Incognito This forum is for the discussion of Incognito Linux.

Notices

Reply
 
Search this Thread
Old 09-11-2009, 03:57 AM   #1
lacakid
LQ Newbie
 
Registered: Sep 2009
Distribution: Opensuse 11
Posts: 6

Rep: Reputation: 0
Virtualbox (latest) won't detect correct Video... X won't work...


I've seen a few posts but after following them still can't get "xdm" going due to some issue in xorg.conf... Does anyone know what you have to do to get Sun Virtualbox to load incognito 2009b with the correct video drivers?? (and please feel free to be as verbose as possbile) so I can bring up and X session.

thanks,
Tom
 
Old 09-11-2009, 05:33 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,551
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
What is your host OS, your guest OS and your version of VirtualBox? Have you installed VirtualBox Guest Additions on the host OS?
 
Old 09-11-2009, 08:34 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,981

Rep: Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610
Incognito 2009b Linux :
Do you get a command prompt ?
And will the command xinit start X ?

An 'xorg.conf' file can also be generated with one of
the other Getoo based live-DVD's and saved to Google
docs as xorg.conf.txt.
> >
Any live Sabayon or Toorox can be used.
.....

Last edited by knudfl; 09-11-2009 at 08:37 AM.
 
Old 11-02-2009, 12:53 AM   #4
lacakid
LQ Newbie
 
Registered: Sep 2009
Distribution: Opensuse 11
Posts: 6

Original Poster
Rep: Reputation: 0
sorry about the delay

My host OS is Windows XP SP 3 and I am running the latest VirtualBox that just came out on 10/29/2009 3.10. Since Incognito is LIVE I can only run it as live.

;
/etc/init.d/vbox-guest: line 41: /etc/init.d/vboxvfs: No such file or directory

and then X doesnt start

Tom
 
Old 11-02-2009, 05:55 AM   #5
anonym
Incognito Maintainer
 
Registered: Oct 2008
Distribution: Gentoo
Posts: 100

Rep: Reputation: 26
As have been said in other threads, this is a known issue. Incognito used to work perfectly in VirtualBox -- I used it extensively to try out my development builds. A bit less than 1 years ago something changed, and now I can't even get X to start in the old versions of Incognito which I know for a fact worked 2 years ago. To me it seems like a bug was introdiced in VirtualBox.

The problem is video related, and it seems it's only the "fbdev" driver that works. In 2009.0 beta, add 'debugmode' to the kernel commandline (press TAB when you have selected your preferred language), then when you are dropped to a console, login as root (the password is empty since you added debugmode), edit /etc/X11/xorg.conf and comment/remove line 4 (which says 'Screen 0 "ScreenVesa" 0 0') and make sure that the device section for 'Card0' uses 'Driver "fbdev"' (should be on line 179). Then restart xdm with '/etc/X11/xdm restart'.
 
Old 11-05-2009, 10:48 PM   #6
lacakid
LQ Newbie
 
Registered: Sep 2009
Distribution: Opensuse 11
Posts: 6

Original Poster
Rep: Reputation: 0
ok i will try that............

With that being fixed do you happen to know how to get the network working? I noticed that is out also Thanks in advance for your help & advice!

Much appreciated!
Tom
 
Old 11-09-2009, 08:55 AM   #7
anonym
Incognito Maintainer
 
Registered: Oct 2008
Distribution: Gentoo
Posts: 100

Rep: Reputation: 26
The default VirtualBox network interface works for me, i.e. PCnet-FAST III (Am79C073).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest Version of VirtualBox Kernel Errors on CentOS 5, i386 Doctorzongo Linux - Desktop 15 04-21-2012 08:42 AM
[SOLVED] Video Problems in VirtualBox on Slackware64-current TSquaredF Slackware 8 10-20-2009 11:44 PM
Winetools doesn't detect the correct version of wine doraimom Linux - Software 2 05-19-2007 08:27 PM
correct way to upgrade from 10.1 to 10.2/latest? zammmm Mandriva 9 08-13-2005 09:01 PM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration