LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Incognito
User Name
Password
Incognito This forum is for the discussion of Incognito Linux.

Notices

Reply
 
Search this Thread
Old 04-14-2009, 07:58 AM   #1
deXtroid101
LQ Newbie
 
Registered: Apr 2009
Posts: 2

Rep: Reputation: 0
Disabling automatic creation of backup files


Hello!
Everytime I modify a file, an automatic backup file is created. Because I have many files and the folders get totally confusing with numerous of these files, I want to disable that option. How do I do that?
 
Old 04-14-2009, 08:19 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
The program you are using to modify the files will have a preferences item in it's edit menu. Explore that to find where you can disable the "create backups" feature.

eg. In GEdit, I go to Edit > Preferences > Editor > File Saving ... where there is a check box against "Create backup copy of files before saving" - uncheck it.

Different programs will do this differently. For eg. commandline programs probably have a configuration file for this. You should be aware that there are many different kinds of files and many ways to modify them - it is difficult to figure out what you need if you are not specific.

Backups usually have a special suffix, usually a tilda (~) which will make it hidden on many distros.
I have a script I run routinely which hunts down and destroys tilda'd filenames (and other inconvenient files).
 
Old 04-15-2009, 08:03 AM   #3
deXtroid101
LQ Newbie
 
Registered: Apr 2009
Posts: 2

Original Poster
Rep: Reputation: 0
happens when i edit and then save text files in kwrite.
i can not find anything to disable this in the editor's menu.
 
Old 04-16-2009, 12:22 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Ah, Kate ...
http://bugs.kde.org/show_bug.cgi?id=79698
http://lists.kde.org/?l=kwrite-devel...1927215805&w=2

... it seems that this is an oft-requested feature (the ability to stop generating auto-backups). I have not found anything to say that the feature has been added and the bug report is not "resolved". Perhaps you'd like to add your vote?

You could access Kate from a script which, when Kate exits, runs rm *~ ... use a bash alias to clean unwanted files, or just not use Kate.

But look in: Settings > Configure Kate
http://kate-editor.org/article/.kateconfig
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Automatic backup for sporadically connected clients with Box Backup LXer Syndicated Linux News 0 08-29-2008 08:40 PM
Is there a way to stop the creation of backup files in KDE? M$ISBS Linux - Software 3 10-03-2006 03:12 AM
text files and their automatic backup files AGazzaz Linux - General 1 07-01-2006 07:38 AM
Automatic Backup of files on KDE Desktop tooparam Linux - General 1 01-29-2006 11:55 AM
Automatic user creation Skorpio Linux - Networking 3 09-25-2003 10:45 AM


All times are GMT -5. The time now is 02:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration