LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Grafpup
User Name
Password
Grafpup This forum is for the discussion of Grafpup Linux.

Notices

Reply
 
Search this Thread
Old 06-29-2007, 08:09 PM   #1
eagles-lair
Member
 
Registered: Nov 2004
Location: Adelaide, Australia
Distribution: Lindows/Linspire, SuSE, PC-BSD, ubuntu, puppy
Posts: 239

Rep: Reputation: 30
Auto start X and login screen missing on Intel 800/900 box


This is a Compaq mother board (Presario small profile) and just about everything I run on this tells me that I've passed a undefined mode number !!!!

This requires press space bar to continue, or Press return to see nodes available

Towards the end of the console text I read
Code:
Intel 800/900 Series VBIOS Hack : version 0.5.2
915resolution unable to determine the chip set type
chipset ID 71248086
please report this problem to stomljen@yahoo.com
I end up at a root prompt, and by typing xwin it then launches into root desktop. The first time, of course, you have to set up X configuration, no problems there, 1280x1024x16bit using the wizard.

I had no problem doing Nathan's suggested "fudge" creating /home and copying the skel directory into it. I then created two users, grafpup and my own using the user manager, and changed root password while I was about it.

Logged out and find that every time I boot (using grub, triple booting with Lycoris Desktop/LX and puppy 215ce) that I end up at a prompt and don't seem to be able to launch the GUI login screen.

I checked those users and the passwords by prior to typing xwin logging in and logging out in each user in turn. Perfect in both text mode at the prompt, and in GUI mode.

Logged in as a user and with X running, I found that I could use my changed root password in running MUT as root.

So, what's to do?

I'm a bit mystified but assume its something most odd with the Intel stuff.


Edit
corrected typo, changed "node" to "mode" near the top

Last edited by eagles-lair; 06-30-2007 at 12:01 AM.
 
Old 06-29-2007, 10:26 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Do you maybe mean "modes" instead of "nodes"?

Look in /boot/grub/menu.lst. The line for the kernel may have something like "vga=794". I think that is the video mode that is causing the problem. You can also edit this line by pressing any key, and then "e" for edit. This will only change it that time, but it is a way to find out whether a particular mode will work.

Actually vga=794 is the mode I usually use. On the Dell Latitude, if I don't use it the virtual terminals are very small in the center of the screen. It is a bitmapped mode that you can even use to run mplayer on with the -vo fbdev video output driver without even starting the X server!
 
Old 06-29-2007, 11:58 PM   #3
eagles-lair
Member
 
Registered: Nov 2004
Location: Adelaide, Australia
Distribution: Lindows/Linspire, SuSE, PC-BSD, ubuntu, puppy
Posts: 239

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by jschiwal
Do you maybe mean "modes" instead of "nodes"?
Yep. Common typo I'm afraid lol. Hopefully fixed by editing, thanks for the heads-up

Quote:
Originally Posted by jschiwal
Look in /boot/grub/menu.lst. The line for the kernel may have something like "vga=794". I think that is the video mode that is causing the problem. You can also edit this line by pressing any key, and then "e" for edit. This will only change it that time, but it is a way to find out whether a particular mode will work.
I've tried that setting and a similar one that Nathan suggested on another post about problems in another computer with different hardware. And also vga=normal which is the one grub defaults to, I think.

Quote:
Originally Posted by jschiwal
Actually vga=794 is the mode I usually use. On the Dell Latitude, if I don't use it the virtual terminals are very small in the center of the screen. It is a bitmapped mode that you can even use to run mplayer on with the -vo fbdev video output driver without even starting the X server!
I'll save that to a file for future use. Thank you very much

There are two distinct problems here, it looks to me

The first is the start-up script doesn't appear to complete running.

The second is typing xwin does not invoke the GUI with the login page loaded.

Richard
in Adelaide

Last edited by eagles-lair; 06-30-2007 at 12:02 AM.
 
Old 06-30-2007, 02:57 AM   #4
eagles-lair
Member
 
Registered: Nov 2004
Location: Adelaide, Australia
Distribution: Lindows/Linspire, SuSE, PC-BSD, ubuntu, puppy
Posts: 239

Original Poster
Rep: Reputation: 30
Nathan,
I've discovered something interesting.

In type 2 installed mode, this recalcitrant machine has all the icons in the menu. (This was edited)

They do not need to be refreshed.

Immediately before the boot-up ends in a root login prompt, there is a line which says:
caching icons in /usr/share/pixmaps

If you wait maybe half a minute to a minute before logging in, there is then a line which says:
caching icons in /usr/share/mini-icons

I'm willing to bet that that is the line which isn't working on other installations. Wonder why.

This icons missing problem is discussed somewhere else.

Richard

Last edited by eagles-lair; 06-30-2007 at 04:08 AM.
 
Old 07-03-2007, 12:41 PM   #5
Nathan F
Grafpup Developer
 
Registered: Jun 2006
Location: Houston, TX
Distribution: Grafpup, Dyne::Bolic
Posts: 63

Rep: Reputation: 15
The missing menu icons is a timing issue, pure and simple. If the icons are not all copied to the temp directory by the time the script finishes then the process is killed. It's a bit of a design flaw on my part, which I am correcting for 2.01. I'm going to ditch the whole concept of caching icons and just read them from one permanent directory.

Nathan
 
Old 07-03-2007, 05:18 PM   #6
eagles-lair
Member
 
Registered: Nov 2004
Location: Adelaide, Australia
Distribution: Lindows/Linspire, SuSE, PC-BSD, ubuntu, puppy
Posts: 239

Original Poster
Rep: Reputation: 30
Aaahhaaa!

Glad my "different" machine helped in analysing what happened.

On the face of it, caching a bunch of icons should make for a quicker screen update, you would think.

Would it be simpler, perhaps, to change the order the script does things, so that the caching is fully complete sooner?

Last edited by eagles-lair; 07-03-2007 at 08:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Black screen instead of login screen! Intel integrated graphics coolblue Suse/Novell 10 05-03-2007 05:30 PM
How do I make my programs auto start on login? martinr Fedora 2 04-11-2006 10:00 AM
Start up scripting and auto login for stand alone linux box kzazula Linux - General 7 01-13-2006 05:22 AM
auto start when login moonloader Slackware 7 08-14-2004 01:53 AM
how do i make a software auto start after login? 286 Linux - Newbie 2 01-21-2004 06:42 PM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration