LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Gentoo (http://www.linuxquestions.org/questions/gentoo-87/)
-   -   System stuck during boot for about a minute, then resumes normally. (http://www.linuxquestions.org/questions/gentoo-87/system-stuck-during-boot-for-about-a-minute-then-resumes-normally-4175474032/)

iro_number1 08-20-2013 12:39 PM

System stuck during boot for about a minute, then resumes normally.
 
1 Attachment(s)
Hello all!

I have this weird issue where the system hangs for about a minute during the early boot stages.
It looks like this:

Code:

[    2.346458] hub 2-0:1.0: port 4, status 0100, change 0001, 12 Mb/s
[    2.450541] hub 2-0:1.0: debounce: port 4: total 100ms stable 100ms status 0x100
[    2.450549] hub 5-0:1.0: state 7 ports 5 chg 0000 evt 0010
[    2.450558] hub 4-0:1.0: state 7 ports 5 chg 0000 evt 0008
[    2.703040] Switched to clocksource tsc
[  61.391128] input: HDA Creative Front Headphone as /devices/pci0000:00/0000:00:0c.0/0000:05:00.0/sound/card2/input15
[  61.391320] input: HDA Creative Line Out as /devices/pci0000:00/0000:00:0c.0/0000:05:00.0/sound/card2/input16
[  61.391501] input: HDA Creative Line as /devices/pci0000:00/0000:00:0c.0/0000:05:00.0/sound/card2/input17
[  61.391683] input: HDA Creative Mic as /devices/pci0000:00/0000:00:0c.0/0000:05:00.0/sound/card2/input18

I attached the full dmesg output if anyone thinks it might be relevant.

The system is using the ~amd64 keyword and is compiled with gcc-4.8.1 (not sure if that really affects this). Vanilla kernel 3.11.rc6 [It was happening with stable 3.10 and 3.11-rc5 as well].

Let me know if any other information is neccessary.

I have never encountered such issue before so I'm not sure what's causing it/how to solve it. Any help would be greatly appreciated.

gilead 08-20-2013 07:57 PM

According the the thread here, the solution was to disable acpi in the BIOS. Is that something you're able to try?

iro_number1 08-22-2013 01:48 PM

I just went through my bios options but the only thing about ACPI was related to S1 and S3. There seems to be no way of disabling it.
The board is a Gigabyte GA-990FXA-UD7, if anyone knows how to disable this.

For now i'll try to find a solution by trying to fix the TSC timer.

rigor 08-24-2013 11:51 PM

Hi iro_number1,

Some kernels have options which allow you to tell them to not use the ACPI or the TSC. If your kernel has those options, they might help.

Depending on what you have installed, you may find kernel parameter documentation on your system. In my case, an overview of kernel parameters is found at /usr/src/linux/Documentation/kernel-parameters.txt

You can also find a variety of related information from a doing an Internet for a collection of keywords such as: linux acpi boot param notsc

But here are a couple results. The first is ACPI and TSC related, and the second is a HOWTO of kernel parameters:

http://linuxpoison.blogspot.com/2010...arameters.html

http://www.cyberciti.biz/howto/quest...parameters.php

Hope this helps.


All times are GMT -5. The time now is 07:35 PM.