LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Gentoo (http://www.linuxquestions.org/questions/gentoo-87/)
-   -   Strange error starting apache - not showing up in google ;-) (http://www.linuxquestions.org/questions/gentoo-87/strange-error-starting-apache-not-showing-up-in-google-%3B-932155/)

MarcusWebb1966 03-01-2012 08:31 AM

Strange error starting apache - not showing up in google ;-)
 
Ok, so it's a gentoo distro on a virtual box patched up to the latest of everything, and etc-update and revdep-rebuild are not asking to do anything either. I'm trying to start Apache using any of the following:
Code:

/etc/init.d/apache2 start
/etc/init.d/apache2 restart
apache2ctl start
apache2ctl restart

and when doing so I get:

Code:

* Starting apache2 ...
 * start-stop-daemon: failed to start `/usr/sbin/apache2'        [ ok ]

which it clearly isn't, because I would like to see it running. Not sure what you'd need to see in the way of conf files and the like so do let me know. What I can tell you is that an
Code:

apache2ctl configtest
came back with no errors, so in that sense things are just fine.

As ever, your ideas, suggestions, and solutions gratefully accepted!

Kind Regards
Marcus

acid_kewpie 03-01-2012 09:58 AM

don't use the service script. run the httpd binary in foreground with debugging as a starting point for info. You've also not mentioend the apache error_log file... is it OK?

MarcusWebb1966 03-01-2012 10:06 AM

Ah, well the error_log tells me this:
Quote:

[Thu Mar 01 16:03:35 2012] [alert] (EAI 3)Temporary failure in name resolution: mod_unique_id: unable to find IPv4 address of "bab2"

MarcusWebb1966 03-01-2012 10:13 AM

... which has led me to the solution for the problem. There was no alias for bab2 in my /etc/hosts file. Thanks so much acid_kewpie, that really resolved matters for me!


All times are GMT -5. The time now is 07:32 PM.