LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 03-19-2010, 03:21 PM   #1
ursusca
Member
 
Registered: Sep 2008
Location: Toronto, ON, Canada
Distribution: Gentoo, RHEL (Fedora, CentOS, OEL), Ubuntu, FreeBSD, Solaris 10
Posts: 170

Rep: Reputation: 34
Set default sound card


Hello there!

I have ASUS M4A78-E motherboard. I've disabled Onboard sound card (VIA VT1708S) and installed Audigy sound card (c-media sb 8738 5.1 channel (CMI8738/PCI-6ch-LX)). My system detects now two audio devices.
Code:
$lspci -v
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
   Subsystem: ATI Technologies Inc RS780 Azalia controller
   Flags: bus master, fast devsel, latency 0, IRQ 19
   Memory at fbdfc000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 3
   Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
   Kernel driver in use: HDA Intel
   Kernel modules: snd-hda-intel

04:05.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
   Subsystem: Creative Labs SB0570 [SB Audigy SE]
   Flags: bus master, medium devsel, latency 64, IRQ 20
   I/O ports at ec00 [size=32]
   Capabilities: [dc] Power Management version 2
   Kernel driver in use: CA0106
   Kernel modules: snd-ca0106
ATI HDMI (part of the gpu) and my Audigy sound card. ATI HDMI is a dafault sound card now
Code:
cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfbdfc000 irq 19
 1 [CA0106         ]: CA0106 - CA0106
                      Audigy SE [SB0570] at 0xec00 irq 20
I've disabled HDA ATI HDMI in Gnome sound preference. How can I change default sound card on Audigy?

Thanks,
 
Old 03-21-2010, 03:43 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
There are a couple different ways to do this;
.asoundrc
http://alsa.opensrc.org/.asoundrc
depending on your baselayout version
/etc/modules.d/alsa or
/etc/modprobe.d/alsa.conf
http://groups.google.com/group/linux...bdddda5b1f1b9f
http://alsa.opensrc.org/index.php/Mu...an_GNU.2FLinux
/etc/asound.conf
http://en.gentoo-wiki.com/wiki/ALSA#...t_Sound_Device
HTH
 
Old 03-22-2010, 03:55 PM   #3
ursusca
Member
 
Registered: Sep 2008
Location: Toronto, ON, Canada
Distribution: Gentoo, RHEL (Fedora, CentOS, OEL), Ubuntu, FreeBSD, Solaris 10
Posts: 170

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by comprookie2000 View Post
There are a couple different ways to do this;
.asoundrc
http://alsa.opensrc.org/.asoundrc
depending on your baselayout version
/etc/modules.d/alsa or
/etc/modprobe.d/alsa.conf
http://groups.google.com/group/linux...bdddda5b1f1b9f
http://alsa.opensrc.org/index.php/Mu...an_GNU.2FLinux
/etc/asound.conf
http://en.gentoo-wiki.com/wiki/ALSA#...t_Sound_Device
HTH
Thank you comprookie2000!

I'm using baselayout version 1.
Code:
# emerge -p baselayout

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/baselayout-1.12.13
I've added this lines to my /etc/modprobe.d/alsa.conf file
Code:
# --- END: Generated by ALSACONF, do not edit. ---
#set default sound card
options snd-ca0106 index=0
alias snd-card-1 snd-hda-intel
options snd-hda-intel index=1
options snd cards_limit=2
Code:
# cat /etc/modprobe.d/alsa.conf 
# Alsa kernel modules' configuration file.

# ALSA portion
# OSS/Free portion

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.21 ---
alias snd-card-0 snd-ca0106
alias sound-slot-0 snd-ca0106
# --- END: Generated by ALSACONF, do not edit. ---
#set default sound card
options snd-ca0106 index=0
alias snd-card-1 snd-hda-intel
options snd-hda-intel index=1
options snd cards_limit=2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to make a sound card a Default Sound Card Srikanth VM Slackware 5 09-29-2009 05:01 AM
Default Sound card replica9000 Linux - Hardware 3 08-25-2008 11:59 AM
specify default sound card joelescoulie Slackware 2 07-12-2005 03:43 PM
Default sound card Wakeboardbum83 Suse/Novell 3 03-24-2005 12:13 PM
Set Default Ethernet Card omarswan Linux - General 4 10-07-2002 04:03 PM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration