LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-10-2012, 06:30 AM   #1
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 416

Rep: Reputation: 19
scrambled colors


I've just finished a major update (1GB download) which included moving to KDE-4.9.3.

While the desktop starts normally, the colours are totally scrambled, making it unusable.

My video is an ATI Mobility Radeon HD 2400, and x11-drivers/ati-drivers-12.11_beta has been built.

I know the hardware is good because another distro works fine.

Would this be a problem with the driver, KDE, or a combination?

Thanks
Jim
 
Old 12-10-2012, 09:47 AM   #2
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 49
I updated my Gentoo box to the latest KDE yesterday, although I have an Nvidia card (I've had problems with AMD cards in the past).

As a sanity check see that your opengl is set to the AMD driver. eselect opengl list; eselect opengl set <whatever option you need>

I would suggest rolling back to an earlier video driver; in your /etc/portage/package.mask file add >=x11-drivers/ati-drivers-12.8 and re-emerge your ati-drivers. This will roll you back to the 12.6 version.

Last edited by vik; 12-10-2012 at 09:50 AM.
 
Old 12-11-2012, 08:38 AM   #3
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 416

Original Poster
Rep: Reputation: 19
opengl is set to ati, and unfortunately rolling back did not solve the problem.

I'm wondering if there is something else involved? Up until now I have been using an xorg.conf, but as of this update it is no longer usable. The error is 'No screens found', and the logfile indicates one found but not acceptable.


Code:
Section "ServerFlags"
    #DontZap # disable <Ctrl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
#    Load "v4l" # Video for Linux
    Load "extmod"
    Load "glx" # 3D layer
    Load "dri" # direct rendering
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
#    Option "Protocol" "ExplorerPS/2"
    Option "Protocol" "Auto"
    Option "Device" "/dev/input/mice"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"

    Subsection "Display"
#        Viewport 0 0
        Depth    24
        Modes    "1920x1080"
    Endsubsection
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Acer"
    ModelName "H223HQ"
    HorizSync 30-80
    VertRefresh 55-75
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "ATI"
    BoardName "ATI Radeon HD 2400"
    Driver "radeon"
    Option "DPMS"
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
#    InputDevice "SynapticsMouse1" "SendCoreEvents"
    Screen "screen1"
EndSection
 
Old 12-11-2012, 05:38 PM   #4
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 49
It looks like your xorg.conf is messed up. If you're trying to use the fglrx driver you don't want this:
Code:
Section "Device"
    Identifier "device1"
    VendorName "ATI"
    BoardName "ATI Radeon HD 2400"
    Driver "radeon"
    Option "DPMS"
EndSection
because it will try to load the radeon driver which will conflict with the fglrx driver. Try renaming your xorg.conf to xorg.conf.bak and see if X comes up without an xorg.conf first. If that fails, run:
Code:
/opt/bin/aticonfig --initial
to create a new xorg.conf and see how it goes. You might want to blacklist the radeon module as well:
Code:
echo "blacklist radeon" >> /etc/modprobe.d/blacklist.conf

Last edited by vik; 12-11-2012 at 06:29 PM.
 
Old 12-12-2012, 01:13 AM   #5
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 416

Original Poster
Rep: Reputation: 19
Still batting .000

X does not start at all with xorg.conf present, and has bad colours when absent.
"blacklist radeon" had no effect. According to lsmod it was not loaded at boot time.
/opt/bin/aticonfig could not detect a supported card.

The hardware I'm using is a Toshiba Satellite M200 laptop with an external HD monitor. The internal screen was broken and removed. I have checked the physical connection to the monitor with another computer and it tests good.

I have unmerged ati-drivers, and still have bad colour. Is it possible that KDE 4.9.3 is sending garbage to the card?
 
Old 12-12-2012, 05:36 AM   #6
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 49
Simplest way to see if KDE is the problem would be to emerge twm and xterm, then pick that environment from KDM login. I do not think KDE is the problem though: it could be trying to use some opengl effects that are not well supported by your driver. Maybe try turning off desktop effects from "Workspace Appearance and Behavior" in System Settings?

Do you have radeon built into the kernel? If you do, blacklisting it won't help and it will conflict with fglrx.

On the distro that does work, check to see which driver is working for you: is it radeon or fglrx? What version of KDE do you have on that distro? Also, you could try taking that xorg.conf and moving it over to your current Gentoo setup and see how it goes...

Last edited by vik; 12-12-2012 at 05:59 AM.
 
Old 12-13-2012, 08:21 PM   #7
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 416

Original Poster
Rep: Reputation: 19
More pieces to the puzzle.
I went a bit overboard and installed Gnome. Still bad colours.

However this time I noticed that the 2 Tuxes (sp?) displayed at the beginning of the boot process are also defective.

I have just built a fresh 3.5.7 kernel.
Ascii colours seem to be OK.

The system that works uses a 2.6.39 kernel, and the same /. It has uvesafb loaded which the defective system does not. It also does not like the xorg.conf but works without it.
 
Old 12-13-2012, 08:47 PM   #8
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 49
I think we're narrowing it down: seeing bad colors before booting into X suggests you may be having problems with one of the AMD framebuffer modules. I believe it's just a matter of figuring out which modules you're actually using and seeing what's conflicting. My guess would be you're trying to use the KMS driver along with radeon, which has problems as noted here: http://en.gentoo-wiki.com/wiki/Radeon

1) first, what does your /etc/portage/make.conf VIDEO_CARDS= line looks like.

2) lsmod

3) let's see how your kernel is configured:
Code:
zcat /proc/config.gz | grep FB_RADEON
zcat /proc/config.gz | grep FB_ATY
zcat /proc/config.gz | grep DRM_RADEON
zcat /proc/config.gz | grep DRM_R128

Last edited by vik; 12-13-2012 at 08:51 PM.
 
Old 12-13-2012, 11:05 PM   #9
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 416

Original Poster
Rep: Reputation: 19
/etc/make.conf VIDEO_CARDS="ati"
Code:
lsmod:
  Good system         Bad
    uvesafb             pcspkr
    mmc_block           pc_ich
    mmc_core            sky2
    tifm_sd
    sky2
    pcspkr
    mac_hid

(- = not present as opposed to not set)
                     Good     Fail     Fail after trying to match Good
FB_RADEON           Not set     y       Not set
FB_RADEON_I2C         -         y       -
FB_RADEON_BACKLIGHT   -         Y       -
FB_RADEON_DEBUG       -         ns      -
FB_ATY                ns        ns      ns
FB_ATY128             -         ns      -
DRM_RADEON            -         m       ns
DRM_RADEON_KMS        -         ns      -
DRM_R128              -         ns      ns
Still no luck.
I forgot to add uvesafb in the latest try.
 
Old 12-14-2012, 06:41 AM   #10
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 49
Yep, looks like you were having problems with the AMD framebuffer modules. OK, since in Gentoo we don't usually use an initrd, you'll need to build in uvesa (CONFIG_FB_UVESA=Y) in order to boot. That's why on your good system it was a module and still worked fine, whereas on your Gentoo install it's broken. While you're still building your kernel, make sure you unset Device Drivers->Graphics Support->Direct Rendering Manager as mentioned in the gentoo fglrx guide. This should also remove your Radeon module so now you only have fglrx and uvesa.

Now, after boot edit your /etc/make.conf like this:
Code:
VIDEO_CARDS="fglrx"
And do a emerge -uND world. That should pull in the ati drivers for you automatically and eselect opengl as well.

Now, you should be able to startx and hopefully have everything work.

Last edited by vik; 12-14-2012 at 06:57 AM.
 
Old 12-16-2012, 09:16 PM   #11
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 416

Original Poster
Rep: Reputation: 19
None of the above helped. However I have found another clue.

The version that works uses the default vga setting when booting, making for a rather poor display on an full HD monitor. I changed it to vga=883 (0x0373) which has been working up until the update. It gives me a 240 character line in console mode. Instant fail!

I changed to vga=794 which gives me a 160 character line and all is well. Except I don't have the full benefit of the HD screen. I think I will try "1920x1080" as that works on my other system.
 
Old 12-17-2012, 10:28 AM   #12
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 49
A few things you could try:

1) If games aren't a priority for you, you could try the open-source radeon driver and see if you have better luck.

2) Take a look at your emerge log when you updated. Revert all packages to the pre-update state and test updating each one individually until you find what's causing the issue. What a pain though...

3) Alternatively if you're tired of messing with it, I would recommend you try a few distros with live CDs and see if any of them bring up X correctly.

FYI, specifying vga=ask in your grub kernel args will bring up a list of the modes your video card will support when you boot.

Last edited by vik; 12-17-2012 at 10:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure Xterm colors if my xterm can support 256 colors n179911 Linux - Software 4 07-06-2009 02:28 AM
How to change shell to have nice colors and look cool? Penguin likes cool colors! newtovanilla Linux - Newbie 3 11-28-2008 12:55 PM
scrambled screen nin881 Suse/Novell 5 10-07-2005 09:32 PM
Scrambled Console Fordor Slackware 4 07-31-2004 04:02 AM
nvidia scrambled neoh Linux - Hardware 2 10-29-2003 10:23 PM


All times are GMT -5. The time now is 01:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration