LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices



Reply
 
Search this Thread
Old 05-19-2011, 08:33 PM   #1
crosstalk
Member
 
Registered: Jul 2010
Distribution: Gentoo, Debian, Mint, Xubuntu
Posts: 150

Rep: Reputation: 35
revdep-rebuild always recompiles evolution-data-server


Whenever I run revdep-rebuild, it always recompiles evolution-data-server. It does not appear to have any negative consequences, other than the wasted time and processing power.

Code:
sudo revdep-rebuild -p
 * Configuring search environment for revdep-rebuild
  File "<string>", line 1
    import os; import pwd; print pwd.getpwuid(os.getuid())[0]
                                   ^
SyntaxError: invalid syntax

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 9% ]  *   broken /usr/bin/eggcacher (requires libpython2.6.so.1.0)
[ 19% ]  *   broken /usr/bin/packpanda (requires libpython2.6.so.1.0)
[ 56% ]  *   broken /usr/lib/libedataserverui-1.2.so.8 (requires libeggdbus-1.so.0)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *  !!! /usr/bin/eggcacher not owned by any package is broken !!!
 *   /usr/bin/eggcacher -> (none)
 *  !!! /usr/bin/packpanda not owned by any package is broken !!!
 *   /usr/bin/packpanda -> (none)
 *   /usr/lib/libedataserverui-1.2.so.8 -> gnome-extra/evolution-data-server
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --oneshot --pretend  gnome-extra/evolution-data-server:0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] gnome-extra/evolution-data-server-2.32.2 
 * Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.
Code:
ldd /usr/lib/libedataserverui-1.2.so.8 
	linux-gate.so.1 =>  (0xb7735000)
	libebook-1.2.so.9 => /usr/lib/libebook-1.2.so.9 (0xb76c7000)
	libcamel-1.2.so.14 => /usr/lib/libcamel-1.2.so.14 (0xb7666000)
	libssl3.so => /usr/lib/libssl3.so (0xb762f000)
	libsmime3.so => /usr/lib/libsmime3.so (0xb7608000)
	libnssutil3.so => /usr/lib/libnssutil3.so (0xb75ec000)
	libnss3.so => /usr/lib/libnss3.so (0xb74d7000)
	libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xb7464000)
	libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0xb73cb000)
	libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0xb73ab000)
	libcom_err.so.2 => /lib/libcom_err.so.2 (0xb73a7000)
	libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0xb737f000)
	libedataserver-1.2.so.13 => /usr/lib/libedataserver-1.2.so.13 (0xb735d000)
	libplds4.so => /usr/lib/libplds4.so (0xb7358000)
	libplc4.so => /usr/lib/libplc4.so (0xb7352000)
	libnspr4.so => /usr/lib/libnspr4.so (0xb731b000)
	libsoup-2.4.so.1 => /usr/lib/libsoup-2.4.so.1 (0xb72d9000)
	libgnutls.so.26 => /usr/lib/libgnutls.so.26 (0xb7259000)
	libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0xb724b000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb6e7b000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb6de1000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb6dc7000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb6db1000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6da6000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb6d88000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6caf000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb6c61000)
	libpng14.so.14 => /usr/lib/libpng14.so.14 (0xb6c42000)
	libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0 (0xb6c3e000)
	libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb6c36000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6c2d000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xb6b2a000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6b12000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xb6b0e000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6b08000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb6acd000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6aa3000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6a32000)
	libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb6a13000)
	libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6921000)
	libm.so.6 => /lib/libm.so.6 (0xb68fb000)
	libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0xb68cd000)
	libORBit-2.so.0 => /usr/lib/libORBit-2.so.0 (0xb6881000)
	libgnome-keyring.so.0 => /usr/lib/libgnome-keyring.so.0 (0xb6869000)
	libeggdbus-1.so.0 => not found
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb684c000)
	libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb6819000)
	libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb6744000)
	libresolv.so.2 => /lib/libresolv.so.2 (0xb672f000)
	libz.so.1 => /lib/libz.so.1 (0xb671d000)
	libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb66ea000)
	libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb66e6000)
	libdl.so.2 => /lib/libdl.so.2 (0xb66e2000)
	libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb66dc000)
	librt.so.1 => /lib/librt.so.1 (0xb66d3000)
	libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0xb666b000)
	libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0xb6666000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb658b000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xb6571000)
	libc.so.6 => /lib/libc.so.6 (0xb641b000)
	libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0xb6414000)
	libkeyutils.so.1 => /lib/libkeyutils.so.1 (0xb6411000)
	/lib/ld-linux.so.2 (0xb7736000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb640a000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0xb63fd000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb63f5000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0xb63e7000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb63dd000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb63d8000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb63d4000)
	libEGL.so.1 => /usr/lib/libEGL.so.1 (0xb63c7000)
	libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0xb63c3000)
	libGL.so.1 => //usr/lib/opengl/xorg-x11/lib/libGL.so.1 (0xb6371000)
	libicuuc.so.46 => /usr/lib/libicuuc.so.46 (0xb6265000)
	libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb625f000)
	libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0xb625b000)
	libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0xb6249000)
	libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb623f000)
	libicudata.so.46 => /usr/lib/libicudata.so.46 (0xb53c0000)
	libstdc++.so.6 => /usr/lib/gcc/i686-pc-linux-gnu/4.4.5/libstdc++.so.6 (0xb52c7000)
	libgcc_s.so.1 => /usr/lib/gcc/i686-pc-linux-gnu/4.4.5/libgcc_s.so.1 (0xb52aa000)
Thanks for any help in stopping this behavior.
 
Old 05-20-2011, 12:11 AM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
what is you main active version of python?

Code:
eselect python list
Have you done a depclean lately?

Code:
emerge --depclean -av
 
Old 05-20-2011, 08:36 AM   #3
crosstalk
Member
 
Registered: Jul 2010
Distribution: Gentoo, Debian, Mint, Xubuntu
Posts: 150

Original Poster
Rep: Reputation: 35
Here's my Python version:

Code:
eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.1 *
I have done a depclean recently (i.e. yesterday).

Thanks for the help.
 
Old 05-20-2011, 08:52 AM   #4
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
You shouldn't have your main active version of python be python-3

Set it to python-2.7

Code:
eselect python set 1

Quote:
[lxde@msi-gentoo ~]$ eselect python list
Available Python interpreters:
[1] python2.7 *
[2] python3.2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to stop evolution-data-server from loading? Darkover Debian 1 05-31-2006 12:16 AM
evolution-data-server and GCC 4.0.x ParticleHunter Linux From Scratch 0 04-26-2006 09:39 AM
Building evolution-data-server-1.0.2-7.src.rpm louisb Linux - Enterprise 1 07-02-2005 05:45 PM
Building evolution-data-server-1.0.2-7.src.rpm louisb Linux - General 1 06-22-2005 09:21 AM
revdep-rebuild error in Gentoo vharishankar Linux - Distributions 2 06-10-2005 05:05 AM


All times are GMT -5. The time now is 07:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration