LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 03-05-2012, 10:51 PM   #1
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
No networking with wicd 1.7.1_pre20120127?


I'm using version 1.7.1_pre20120127 with python 2.7.2:
Code:
[U] net-misc/wicd
     Available versions:  1.7.0 (~)1.7.0-r1 1.7.1_beta2-r4 (~)1.7.1_pre20111210-r1 1.7.1_pre20120127 (~)1.7.1_pre20120127-r1 (~)1.7.1 (~)1.7.1-r1 {X ambiance +gtk ioctl libnotify mac4lin ncurses nls +pm-utils}
     Installed versions:  1.7.1_pre20120127(01:42:42 PM 02/29/2012)(X gtk libnotify ncurses nls pm-utils -ioctl -mac4lin)
     Homepage:            http://wicd.sourceforge.net/
     Description:         A lightweight wired and wireless network manager for Linux
I followed this guide to install and configure: http://en.gentoo-wiki.com/wiki/Wicd

If I add wicd to the defaults runlevel, it always ask for root password after boot. But if I add it to the boot runlevel, there is no connection (both wired and wireless) although the logs say "successful":
Code:
Putting interface up...
Running DHCP with hostname gentoo
dhcpcd[5063]: version 5.2.12 starting

dhcpcd[5063]: eth0: broadcasting for a lease

dhcpcd[5063]: eth0: offered 192.168.15.36 from 192.168.15.1

dhcpcd[5063]: eth0: acknowledged 192.168.15.36 from 192.168.15.1

dhcpcd[5063]: eth0: checking for 192.168.15.36

dhcpcd[5063]: eth0: leased 192.168.15.36 for 600 seconds

dhcpcd[5063]: forked to background, child pid 5094


DHCP connection successful
Connecting thread exiting.
Sending connection attempt result success
wicd-gtk shows "Not connected" and eth0 has no IP:
Code:
eth0      Link encap:Ethernet  HWaddr 00:13:a9:4f:84:44  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1860 errors:0 dropped:2 overruns:0 frame:0
          TX packets:301 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:205470 (200.6 KiB)  TX bytes:34017 (33.2 KiB)
          Interrupt:16
 
Old 03-07-2012, 03:10 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,131

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
Is your wireless interface eth0?
Usually it's wlan0 with eth0 being the nic.
 
Old 03-08-2012, 01:57 AM   #3
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by business_kid View Post
Is your wireless interface eth0?
No. My wireless interface is wlan0. Why did you ask that?
 
Old 03-09-2012, 10:56 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,131

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
You seem to have a wired connection. Wicd is a wireless thing, I thought; it doesn't worry about wired connections.

Many laptops also have a BIOS option "Fast Ethernet Switching" meaning that if you configure the nic, the wifi is switched off and vice versa - to save power.

Once dhcpcd connects, you should be able to surf. If not, try pinging a url and an ip
e.g. ping 4.4.4.4
ping linuxquestions.org
 
  


Reply

Tags
wicd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wicd Fantastic Linux - Software 2 03-31-2011 11:00 AM
Networking in Virtualbox, WICD and no Gnome network manager yanfaun Linux - Virtualization and Cloud 8 06-01-2010 05:07 PM
wicd Polanski Linux - Software 14 04-13-2010 06:51 PM
where is wicd 1.7 ? witek Slackware 6 01-25-2010 04:36 PM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM


All times are GMT -5. The time now is 03:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration