Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Gentoo This forum is for the discussion of Gentoo Linux.


  Search this Thread
Old 06-09-2012, 05:49 AM   #1
Registered: Dec 2009
Distribution: Arch
Posts: 103

Rep: Reputation: 2
No mouse or keyboard input after install of Ati-drivers

Hi all,

After installing the proprietary drivers (radeon gets my laptop too hot that it shuts off) I am unable to use the keyboardor muse. They worked fine beforehand but now I get nothing. All I can do is jab the power button

In my Xorg.log it tells me 'module does not exist' for both synaptics and evdev.
There is no reason for this: they are both in my make.conf and worked fine when I was using radeon.



I changed my Xorg.conf to something like
Section Device
Identifier. "radeonhd"
Driver. "fglrx"
End section

on the advice of a similar forum post. I get the same problem as with the ati xorg.conf

Last edited by origami-sheep; 06-09-2012 at 05:58 AM.
Old 06-09-2012, 06:40 PM   #2
Senior Member
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Please show us your full /var/log/Xorg.0.log file.
Old 06-10-2012, 02:11 AM   #3
Registered: Dec 2009
Distribution: Arch
Posts: 103

Original Poster
Rep: Reputation: 2
Sorry I would have posted back: as a shot in the dark I rebuilt xf86-input-synaptics, xf-evdev and xf-mouse and it started working again. It may be due to the downgrade in xorg-server (fglrx requires 1.11)
Old 06-11-2012, 02:12 AM   #4
Gentoo support team
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,052

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
That was the reason.

To be on the safe side, you need to recompile all the xf86-* packages when updating or downgrading the x server.


ati, evdev, fglrx, synaptics

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Grabbing keyboard and mouse input philips217 Programming 1 11-21-2006 01:05 AM
Mouse Doesn't work after i download/install ati drivers... gbdavidx Slackware 5 08-18-2005 05:17 PM
X11 Input drivers (keyboard and mouse), events Cyborg16 Linux - Software 1 05-22-2005 10:01 AM
Disable mouse, keyboard or other input devices / drivers bastl Programming 0 05-15-2005 07:39 AM
my mouse input is takes as keyboard input in BASH e1000 Slackware 5 12-08-2003 04:00 PM

All times are GMT -5. The time now is 01:24 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration