LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 12-28-2009, 09:03 AM   #1
NoWone
LQ Newbie
 
Registered: Jan 2005
Location: Italy
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
Question Newbie,ppc64: a problem with portage, trying to understand how gentoo works


Hello. I've installed Gentoo linux on a ppc64 system (Sony PS3) using the 64bit userland and everything went fine.

Now I'm trying to understand how portage works and having some trouble with it. The issue is as follows:

When I first booted up the system portage notified me there was an update available - I did "emerge portage" and it began compiling stuff. Unluckily, it upgraded python aswell (from 2.5 to 3.1) and after installing it the system told me it would be unwise to use python3 as some modules were not ported yet and stick with python2 (what's the point installing it in the first place, then?!) - but anyways. Now "emerge portage" gives me this:

Code:
localhost ~ # emerge portage
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/portage-2.1.7.16
 * portage-2.1.7.16.patch.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                         [ ok ]
 * portage-2.1.7.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                              [ ok ]
 * checking ebuild checksums ;-) ...                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                [ ok ]
 * Attempting to select a compatible default python interpreter
 * Unable to select a compatible default python interpreter!
 *
 * ERROR: sys-apps/portage-2.1.7.16 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   portage-2.1.7.16.ebuild, line   92:  Called die
 * The specific snippet of code:
 *                      die "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see \`eselect python --help\`)."
 *  The die message:
 *   This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`).
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.7.16/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.7.16/temp/die.env'.
 *

>>> Failed to emerge sys-apps/portage-2.1.7.16, Log file:

>>>  '/var/tmp/portage/sys-apps/portage-2.1.7.16/temp/build.log'

 * Messages for package sys-apps/portage-2.1.7.16:

 * Attempting to select a compatible default python interpreter
 * Unable to select a compatible default python interpreter!
 *
 * ERROR: sys-apps/portage-2.1.7.16 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   portage-2.1.7.16.ebuild, line   92:  Called die
 * The specific snippet of code:
 *                      die "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see \`eselect python --help\`)."
 *  The die message:
 *   This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`).
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.7.16/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.7.16/temp/die.env'.
 *
portage complains it needs python-2.6 and won't work with 3.1. But now I have python-2.5 and 3.1, but no 2.6 so portage won't update itself. (eselect python list gives me these 2 choices.) Can someone please tell me how to fix this situation? Thank you!!

NW.
 
Old 12-28-2009, 06:50 PM   #2
NoWone
LQ Newbie
 
Registered: Jan 2005
Location: Italy
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
Solved.

Code:
emerge -a python:2.6
eselect python set python2.6
emerge -a portage
emerge -aC python:3.1
echo '>=dev-lang/python-3' >> /etc/portage/package.mask  # or if that is a directory, a file in there
python-updater
 
  


Reply

Tags
portage, python


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gentoo portage problem!!! matrixon Linux - Software 1 09-28-2006 10:25 AM
Gentoo Portage Problem jarrettsloan Linux - Newbie 1 09-10-2005 08:57 PM
gentoo portage suse python problem ... steefje Linux - Software 1 10-31-2004 07:28 AM
newbie learning to update Portage (w/Gentoo) Help! masterspud777 Linux - General 2 08-01-2003 06:23 PM
Gentoo portage problem mopron Linux - Distributions 0 05-29-2003 02:27 PM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration