LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices



Reply
 
Search this Thread
Old 11-09-2011, 10:18 AM   #1
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Rep: Reputation: 55
Netbeans fails to emerge


All dependencies have been successfully emerged except for "dev-util/netbeans". This is the error I get when I run
Code:
emerge -av --oneshot dev-util/netbeans
Code:
nblib:
    [mkdir] Created dir: /var/tmp/portage/dev-util/netbeans-6.8-r1/work/java.source.ant/build/antclasses
    [javac] Compiling 3 source files to /var/tmp/portage/dev-util/netbeans-6.8-r1/work/java.source.ant/build/antclasses

   [repeat] /var/tmp/portage/dev-util/netbeans-6.8-r1/work/java.source.ant/antsrc/org/netbeans/modules/java/source/ant/JavacTask.java:107: package CheckForCleanBuilds does not exist
   [repeat]             if (CheckForCleanBuilds.cleanBuild.get() && getSrcdir() != null) {
   [repeat]                                    ^
   [repeat] 1 error
  [nbmerge] Failed to build target: all-java.source.ant

BUILD FAILED
/var/tmp/portage/dev-util/netbeans-6.8-r1/work/nbbuild/build.xml:362: The following error occurred while executing this line:
/var/tmp/portage/dev-util/netbeans-6.8-r1/work/nbbuild/build.xml:357: The following error occurred while executing this line:
/var/tmp/portage/dev-util/netbeans-6.8-r1/work/nbbuild/build.xml:392: The following error occurred while executing this line:
/var/tmp/portage/dev-util/netbeans-6.8-r1/work/nbbuild/build.xml:375: The following error occurred while executing this line:
/var/tmp/portage/dev-util/netbeans-6.8-r1/work/nbbuild/build.xml:357: The following error occurred while executing this line:
/var/tmp/portage/dev-util/netbeans-6.8-r1/work/nbbuild/build.xml:404: The following error occurred while executing this line:
/var/tmp/portage/dev-util/netbeans-6.8-r1/work/java.source.ant/build.xml:49: Compile failed; see the compiler error output for details.

Total time: 12 minutes 50 seconds
 * ERROR: dev-util/netbeans-6.8-r1 failed (compile phase):
 *   eant failed
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 4884:  Called eant '-Dstop.when.broken.modules=true' '-Dpermit.jdk6.builds=true' '-Dbuild.compiler.deprecation=false' '-Dnb.clusters.list=nb.cluster.platform,nb.cluster.apisupport,nb.cluster.cnd,nb.cluster.dlight,nb.cluster.harness,nb.cluster.ide,nb.cluster.java,nb.cluster.nb,nb.cluster.websvccommon' '-f' 'nbbuild/build.xml' 'build-nozip'
 *   environment, line 1194:  Called die
 * The specific snippet of code:
 *       ant ${antflags} "${@}" || die "eant failed"
 * 
 * If you need support, post the output of 'emerge --info =dev-util/netbeans-6.8-r1',
 * the complete build log and the output of 'emerge -pqv =dev-util/netbeans-6.8-r1'.
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea6-bin  CLASSPATH="" JAVA_HOME="/opt/icedtea6-bin-1.10.4"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER="javac"
and of course, the output of emerge --info
 * The complete build log is located at '/var/tmp/portage/dev-util/netbeans-6.8-r1/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/dev-util/netbeans-6.8-r1/temp/environment'.
 * S: '/var/tmp/portage/dev-util/netbeans-6.8-r1/work'

>>> Failed to emerge dev-util/netbeans-6.8-r1, Log file:
>>>  '/var/tmp/portage/dev-util/netbeans-6.8-r1/temp/build.log'

 * Messages for package dev-util/netbeans-6.8-r1:

 * ERROR: dev-util/netbeans-6.8-r1 failed (compile phase):
 *   eant failed
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 4884:  Called eant '-Dstop.when.broken.modules=true' '-Dpermit.jdk6.builds=true' '-Dbuild.compiler.deprecation=false' '-Dnb.clusters.list=nb.cluster.platform,nb.cluster.apisupport,nb.cluster.cnd,nb.cluster.dlight,nb.cluster.harness,nb.cluster.ide,nb.cluster.java,nb.cluster.nb,nb.cluster.websvccommon' '-f' 'nbbuild/build.xml' 'build-nozip'
 *   environment, line 1194:  Called die
 * The specific snippet of code:
 *       ant ${antflags} "${@}" || die "eant failed"
 * 
 * If you need support, post the output of 'emerge --info =dev-util/netbeans-6.8-r1',
 * the complete build log and the output of 'emerge -pqv =dev-util/netbeans-6.8-r1'.
 * The complete build log is located at '/var/tmp/portage/dev-util/netbeans-6.8-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/netbeans-6.8-r1/temp/environment'.
 * S: '/var/tmp/portage/dev-util/netbeans-6.8-r1/work'
I read in another forum to run
Code:
export -n DISPLAY
and
Code:
USE="java source"
prior to emerge, both with no success.

Here is the output of --pretend (to provide my USE flags, modules etc.):
Code:
 # emerge -pv --oneshot dev-util/netbeans

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-util/netbeans-6.8-r1  USE="-debug -doc" LINGUAS="-ar -ca -cs -de -es -fr -gl -id -it -ja -ko -nl -pl -pt_BR -ro -ru -sq -sv -tr -zh_CN -zh_TW" NETBEANS_MODULES="apisupport cnd dlight harness ide java nb websvccommon -enterprise -ergonomics -groovy -identity -mobility -php -profiler -ruby" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB
Any hints?
 
Old 11-11-2011, 08:05 AM   #2
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Original Poster
Rep: Reputation: 55
I switched my java-vm from icedtea6-bin to sun-jdk-1.6 and netbeans emerged and works ok.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Emerge fails almost 50% of the time Connery Linux - Newbie 5 07-23-2009 11:05 PM
Fluxbox emerge fails..need some help GUIPenguin Linux - General 1 02-14-2006 09:31 AM
Stepmania 3.9-rc3 emerge fails slithy Linux - Games 1 11-22-2005 06:32 AM
Emerge xine-ui fails richcm Linux - Software 2 10-18-2005 12:13 PM
Gentoo: emerge system fails AncAlAgoN Linux - Laptop and Netbook 2 05-23-2004 10:55 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration