LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 06-27-2011, 10:12 PM   #1
Gaidal
LQ Newbie
 
Registered: May 2002
Location: Sweden
Distribution: Arch x64
Posts: 29
Blog Entries: 2

Rep: Reputation: 0
Missing keys in terminal - wrong language?


I'm posting this under Gentoo because I never had the problem in Debian or Slackware.

In the console I can type extended ASCII characters such as , and as you can see it also works in Firefox. However in rxvt-unicode, I can't use these keys - nothing happens when I press them.
It is compiled with everything I thought might be relevant:
Code:
unicode3 truetype iso14755
.

I've read through the Gentoo UTF-8 guide and followed those steps, I didn't really work. After doing as it said, "locale" still shows "POSIX" for each value. If I set LANG to en_US.UTF-8 manually it doesn't change anything though so I guess it's not relevant.

My /usr/share/X11/xorg.conf.d/10-evdev.conf has
Code:
Option "XkbLayout" "se"
and, well, it is obviously working since all keys are in the right place and I can use in other X programs...

I've been searching for a while but there's so much information about various similar issues, much of which is outdated, and I'm not sure what I'm looking for here or what's relevant, as you might notice. :)

I thought urxvt might be choosing a version of the terminus font that is missing those characters, but the problem remained after changing fonts. I use xft in urxvt if it's relevant somehow.

***

Once I fix this, I'd like to edit the keymap. This is very convenient for the console since I can edit the .gz files in
Code:
/usr/share/keymaps
directly with vim. But how do I do the same file or method in X? Or do I have to use xmodmap there?
 
Old 07-07-2011, 01:23 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,971

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by Gaidal View Post
My /usr/share/X11/xorg.conf.d/10-evdev.conf has
Code:
Option "XkbLayout" "se"
Hello Gaidal, I think you missunderstood how this files work. The files in /usr/share/X11/xorg.conf.d are only templates! In order to get them working you'll have to copy them to /etc/X11/xorg.conf.d/ and then restart the X-server. This should work for you.

Markus
 
1 members found this post helpful.
Old 07-08-2011, 04:59 AM   #3
Gaidal
LQ Newbie
 
Registered: May 2002
Location: Sweden
Distribution: Arch x64
Posts: 29
Blog Entries: 2

Original Poster
Rep: Reputation: 0
Oh, that could be it.

Or could it, even though I have the right keymap in X other programs, just not in the terminal?

Unfortunately I destroyed that computer by pouring hot soup over it (!) and can't try this.
When I either have it repaired or get a new one and install Gentoo again, I will return and mark this as solved. Thank you!
 
  


Reply

Tags
keymapping, keymaps, urxvt, utf8


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
some wrong keys in xterm val3xiv Slackware 2 09-04-2009 01:53 AM
Wrong keys on keyboard when in terminal mode boerkees Linux - Newbie 2 05-15-2009 03:51 PM
How to setup Hot keys language layout switching? loom Linux - Newbie 7 05-22-2007 06:08 AM
Some keys don't work ... others are wrong??? sys7em Slackware 1 10-09-2004 08:30 PM
keys are wrong FEDORA jax8 Linux - Newbie 2 03-17-2004 04:43 PM


All times are GMT -5. The time now is 06:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration