LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 08-17-2009, 11:54 PM   #1
darkhand
LQ Newbie
 
Registered: Aug 2009
Location: Houston, TX
Posts: 6

Rep: Reputation: 0
Lost ability to change Virtual Terminals [ Fluxbox, Xorg ]


I haven't booted into linux in a while,but this week I booted it up, updated most of my software, played with it and tried to reconfigure everything to my liking. However, now I've lost the ability to change virtual terminals using CTRL+ALT+F1/F2/F3 etc. I'm using the latest Fluxbox from git repo. and Xorg-7.2, also using nvidia drivers.

This worked at the beginning of the week until recently when I overhauled most of my software. I also noticed when updating fluxbox that my keybindings no longer worked and had to manually edit the ~/.fluxbox/keys config. This could be the culprit but I couldn't find any documentation on implementing the ability to change virtual terminals.

Last edited by darkhand; 08-21-2009 at 05:58 PM.
 
Old 08-18-2009, 12:22 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Hi, welcome to LQ!

Please, do tell us which distro you're using, and what its default
run-level is ...



Cheers,
Tink
 
Old 08-18-2009, 12:30 AM   #3
darkhand
LQ Newbie
 
Registered: Aug 2009
Location: Houston, TX
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the welcome! I am using Gentoo with kernel 2.6.30. Not sure what default runlevel is, never had that question come up.
 
Old 08-18-2009, 03:02 AM   #4
darkhand
LQ Newbie
 
Registered: Aug 2009
Location: Houston, TX
Posts: 6

Original Poster
Rep: Reputation: 0
I recently configured Xorg to use HAL and evdev, is this what could have done it?
 
Old 08-18-2009, 05:47 AM   #5
darkhand
LQ Newbie
 
Registered: Aug 2009
Location: Houston, TX
Posts: 6

Original Poster
Rep: Reputation: 0
Installed xbindkeys and configured control+alt+f1 to execute command "chvt 1"

Now I get a blank screen, no text, monitor is not asleep. Alt+F7 puts me back into X windows session.

Now there must be an xorg.conf misconfiguration, anyone have ideas?
 
Old 08-18-2009, 01:53 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Moved: This thread is more suitable in <GENTOO> and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 08-21-2009, 10:08 AM   #7
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
The fact that the key combos stopped working could be related with the migration to hal/evdev, though I haven't seen it myself. It could also be a fluxbox or xbindkeys binding which is overwriting the default bindings to switch vt.

However, the fact that using chvt you can't see the vt either shouldn't have anything to do with that. That could be related to some graphics driver issue. If you are using a proprietary driver for an nvidia or ati card, make sure that you haven't enabled nvidiafb or radeonfb in your kernel. Or better, disable the framebuffer completely, just to test. You should also test the X logs and make sure that you didn't modify your /etc/inittab in any strange ways.
 
Old 08-21-2009, 05:54 PM   #8
darkhand
LQ Newbie
 
Registered: Aug 2009
Location: Houston, TX
Posts: 6

Original Poster
Rep: Reputation: 0
I previously posted in Gentoo forums:
Quote:
Reconfigured HAL fdi policies, printed out the READMEs and sat on the toilet for quite a while reading it. (My legs fell asleep).
Got the keyboard working with all the binds correct and it's like freaking magic!

Found a few threads pointing to this: http://dev.gentoo.org/~spock/projects/uvesafb/, apparently the nvidia vesa frame buffer doesn't cooperate. Going to see how rebuilding the kernel with these options plays-out.
This didn't work.

I don't know much about framebuffers, what would disabling it do?
 
Old 08-21-2009, 06:12 PM   #9
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
It would mean that you would only have an 80x25 characters text console when you are outside X, and you will have no graphics support in the console (the terminals inside X have nothing to do with this, and will continue to work as always). Disabling it is as easy as to take off your video or vga option (or whatever your fb driver uses) from the boot line in your grub.conf. You could just copy the relevant section, and replicate it so you have the option to boot with or without fb enabled, and see if that makes a difference.
 
Old 08-22-2009, 03:14 PM   #10
darkhand
LQ Newbie
 
Registered: Aug 2009
Location: Houston, TX
Posts: 6

Original Poster
Rep: Reputation: 0
This still didn't work. Do you think nvidia's fb is built into the kernel with a higher priority? Even changing to the uvesafb and changing options at boot didn't change the CLI terminal at all. I appreciate your help, though. I'm still snooping around for some info.

PS: Honestly this isn't a big deal, I don't use it that often, but it is helpful sometimes. It is just weird to lose functionality all of a sudden.

Last edited by darkhand; 08-22-2009 at 03:17 PM.
 
Old 08-22-2009, 03:22 PM   #11
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Originally Posted by darkhand View Post
This still didn't work. Do you think nvidia's fb is built into the kernel with a higher priority? Even changing to the uvesafb and changing options at boot didn't change the CLI terminal at all. I appreciate your help, though. I'm still snooping around for some info.
I don't think it's about priority, however if nvidiafb is built there could be some incompatibility, even if you don't use it. But I really can't know or guarantee whether that's related to your problem or not. It might be an entirely different issue.

You could also try different versions of the nvidia X driver. The problem could lie in a number of places.
 
  


Reply

Tags
nvidia, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change fonts on virtual terminals? MrUmunhum Linux - General 4 04-03-2009 08:23 AM
Lost ability demsg VampireL0rd Linux - Software 1 03-03-2006 10:17 PM
lost ability to su bax Linux - Security 3 01-29-2005 03:32 AM
Change change virtual terminals acid2000 Linux - Software 0 05-28-2003 04:51 PM
Lost printing ability struggler Linux - Newbie 1 02-21-2002 10:16 PM


All times are GMT -5. The time now is 11:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration