LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-08-2009, 08:47 AM   #1
rrrssssss
Member
 
Registered: Mar 2005
Posts: 263

Rep: Reputation: 32
KDE language packs - Can I make Portage skip over them (emerge kde-meta)?


Hello Gentoo forum,

Is there a way to make Portage skip over the kde-base/kde-l10n language packs when installing or upgrading KDE (emerge kde-meta)? I speak only English so I do not need them. These language packs are 280 MB in size and it takes me 28 hours to download them since I only have a dial-up Internet connection.

Furthermore, why does Portage download them when the use flags for each individual language pack are turned off (below)?

kde-base/kde-l10n-4.3.3 [4.3.1] USE="handbook (-aqua) (-kdeprefix)" LINGUAS="-ar -bg -bn_IN -ca -cs -csb -da -de -el -en_GB -es -et -eu -fi -fr -ga -gl -gu -he -hi -hne -hr -hu -is -it -ja -kk -km -kn -ko -ku -lt -lv -mai -mk -ml -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tg -th -tr -uk -wa -zh_CN -zh_TW" 0 kB

I do not knowingly have these use flags set anywhere on my system.

The problem *may* be because I am using "emerge kde-meta" which might explain why masking "kde-l10n" in package.mask will cause the operation to abort, saying it is a required package.

Using the LANGUAS= option in /etc/make.conf does not effect what is downloaded. It only effects what is installed.

Thank you in advance,
Roy

Last edited by rrrssssss; 11-08-2009 at 02:47 PM. Reason: clarity
 
Old 11-08-2009, 08:57 AM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Why do you need to install them in the first place?
And afaik adding LINGUAS="en" in /etc/make.conf is enough, no need to additionally install any language pack if you don't need.
Try to mask the kde-base/kde-l10n-4.3.3 in package.mask and see what happens.

Last edited by ~sHyLoCk~; 11-08-2009 at 08:58 AM.
 
Old 11-08-2009, 09:00 AM   #3
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hello rrrssssss,

as far as I can see it portage doesn't download any of this language-files since they all have a "-" sign and are therefore excluded. The "0kB" at the end of the language-listing in you post tells you that there will be nothing downloaded.

Another question is why you want to emerge the l10n-package if you don't need it. As far as I know this package makes only sense for poeple in not-english-speaking countries.

Markus

Last edited by markush; 11-08-2009 at 09:03 AM.
 
Old 11-08-2009, 09:21 AM   #4
rrrssssss
Member
 
Registered: Mar 2005
Posts: 263

Original Poster
Rep: Reputation: 32
Thanks for the replies,

I put kde-base/kde-l10n in the package.mask file but got the message below when I ran "emerge kde-meta":

!!! All ebuilds that could satisfy ">=kde-base/kde-l10n-4.3.3[-kdeprefix]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kde-l10n-4.3.3 (masked by: package.mask)


Also, even though kde-base/kde-l10n says "0kb", it will still download each and every language pack because that is what happened when I installed KDE 4.3.1. As a matter of fact, there were dozens of packages that said "0kb" and it still downloaded the packages anyway.

I put LINGUAS="en_GB" in /etc/make.conf but portage is still downloading each and every language pack. I'm assuming "en_GB is English because I could not see anything for "en".

Anyone?

Thanks in advance,
Roy

UPDATE -----------
UPDATE --------------

Sorry, I spoke too soon when I said the packages with "0kb will download. If a package says "0kb, it will not download because it is part of one of the meta packages that have already downloaded. The only exception to the rule would be the kde-l10n language pack package and the only reason it downloads is because the nls use flag is enabled. See my last post where I corrected the problem.

Last edited by rrrssssss; 11-08-2009 at 04:33 PM.
 
Old 11-08-2009, 02:45 PM   #5
rrrssssss
Member
 
Registered: Mar 2005
Posts: 263

Original Poster
Rep: Reputation: 32
Solved

I solved my problem.

A guy named VoidMage helped me in the official Gentoo forum.

I turned off the nls use flag (native language support) for the kde-meta package in /etc/portage/package.use (kde-base/kde-meta -nls)

Now I am just using the default en_US local. Now I don't have to wait 28 hours for all of the language packs to download using my dial-up connection.

All the best,
Roy

Last edited by rrrssssss; 11-08-2009 at 04:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can I make PCLinuxOS skip its setup questions? newbiesforever Linux - Distributions 8 07-08-2007 10:54 PM
KDE 3.5.x packages - order of certain packs. first? hyphae Slackware 9 01-19-2007 08:13 AM
Language packs for Fedora 4 naron Fedora 2 08-18-2005 04:31 AM
Mozilla 1.7.3 - switching between language packs njschroe Linux - Software 0 02-02-2005 05:33 PM
language packs canyon289 Linux - Software 0 11-14-2004 02:35 PM


All times are GMT -5. The time now is 12:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration