LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 04-18-2010, 08:32 AM   #1
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 434

Rep: Reputation: 19
Is Webkit really needed?


Webkit takes forever to compile. If I do not use konquerer, do I really need it?

If not, how do I disable it?

TIA
Jim
 
Old 04-19-2010, 01:53 AM   #2
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Originally Posted by CollieJim View Post
Webkit takes forever to compile. If I do not use konquerer, do I really need it?

If not, how do I disable it?

TIA
Jim
If a package is pulled into the tree it can only be because
  1. you emerged it explicitly, using "emerge package"
  2. or it's a dependency of a package you emerged (world) or a dependency of a system package

Portage doesn't randomly push packages into your system if they are not needed.

Being that said, you made the assumption that konqueror uses webkit, which is wrong unless something important happened the last few days. Konqueror, as far as I know, uses it's own engine, called khtml. khtml is an ancestor of webkit, but it's not quite the same.

You can use "equery d <package_name>" to find what packages are officially depending on a given package (webkit in this case). equery is part of the gentoolkit package, in case you don't have it installed.
 
Old 04-19-2010, 05:40 AM   #3
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 434

Original Poster
Rep: Reputation: 19
Thanks. I'll see what I can find. Bad guess on konquerer.
equery turned up PyQt4-4.7, kdelibs-4/3/5, and kdeplasma-addons-4.3.5.

With USE -webkit, emerge --newuse only wanted to rebuild PyQt4.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Diving into WebKit LXer Syndicated Linux News 0 02-27-2010 11:41 PM
webkit compile error on libsoup borsaman Linux - Software 1 08-17-2009 08:27 AM
LQ and Webkit. Hitboxx LQ Suggestions & Feedback 11 06-27-2009 10:54 AM
WebKit for Linux? LinuxNoob75 Linux - Software 7 02-13-2008 12:22 PM
LXer: WebKit Ported to Qt 4 LXer Syndicated Linux News 0 07-12-2006 06:03 AM


All times are GMT -5. The time now is 11:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration