LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Gentoo (http://www.linuxquestions.org/questions/gentoo-87/)
-   -   How to install using ebuild (http://www.linuxquestions.org/questions/gentoo-87/how-to-install-using-ebuild-888123/)

abdoullah 06-24-2011 09:39 AM

How to install using ebuild
 
Hello everyone,
first I have to say that this is my first time using ebuild, I am trying to install python 2.7 using ebuild script that i got from "http://gentoo-portage.com/dev-lang/python", when i type :
ebuild python-2.7.1-r1.ebuild download or ebuild python-2.7.1-r1.ebuild install it gives me this:
Appending /usr/local to PORTDIR_OVERLAY...
!!! /usr/local/portage/layman/python-2.7.1-r1.ebuild does not seem to have a valid PORTDIR structure

my /etc/make.conf has the following config:
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise"

i tried launching the comand from the three locations but had the exact same error, not sure what the issue is, so please give me some help!

andrewthomas 06-24-2011 02:21 PM

python-2.7.1-r1 is stable in the portage tree

Why did you download the ebuild from gentoo-portage.com?

All you have to do is

Code:

emerge --sync && emerge -av python

abdoullah 06-24-2011 03:05 PM

unfortunately, the command you suggested gave me the following output, matter of fact my portage is out of date and my profile too, that's why I am looking to update python manually so that i can update portage then profile, it's kind of the story of who is first chicken or egg :).

*
* The FEATURES=digest setting can prevent corruption from being noticed.
* The `repoman manifest` command is the preferred way to generate
* manifests and it is capable of doing an entire repository or category at
* once.
*

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-python/python-docs:2.7".
(dependency required by "dev-lang/python-2.7.1-r1" [ebuild])
(dependency required by "python" [argument])


* IMPORTANT: 17 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

andrewthomas 06-24-2011 09:56 PM

post the output of

Code:

eselect python list
and the output of

Code:

emerge -pv python
Quote:

emerge: there are no ebuilds to satisfy "dev-python/python-docs:2.7".
This is not really true, since python-docs-2.7.1 will satisfy the dependency.

Yet, it may be best to remove the doc USE flag from python until you can get things settled.

Add
Code:

dev-lang/python -doc
to /etc/portage/package.use

Then
Code:

env-update && source /etc/profile
and try to emerge python again.

When was the last time that you updated portage and/or world?

abdoullah 06-25-2011 10:57 PM

yes sir, here you go:

eselect python list
!!! Error: Can't load module python
Killed

emerge -pv python

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
hardened/linux/amd64

To upgrade do the following steps:
# Check 'eselect profile list'.
# Find the number that corresponds with the hardened/linux/amd64 profile.
# Use 'eselect profile set <number>' to set a new /etc/make.profile symlink.
#
# Reference: http://www.gentoo.org/doc/en/gentoo-upgrading.xml
# See: "General instructions" in Section 3. "Profile updating instructions"


*
* The FEATURES=digest setting can prevent corruption from being noticed.
* The `repoman manifest` command is the preferred way to generate
* manifests and it is capable of doing an entire repository or category at
* once.
*

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-python/python-docs:2.7".
(dependency required by "dev-lang/python-2.7.1-r1" [ebuild])
(dependency required by "python" [argument])


* IMPORTANT: 17 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

I did that modification and i tried to update python and i got this again:
emerge -pv python

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
hardened/linux/amd64

To upgrade do the following steps:
# Check 'eselect profile list'.
# Find the number that corresponds with the hardened/linux/amd64 profile.
# Use 'eselect profile set <number>' to set a new /etc/make.profile symlink.
#
# Reference: http://www.gentoo.org/doc/en/gentoo-upgrading.xml
# See: "General instructions" in Section 3. "Profile updating instructions"


*
* The FEATURES=digest setting can prevent corruption from being noticed.
* The `repoman manifest` command is the preferred way to generate
* manifests and it is capable of doing an entire repository or category at
* once.
*

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "app-shells/bash-completion" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-shells/bash-completion-1.3 (masked by: EAPI 3)
- app-shells/bash-completion-1.2 (masked by: EAPI 3)

The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "app-admin/eselect-1.2.15" [ebuild])
(dependency required by "app-admin/eselect-python-20100321" [ebuild])
(dependency required by "dev-lang/python-2.7.1-r1" [ebuild])
(dependency required by "python" [argument])


* IMPORTANT: 17 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

portage i think was updated two 1 year ago or more.

andrewthomas 06-25-2011 11:48 PM

I am unclear on what changes you have made.

Did you update your profile?

Try to post the output of

Code:

eselect profile list

abdoullah 06-27-2011 07:42 AM

Hi,
The changes I have made are trying to install python using a tar package, plus your suggestions.
for updating the profile, as I said in a previous reply: my aim is to update portage so that i can update the profile since they say it is very recommended (I don't to miss up the whole sever since it's my first time to do that for gentoo), it's kind of a cycle: u need this package to update portage but u need to update portage to get this package installed, that's why I was looking to put pyhton using ebuild, so back to my original thread, any body knows how to use ebuild script to install python pleaaase?

---------- Post added 06-27-11 at 08:43 AM ----------

yeah, i forgot here the output of the command asked by Andrew:
eselect profile list
Available profile symlink targets:
[1] default/linux/amd64/10.0
[2] default/linux/amd64/10.0/desktop
[3] default/linux/amd64/10.0/desktop/gnome
[4] default/linux/amd64/10.0/desktop/kde
[5] default/linux/amd64/10.0/developer
[6] default/linux/amd64/10.0/no-multilib
[7] default/linux/amd64/10.0/server
[8] hardened/linux/amd64
[9] hardened/linux/amd64/selinux
[10] hardened/linux/amd64/no-multilib
[11] hardened/linux/amd64/no-multilib/selinux
[12] selinux/2007.0/amd64
[13] selinux/2007.0/amd64/hardened
[14] selinux/v2refpolicy/amd64
[15] selinux/v2refpolicy/amd64/desktop
[16] selinux/v2refpolicy/amd64/developer
[17] selinux/v2refpolicy/amd64/hardened
[18] selinux/v2refpolicy/amd64/server

andrewthomas 06-27-2011 11:12 AM

You need to upgrade portage before you can change to a new profile

What is your current version of portage?

equery list '*'|grep sys-apps/portage

You don't need python-2.7 to be able to upgrade portage, you can do it with 2.6.

You probably want to shoot for portage-2.1.9.42

The output of eselect profile list did not show what profile is currently selected

post the output of

Code:

ls -al /etc/make.profile

abdoullah 06-27-2011 11:58 AM

hi,
first of thank you for you patience and commitment
here is the portage version: Portage 2.1.6.13 (hardened/amd64/multilib, gcc-3.4.6, glibc-2.5-r4, 2.6.18-hardened x86_64)
output:
ls -al /etc/make.profile
lrwxrwxrwx 1 root root 45 Mar 9 2007 /etc/make.profile -> /usr/portage/profiles/hardened/amd64/multilib/

but I don't think you're looking for this, actually this is a folder that has the following contents:
-rw-r--r-- 1 root root 345 Nov 25 2010 deprecated
-rw-r--r-- 1 root root 1214 Mar 18 18:31 make.defaults
-rw-r--r-- 1 root root 358 Jul 31 2009 package.mask
-rw-r--r-- 1 root root 3 Apr 17 2007 parent
-rw-r--r-- 1 root root 342 Aug 24 2007 use.mask

do you want me to post any content of any of them?

andrewthomas 06-27-2011 02:04 PM

How about posting

Code:

ls -al /usr/portage/profiles/obsolete/

abdoullah 06-27-2011 03:30 PM

unfortunately:

ls -al /usr/portage/profiles/obsolete/
ls: cannot access /usr/portage/profiles/obsolete/: No such file or directory

:(

andrewthomas 06-27-2011 03:59 PM

What happens if you try to

Code:

emerge -1n portage

abdoullah 06-27-2011 11:12 PM

same thing:
emerge -1n portage

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
hardened/linux/amd64

To upgrade do the following steps:
# Check 'eselect profile list'.
# Find the number that corresponds with the hardened/linux/amd64 profile.
# Use 'eselect profile set <number>' to set a new /etc/make.profile symlink.
#
# Reference: http://www.gentoo.org/doc/en/gentoo-upgrading.xml
# See: "General instructions" in Section 3. "Profile updating instructions"



* IMPORTANT: 17 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

*
* The FEATURES=digest setting can prevent corruption from being noticed.
* The `repoman manifest` command is the preferred way to generate
* manifests and it is capable of doing an entire repository or category at
* once.
*
Calculating dependencies... done!

!!! All ebuilds that could satisfy "app-shells/bash-completion" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-shells/bash-completion-1.3 (masked by: EAPI 3)
- app-shells/bash-completion-1.2 (masked by: EAPI 3)

The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "app-admin/eselect-1.2.15" [ebuild])
(dependency required by "sys-apps/portage-2.1.9.42" [ebuild])
(dependency required by "portage" [argument])


* IMPORTANT: 17 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

andrewthomas 06-28-2011 12:23 AM

You are going to have to manually install portage to enable you to upgrade.

http://www.gentoo.org/proj/en/portag...ng-portage.xml

Then you will be able to update your profile and gcc.

abdoullah 07-01-2011 09:33 AM

thank you for the link, I'll let you know how it goes.


All times are GMT -5. The time now is 09:10 AM.