LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Gentoo (http://www.linuxquestions.org/questions/gentoo-87/)
-   -   How to disable pam verbose? (http://www.linuxquestions.org/questions/gentoo-87/how-to-disable-pam-verbose-934323/)

cristi92b 03-13-2012 09:26 PM

How to disable pam verbose?
 
pam is verbosing after I type the username and before I am prompted for password on tty1. Can you please tell me how can I disable this?

I'm using Gentoo Linux.

ls -l -a /etc/pam.d
Code:

total 156
drwxr-xr-x  2 root root 4096 Mar 14  2012 .
drwxr-xr-x 76 root root 4096 Mar 14 04:15 ..
-rw-r--r--  1 root root  152 Feb 23 13:43 chage
-rw-r--r--  1 root root  152 Feb 23 13:43 chfn
-rw-r--r--  1 root root  144 Feb 23 13:43 chgpasswd
-rw-r--r--  1 root root  144 Feb 23 13:43 chpasswd
-rw-r--r--  1 root root  152 Feb 23 13:43 chsh
-rw-r--r--  1 root root  123 Feb 25 02:22 cron
-rw-r--r--  1 root root  106 Mar 11 19:46 cups
-rw-r--r--  1 root root  274 Feb 26 16:19 gdm
-rw-r--r--  1 root root  369 Feb 26 16:19 gdm-autologin
-rw-r--r--  1 root root  200 Feb 26 16:19 gdmsetup
-rw-r--r--  1 root root  152 Feb 23 13:43 groupadd
-rw-r--r--  1 root root  152 Feb 23 13:43 groupdel
-rw-r--r--  1 root root  103 Feb 23 13:43 groupmems
-rw-r--r--  1 root root  152 Feb 23 13:43 groupmod
-rw-r--r--  1 root root  362 Feb 25 02:22 imap
lrwxrwxrwx  1 root root    4 Feb 25 02:22 imap4 -> imap
lrwxrwxrwx  1 root root    4 Feb 25 02:22 imap4s -> imap
lrwxrwxrwx  1 root root    4 Feb 25 02:22 imaps -> imap
-rw-r--r--  1 root root  190 Feb 23 13:43 login
-rw-r--r--  1 root root  152 Feb 23 13:43 newusers
-rw-r--r--  1 root root  128 Mar 14  2012 other
-rw-r--r--  1 root root  144 Feb 23 13:43 passwd
-rw-r--r--  1 root root  155 Feb 25 07:43 polkit-1
-rw-r--r--  1 root root  362 Feb 25 02:22 pop
lrwxrwxrwx  1 root root    3 Feb 25 02:22 pop3 -> pop
lrwxrwxrwx  1 root root    3 Feb 25 02:22 pop3s -> pop
lrwxrwxrwx  1 root root    3 Feb 25 02:22 pops -> pop
-rw-r--r--  1 root root  135 Feb 25 02:59 ppp
-rw-r--r--  1 root root  160 Feb 25 07:47 saslauthd
-rw-r--r--  1 root root  152 Feb 23 13:43 shadow
-rw-r--r--  1 root root  156 Mar 11 19:59 sshd
-rw-r--r--  1 root root  63 Mar 11 20:37 start-stop-daemon
-rw-r--r--  1 root root 1059 Feb 23 13:43 su
-rw-r--r--  1 root root  135 Feb 25 21:29 sudo
-rw-r--r--  1 root root  512 Mar 14 03:22 system-auth
-rw-r--r--  1 root root  121 Mar 14  2012 system-local-login
-rw-r--r--  1 root root  579 Mar 14 03:59 system-login
-rw-r--r--  1 root root  121 Mar 14  2012 system-remote-login
-rw-r--r--  1 root root  250 Mar 14  2012 system-services
-rw-r--r--  1 root root  152 Feb 23 13:43 useradd
-rw-r--r--  1 root root  152 Feb 23 13:43 userdel
-rw-r--r--  1 root root  152 Feb 23 13:43 usermod
-rw-r--r--  1 root root  77 Feb 25 21:22 xscreensaver


Tinkster 03-14-2012 03:03 PM

Can you give an example of what you mean by "PAM is verbosing"?

If you're on TTY1 chances are you're not only getting PAM but any syslog
messages on the tty?



Cheers,
Tink

cristi92b 03-14-2012 06:07 PM

2 Attachment(s)
Thank you for your answer! See the pictures I uploaded.

Tinkster 03-14-2012 07:45 PM

grep your pam.d for "pam_debug" ...

cristi92b 03-14-2012 08:18 PM

Code:

grep -r "pam_debug" /etc/pam.d
No output

Code:

grep -r -c "pam_debug" /etc/pam.d
Output:

/etc/pam.d/gdm:0
/etc/pam.d/polkit-1:0
/etc/pam.d/pop:0
/etc/pam.d/sshd:0
/etc/pam.d/chage:0
/etc/pam.d/system-remote-login:0
/etc/pam.d/sudo:0
/etc/pam.d/usermod:0
/etc/pam.d/system-auth:0
/etc/pam.d/imap:0
/etc/pam.d/newusers:0
/etc/pam.d/imap4:0
/etc/pam.d/system-login:0
/etc/pam.d/system-local-login:0
/etc/pam.d/start-stop-daemon:0
/etc/pam.d/other:0
/etc/pam.d/cron:0
/etc/pam.d/gdmsetup:0
/etc/pam.d/imaps:0
/etc/pam.d/groupadd:0
/etc/pam.d/userdel:0
/etc/pam.d/groupmems:0
/etc/pam.d/passwd:0
/etc/pam.d/useradd:0
/etc/pam.d/pop3s:0
/etc/pam.d/gdm-autologin:0
/etc/pam.d/imap4s:0
/etc/pam.d/chgpasswd:0
/etc/pam.d/login:0
/etc/pam.d/chsh:0
/etc/pam.d/system-services:0
/etc/pam.d/chpasswd:0
/etc/pam.d/saslauthd:0
/etc/pam.d/xscreensaver:0
/etc/pam.d/shadow:0
/etc/pam.d/groupmod:0
/etc/pam.d/pop3:0
/etc/pam.d/su:0
/etc/pam.d/groupdel:0
/etc/pam.d/chfn:0
/etc/pam.d/pops:0
/etc/pam.d/cups:0
/etc/pam.d/ppp:0

Tinkster 03-14-2012 09:33 PM

Ummm ok - that's odd. I'm moving the thread over to our gentoo forum, maybe
someone there has encountered similar issues.

Tinkster 03-14-2012 09:34 PM

As an aside - does /etc/pam.conf exist?

cristi92b 03-14-2012 10:45 PM

No, there's no /etc/pam.conf

Thank you for your answers and for moving the thread.

i92guboj 03-15-2012 08:00 AM

First thing first, let's see if you emerged sys-auth/pambase and|or sys-libs/pam with USE=debug. If so, disable that flag, and re-emerge those packages.

One word of advice: don't set USE=debug globally. If you need to enable the debug feature, do it on a per-package basis, in /etc/portage/package.use

cristi92b 03-15-2012 12:55 PM

I disabled global USE "debug" flag and re-emerged sys-auth/pambase and sys-libs/pam without the "debug" flag, and now the problem is solved!

Thank you!!!


All times are GMT -5. The time now is 11:45 PM.