LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 05-27-2012, 03:49 PM   #1
fogpipe
Member
 
Registered: Mar 2011
Distribution: Slackware 64 Current
Posts: 328

Rep: Reputation: 77
gnome-mplayer and vlc dbus error wont play video


This happened suddenly about 10 packages into the emerge of kde-meta both gnome-mplayer and vlc were working fine before that. The reason i know the specific point that it happend is that i restarted vlc after changing its output module. This is not vlc specific, any video player gives the same message, here is the error:


Code:
vlc <sometitlehere>.avi
VLC media player 1.1.13 The Luggage (revision exported)
Warning: call to srand(1338150302)
Warning: call to rand()
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x604150] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
Warning: call to srand(1338150302)
Warning: call to rand()
Warning: call to srand(1338150302)
Warning: call to rand()
Warning: call to srand(1338150302)
Warning: call to rand()
Warning: call to srand(1338150302)
Warning: call to rand()
Blocked: call to setlocale(6, "")
Illegal instruction

This is the error from gnome-mplayer:

Code:
gnome-mplayer -v <sometitlehere>.avi
GNOME MPlayer v1.0.5
gmtk v1.0.5
Running with GIO support
Using audio device:
Illegal instruction

alsaplayer works fine, im currently listening to some music. My user belongs to both the audio and video groups and video plays fine when booted to another linux and using the same home directory.
UPDATE: same thing trying to play .flv files
Thanks

EDIT: about the same time the underscore character "_" dissapeared from my terminal font. Not sure if thats related. The underscore character does appear in directory listings but not in what i type at a prompt.

Last edited by fogpipe; 05-27-2012 at 07:32 PM.
 
Old 05-27-2012, 07:36 PM   #2
fogpipe
Member
 
Registered: Mar 2011
Distribution: Slackware 64 Current
Posts: 328

Original Poster
Rep: Reputation: 77
Ok so as near as i can tell, what happened was that polkit-kde made some changes to the dbus config. This may have been due to my stepping on one of the many figurative land mines in the USE flag wilderness. No need to reply to the above post and if mods want to delete it, go ahead. Im done with gentoo so its irrelevant to me now anyway.
 
Old 05-28-2012, 03:06 AM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,036

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
In case you still care, an "Illegal instruction" error is nothing related to what you think.

It's a much lower-level error, which basically means you are trying to run an instruction that your cpu doesn't support. This can be triggered by binaries coming from external repositories that have been compiled for another cpu (even a slightly different one).

In Gentoo, these can appear also because you have set your CFLAGS above what your cpu can run, or because you enabled some optimization via an USE flag, which can be done specially for media players like vlc or mplayer.

A common failure is to enable USE=sse when your cpu doesn't support it, or 3dnow or mmx (well, mmx shouldn't be a problem nowadays...). A more common error is to confuse the ssse3 extension with the regular sse3 one (there's an USE to set that on the mplayer ebuild).
 
Old 05-29-2012, 01:48 AM   #4
fogpipe
Member
 
Registered: Mar 2011
Distribution: Slackware 64 Current
Posts: 328

Original Poster
Rep: Reputation: 77
it turned out to be an interface construction error. clvc worked fine, as did command line mplayer. I installed kde and it repeatedly crashed with dbus errors. Fluxbox rox and alot of other stuff worked ok and the above error appeared when kde was emerging. i didnt change the use flags, vlc just lost the ability to present a gui during the kde emerge. At the same time the console font lost the "_" character. I was a loyal gentoo user up until about 2006 or so but imo its current incarnation is a mess. It reminds of nothing so much as "dll hell" from the windows 95 days. Thanks for the input anyway, but i no longer have a gentoo partition on my hard drive.

EDIT:btw my guess as to what actually was going on is that when kde started installing vlc tried to use a qt4 interface module and the interface crashed for whatever reason kde was crashing. If you look at bugs.gentoo.org kde and dbus dont seem to play well together on gentoo for alot of people.

Last edited by fogpipe; 05-29-2012 at 02:38 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Smallest linux which can play video(xine || mplayer || vlc) PoleStar Linux - Newbie 7 09-14-2010 04:49 PM
IPod wont mount Dbus Error diandoo Linux - Newbie 5 02-08-2010 08:37 AM
Dvd's do not play in VLC, xine, mplayer, or movie play (Karmic) Nizzok Linux - Software 2 01-02-2010 06:12 AM
VLC/mplayer can't play x264 HD-TV capture. large_satchell Linux - Software 1 02-06-2009 06:18 AM
".cam" webcam video -- is there a codec? Can I play it with xine, Mplayer, VLC, ...? ErrorBound Linux - Software 0 07-09-2006 10:44 AM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration