LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2010, 10:31 PM   #1
Secant
LQ Newbie
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 18

Rep: Reputation: 0
GNOME 2.28 NTFS automount permissions problem [SOLVED]


I'm having a few problems getting automounting working after upgrading from GNOME 2.26 to GNOME 2.28. AFAIK automounting used to use HAL and it is now done though policykit. The problem is that the permissions set by policykit are wrong when I automount a USB flash drive. I can't create or delete files/directories on the drive, even though my user is set as the owner and the permissions appear to be set by default to 0700.

At first, automounting didn't work at all. I then modified the file /usr/share/polkit-1/actions/org.freedesktop.devicekit.disks.policy which allowed the drive to be automounted. But, I can't modify the contents of the drive even though I have the appropriate permissions. The exact error I get when trying to create a file is:

Code:
Error while creating file new file.
There was an error creating the directory in /media/rally2.
Error opening file '/media/rally2/new file': Permission denied
Even if I become root, the problem persists: I can't modify the contents of the drive.

Does anybody know what's going on here?

EDIT:
I am ~amd64, but have unmasked sys-fs/udev (now at 151-r4) specifically to get automounting working.

Last edited by Secant; 05-25-2010 at 12:58 PM.
 
Old 05-10-2010, 03:07 AM   #2
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,049

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
If root can't do a thing either then the problem is at a lower level, and not with permissions.

Is it an NTFS volume? If so, your problem is most likely that gnome is using ntfs instead of ntfs-3g to mount it. The regular ntfs driver has very limited support for writing files, and by default it only mounts volumes in read-only mode. I've had a similar problem in the past, what I usually do is to remove the ntfs support from my kernel, then I install ntfs3g and create a file called /etc/udev/rules.d/99-ntfs3g.rules with this contents:

Code:
ENV{ID_FS_TYPE}=="ntfs", ENV{ID_FS_TYPE}="ntfs-3g"
This allows automounting of ntfs volumes for me.

Some days ago, however, the ebuild for ntfs3g-2010.3.6 got a new udev use flag, so you might want to enable that flag and try that version of ntfs3g before. It might work out of the box that way without creating the fules by hand. Haven't tested it.
 
Old 05-11-2010, 12:21 AM   #3
Secant
LQ Newbie
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for the reply, it is an ntfs volume and as I've had issues with ntfs/ntfs-3g before I think you've hit the nail on the head.

When I next switch back to GNOME I'll try your solution and post the results.
 
Old 05-25-2010, 12:57 PM   #4
Secant
LQ Newbie
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
Right, that's done it. I unmasked the latest version of `sys-fs/ntfs3g' and recompiled it with the `udev' USE flag, stopped hald, and now everything works perfectly.

I had to stop hald, otherwise I got a "resource not available" error message when hal tried to mount it while PK was mounting it.

Thanks!
 
  


Reply

Tags
automount, gentoo, gnome


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba automount with full rw permissions... buccaneere Linux - Networking 1 03-26-2009 08:21 AM
how to change automount permissions in Ubuntu mhg Linux - Newbie 6 05-22-2007 09:36 PM
Automount DVD Drive w/ Permissions jerm1701 Linux - General 4 03-02-2006 06:00 PM
automount cd and usb memory in gnome 2.8 testing sarge with gnome-volume-manager gvm pevelius Debian 0 12-20-2004 03:15 AM
Automount permissions Galizah Mandriva 0 05-07-2004 10:58 AM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration